]> git.pld-linux.org Git - packages/Maverik.git/blame - Maverik.spec
- "s-/usr/lib/-%{_libdir}-"
[packages/Maverik.git] / Maverik.spec
CommitLineData
45a08a3b 1Summary: A vr micro-Kernel
2Name: Maverik
3Version: 4.3
4Release: 2
5Copyright: GPL
6Group: Developments/Libraries
fd45442d 7Vendor: Advanced Interfaces Group
a8aaec65 8Source0: ftp://aig.cs.man.ac.uk/pub/aig/Maverik/%{name}-%{version}.tar.gz
45a08a3b 9Source1: MaverikDemos-4.3.tar.gz
10Source2: Maverik-4.3-1.rpm-extras.tgz
11Patch: Maverik-4.3.1-linux.patch
fd45442d 12URL: http://hegel.cs.man.ac.uk/systems/Maverik/
13Buildroot: /tmp/%{name}-%{version}-root
45a08a3b 14
15%description
fd45442d 16GNU Maverik is a framework and library for developing VR applications (it is
17not an end-user application). It provides optimised management of graphics
18and peripheral driving capabilities for a single user. A novel feature of
19GNU MAVERIK is its direct use of the applications own data structures. This
20means significant performance benefits can be achieved through application
21specific optmisations.
45a08a3b 22
23Under GNU/Linux, GNU MAVERIK can use 3DFx VOODOO cards in pairs to drive stereo
24headsets. See the web pages (http://aig.cs.man.ac.uk) for more detail, and
25examples of applications written using GNU MAVERIK.
26
27Examples
28----------
29To run the examples, you will need to set the LD_LIBRARY_PATH to pick up
30the MAVERIK library. i.e.
31
af7c4ddb 32export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:%{_libdir}/Maverik/lib
45a08a3b 33
45a08a3b 34%package demos
fd45442d 35Summary: Maverik Demos
36Group: Developments/libraries
37Requires: %{name} = %{version}
38
45a08a3b 39%description demos
40Maverik demos. AIGLab, EscapeCity and LegibleCity.
41
42%prep
fd45442d 43%setup -q
44%setup -q -T -D -b 1
45%setup -q -T -D -a 2
45a08a3b 46%patch -p 1
47
48%build
49echo "building "
50#export OS_TYPE="Linux"
51#export MAV_HOME=`pwd`
52#source setup_env
53( ./setup --VRML97 --TIFF ; make ; make clean)
54
55#export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${RPM_BUILD_DIR}/Maverik-3.0b4/lib/Linux
56#(cd examples; make)
57
58# dont make examples they need incl and lib paths setting, and those
59# are different between our build and the installed build. Fix that
60# one day. For now a useful test for the user to try.
61#(cd examples ; make ; make clean)
62
63%install
64echo "install"
65
af7c4ddb 66install -d %{_libdir}/Maverik/Maverik-4.3/lib
67(cd lib; cp -pr * %{_libdir}/Maverik/Maverik-4.3/lib)
45a08a3b 68
69# include
af7c4ddb 70install -d %{_libdir}/Maverik/Maverik-4.3/incl
71cp -pr incl %{_libdir}/Maverik/Maverik-4.3
45a08a3b 72
73# examples
af7c4ddb 74cp -pr examples %{_libdir}/Maverik/Maverik-4.3
45a08a3b 75
76# bin
af7c4ddb 77install -d %{_libdir}/Maverik/Maverik-4.3/bin
78install set_mav_vsn %{_libdir}/Maverik/Maverik-4.3/bin
45a08a3b 79
80# src
af7c4ddb 81install -d %{_libdir}/Maverik/Maverik-4.3/src
82cp -pr src %{_libdir}/Maverik/Maverik-4.3
45a08a3b 83
84# demos (stub)
af7c4ddb 85install -d %{_libdir}/Maverik/Maverik-4.3/demos
86cp -pr demos %{_libdir}/Maverik/Maverik-4.3
45a08a3b 87
88# misc for remake
af7c4ddb 89install setup %{_libdir}/Maverik/Maverik-4.3/setup
90install Makefile %{_libdir}/Maverik/Maverik-4.3/Makefile
45a08a3b 91
92# manual
af7c4ddb 93install -d %{_libdir}/Maverik/Maverik-4.3/man/man3
94#install Maverik.3 %{_libdir}/Maverik/Maverik-4.3/man/man3
95cp -pr doc/MFS/man3 %{_libdir}/Maverik/Maverik-4.3/man/
96install set_mav_vsn.3 %{_libdir}/Maverik/Maverik-4.3/man/man3
45a08a3b 97
45a08a3b 98
99%post
af7c4ddb 100%{_libdir}/Maverik/Maverik-4.3/bin/set_mav_vsn -i 4.3
45a08a3b 101echo ""
102echo "Examples"
103echo "----------"
104echo "To run the examples, you will need to set the LD_LIBRARY_PATH to pick up"
105echo "the MAVERIK library. i.e. (using the bash shell)"
106echo ""
af7c4ddb 107echo " export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:%{_libdir}/Maverik/lib"
45a08a3b 108echo ""
109%preun
af7c4ddb 110%{_libdir}/Maverik/Maverik-4.3/bin/set_mav_vsn -e 4.3
111cp %{_libdir}/Maverik/Maverik-4.3/bin/set_mav_vsn /tmp
45a08a3b 112
113$postun
114if [ $1 != 0 ] ;
115then
af7c4ddb 116if [ ! -e %{_libdir}/Maverik/incl ];
45a08a3b 117then
118 /tmp/set_mav_vsn -i newest
119fi
120rm -f /tmp/set_mav_vsn
121fi
fd45442d 122
123%files
af7c4ddb 124#%docdir %{_libdir}/Maverik/Maverik-4.3/man
fd45442d 125%doc README.rpm README INSTALL FAQ VERSIONS COPYING doc/MPG/ps/mpg.ps
126
af7c4ddb 127%dir %{_libdir}/Maverik/Maverik-4.3
128%{_libdir}/Maverik/Maverik-4.3/bin
129%{_libdir}/Maverik/Maverik-4.3/lib
130%{_libdir}/Maverik/Maverik-4.3/incl
131%{_libdir}/Maverik/Maverik-4.3/man
132%{_libdir}/Maverik/Maverik-4.3/examples
133%dir %{_libdir}/Maverik/Maverik-4.3/demos
134%{_libdir}/Maverik/Maverik-4.3/demos/Makefile
135%{_libdir}/Maverik/Maverik-4.3/demos/README
fd45442d 136
137%files demos
af7c4ddb 138%{_libdir}/Maverik/Maverik-4.3/demos/AIGLab
139%{_libdir}/Maverik/Maverik-4.3/demos/EscapeCity
140%{_libdir}/Maverik/Maverik-4.3/demos/LegibleCity
This page took 0.090191 seconds and 4 git commands to generate.