]> git.pld-linux.org Git - packages/Lunchbox.git/blame - Lunchbox.spec
boost rebuild
[packages/Lunchbox.git] / Lunchbox.spec
CommitLineData
7c02bafe
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_with mpi # MPI support
3da0d941 5
7c02bafe
JB
6Summary: Lunchbox - C++ library for multi-threading programming
7Summary(pl.UTF-8): Lunchbox - biblioteka C++ do programowania wielowątkowego
8Name: Lunchbox
7c79b477 9Version: 1.17.0
737d614c 10Release: 8
7c02bafe
JB
11License: LGPL v2.1
12Group: Libraries
7c79b477 13#Source0Download: https://github.com/Eyescale/Lunchbox/releases
7c02bafe 14Source0: https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
7c79b477 15# Source0-md5: 76bcd79003c9b9d58d5f772cfdd812c7
bb2938e8
JP
16Patch0: cxx.patch
17Patch1: nanosleep.patch
7c02bafe 18URL: http://pogl.wordpress.com/category/lunchbox/
7c79b477 19BuildRequires: Eyescale-CMake >= 2018.02
99b90907 20BuildRequires: Servus-devel >= 1.5.0
7c02bafe
JB
21BuildRequires: avahi-devel
22BuildRequires: boost-devel >= 1.41.0
7c79b477 23BuildRequires: cmake >= 3.1
7c02bafe 24%{?with_apidocs:BuildRequires: doxygen}
7c02bafe 25BuildRequires: hwloc-devel >= 1.3
1b7bae68 26BuildRequires: hwloc-devel < 2
7c02bafe
JB
27BuildRequires: libstdc++-devel
28%{?with_mpi:BuildRequires: mpi-devel}
29BuildRequires: pkgconfig
38861d5d 30BuildRequires: rpm-build >= 4.6
b1c97861 31BuildRequires: rpmbuild(macros) >= 1.605
7c79b477 32Requires: Servus >= 1.5.0
7c02bafe 33Requires: hwloc-libs >= 1.3
7c02bafe
JB
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
38formerly known as eq::base or co::base, the foundation for the
39Equalizer parallel rendering framework and the Collage network
40library. It is intended for all application developers creating
41high-performance multi-threaded programs.
42
43%description -l pl.UTF-8
44Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
45była znana jako eq::base lub co::base - podstawa szkieletu do
46renderowania wielowątkowego Equalizer lub biblioteki sieciowej
47Collage. Biblioteka jest przeznaczona dla wszystkich programistów
48tworzących wysoko wydajne, wielowątkowe aplikacje.
49
50%package devel
51Summary: Header files for Lunchbox library
52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Lunchbox
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
7c79b477 55Requires: Servus-devel >= 1.5.0
7c02bafe 56Requires: boost-devel >= 1.41.0
7c02bafe
JB
57Requires: libstdc++-devel
58
59%description devel
60Header files for Lunchbox library.
61
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki Lunchbox.
64
65%package apidocs
66Summary: Lunchbox API documentation
67Summary(pl.UTF-8): Dokumentacja API biblioteki Lunchbox
68Group: Documentation
3da0d941 69BuildArch: noarch
7c02bafe
JB
70
71%description apidocs
72API documentation for Lunchbox library.
73
74%description apidocs -l pl.UTF-8
75Dokumentacja API biblioteki Lunchbox.
76
77%prep
c6de7caf 78%setup -q
7c02bafe 79
7c79b477 80rmdir CMake/common
c6de7caf 81ln -s %{_datadir}/Eyescale-CMake CMake/common
7c02bafe 82
bb2938e8
JP
83%patch0 -p1
84%patch1 -p1
c428797b 85
7c02bafe
JB
86%build
87install -d build
88cd build
89%cmake .. \
87a51c8c 90 -DCOMMON_DISABLE_WERROR:BOOL=ON \
7c79b477
JB
91 %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
92
7c02bafe
JB
93%{__make}
94
95%if %{with apidocs}
96doxygen doc/Doxyfile
97%endif
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102%{__make} -C build install \
103 DESTDIR=$RPM_BUILD_ROOT
104
105%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(644,root,root,755)
c6de7caf 115%doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
7c02bafe 116%attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
7c79b477
JB
117%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
118%dir %{_datadir}/Lunchbox
119%{_datadir}/Lunchbox/benchmarks
7c02bafe
JB
120
121%files devel
122%defattr(644,root,root,755)
123%attr(755,root,root) %{_libdir}/libLunchbox.so
124%{_includedir}/lunchbox
7c02bafe
JB
125%{_datadir}/Lunchbox/CMake
126
127%if %{with apidocs}
128%files apidocs
129%defattr(644,root,root,755)
130%doc build/doc/html/*
131%endif
This page took 0.373563 seconds and 4 git commands to generate.