]> git.pld-linux.org Git - packages/LiTE.git/commitdiff
- added stat patch (fixes build in current environment) auto/ti/LiTE-0_8_10-2
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 1 Jan 2012 10:09:33 +0000 (10:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 2

Changed files:
    LiTE-stat.patch -> 1.1
    LiTE.spec -> 1.12

LiTE-stat.patch [new file with mode: 0644]
LiTE.spec

diff --git a/LiTE-stat.patch b/LiTE-stat.patch
new file mode 100644 (file)
index 0000000..9f6d5c6
--- /dev/null
@@ -0,0 +1,38 @@
+stat already declared as different kind of symbol
+--- LiTE-0.8.10/examples/dfbspy.c.orig 2008-06-21 01:22:49.000000000 +0200
++++ LiTE-0.8.10/examples/dfbspy.c      2012-01-01 11:01:33.872553222 +0100
+@@ -89,9 +89,9 @@
+ /**************************************************************************************************/
+-#define CALC(x)     stat.x = (int)(((s.x - last_stat.x) * 1000 / (float) diff) + 0.5f)
++#define CALC(x)     cur_stat.x = (int)(((s.x - last_stat.x) * 1000 / (float) diff) + 0.5f)
+-static FusionStat last_stat, stat;
++static FusionStat last_stat, cur_stat;
+ static long long  last_millis;
+ static int
+@@ -145,14 +145,14 @@
+      void          (*update)( LiteLabel *label, void *ctx );
+      void           *ctx;
+ } list[] = {
+-     { "lease/purchase", update_number, &stat.lease_purchase },
+-     { "cede",           update_number, &stat.cede },
+-     { "attach",         update_number, &stat.attach },
+-     { "detach",         update_number, &stat.detach },
+-     { "ref up",         update_number, &stat.ref_up },
+-     { "ref down",       update_number, &stat.ref_down },
+-     { "prevail/swoop",  update_number, &stat.prevail_swoop },
+-     { "dismiss",        update_number, &stat.dismiss }
++     { "lease/purchase", update_number, &cur_stat.lease_purchase },
++     { "cede",           update_number, &cur_stat.cede },
++     { "attach",         update_number, &cur_stat.attach },
++     { "detach",         update_number, &cur_stat.detach },
++     { "ref up",         update_number, &cur_stat.ref_up },
++     { "ref down",       update_number, &cur_stat.ref_down },
++     { "prevail/swoop",  update_number, &cur_stat.prevail_swoop },
++     { "dismiss",        update_number, &cur_stat.dismiss }
+ };
+ #define NUM_LIST    (sizeof(list)/sizeof(list[0]))
index 18f45957cb80bd94bd8c0454f2432ae78f1c438f..94d5d2a5c6a1c772ff6d08a6e98395cdd11ae7e2 100644 (file)
--- a/LiTE.spec
+++ b/LiTE.spec
@@ -6,11 +6,12 @@ Summary:      LiTE is a Toolkit Engine
 Summary(pl.UTF-8):     LiTE - silnik toolkitu
 Name:          LiTE
 Version:       0.8.10
-Release:       1
+Release:       2
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://www.directfb.org/downloads/Libs/%{name}-%{version}.tar.gz
 # Source0-md5: b9a28007d38c2b1c51ba1c3841df29ad
+Patch0:                %{name}-stat.patch
 URL:           http://www.directfb.org/index.php?path=Platform/LiTE
 BuildRequires: DirectFB-devel >= 1:1.0.0
 BuildRequires: autoconf >= 2.52
@@ -55,6 +56,7 @@ Statyczna biblioteka LiTE.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
This page took 0.044996 seconds and 4 git commands to generate.