]> git.pld-linux.org Git - packages/LTI-Lib.git/blob - LTI-Lib.spec
- tabs in preamle
[packages/LTI-Lib.git] / LTI-Lib.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx
4 %bcond_with     sse
5 %bcond_with     3dnow
6 %bcond_without  gtk
7
8 Summary:        LTI-Lib - computer vision library
9 Summary(pl.UTF-8):      LTI-Lib - biblioteka do komputerowego przetwarzania obrazów.
10 Name:           LTI-Lib
11 Version:        1.9.8
12 Release:        1
13 License:        LGPL
14 Group:          Development/Libraries
15 Source0:        http://dl.sourceforge.net/ltilib/031124_ltilib-%{version}.tar.bz2
16 # Source0-md5:  dfa6616f3dc5dae04e84311764181b96
17 Patch0:         %{name}-Makefile.patch
18 URL:            http://ltilib.sourceforge.net/doc/homepage/index.shtml
19 BuildRequires:  XFree86-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  doxygen
23 BuildRequires:  gcc-g77
24 BuildRequires:  graphviz
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  tetex-latex-bibtex
29 %if %{with gtk}
30 BuildRequires:  gtk+-devel
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The LTI-Lib is an object oriented library with algorithms and data
36 structures frequently used in image processing and computer vision.
37
38 %description -l pl.UTF-8
39 LTI-Lib jest zorientowaną obiektowo biblioteką zawierającą najczęściej
40 używane algorytmy i struktury danych w procesach przetwarzania i
41 analizy obrazów.
42
43 %package doc
44 Summary:        LTI-Lib - documentation
45 Summary(pl.UTF-8):      LTI-Lib - dokumentacja
46 Group:          Development/Libraries
47
48 %description doc
49 LTI-Lib documentation.
50
51 %description doc -l pl.UTF-8
52 Dokumentacja biblioteki LTI-Lib.
53
54 %prep
55 %setup -q -n ltilib
56 %patch0 -p1
57
58 %build
59 cd doc/styleguide/en
60 %{__make} pdf
61
62 cd ../../../linux
63 %{__aclocal}
64 %{__autoconf}
65 %{__autoheader}
66
67 %ifarch i386
68     _ac_cpu="Generic i386"      ; export _ac_cpu
69     _ac_mmx="no"                ; export _ac_mmx
70     _ac_sse="no"                ; export _ac_sse
71     _ac_3dnow="no"              ; export _ac_3dnow
72 %endif
73
74 %ifarch i486
75     _ac_cpu="Generic i486"      ; export _ac_cpu
76     _ac_mmx="no"                ; export _ac_mmx
77     _ac_sse="no"                ; export _ac_sse
78     _ac_3dnow="no"              ; export _ac_3dnow
79 %endif
80
81 %ifarch i586
82     _ac_cpu="Generic Pentium"   ; export _ac_cpu
83     _ac_mmx="no"                ; export _ac_mmx
84     _ac_sse="no"                ; export _ac_sse
85     _ac_3dnow="no"              ; export _ac_3dnow
86 %endif
87
88 %ifarch i686
89     _ac_cpu="Generic i686"      ; export _ac_cpu
90     _ac_mmx="yes"               ; export _ac_mmx
91     _ac_sse="no"                ; export _ac_sse
92     _ac_3dnow="no"              ; export _ac_3dnow
93 %endif
94
95 %ifarch athlon
96     _ac_cpu="Generic Athlon"    ; export _ac_cpu
97     _ac_mmx="yes"               ; export _ac_mmx
98     _ac_sse="no"                ; export _ac_sse
99     _ac_3dnow="yes"             ; export _ac_3dnow
100 %endif
101
102 %if %{with mmx}
103     _ac_mmx="yes"               ; export _ac_mmx
104 %endif
105
106 %if %{with sse}
107     _ac_sse="yes"               ; export _ac_sse
108 %endif
109
110 %if %{with 3dnow}
111     _ac_3dnow="yes"             ; export _ac_3dnow
112 %endif
113
114 %configure \
115 %if !%{with gtk}
116         --without-gtk \
117 %endif
118         --disable-debug
119
120 %{__make} doxydoc
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc
127
128 cp doc/html/*.html      $RPM_BUILD_ROOT%{_docdir}/%{name}-doc
129 cp doc/html/*.png       $RPM_BUILD_ROOT%{_docdir}/%{name}-doc
130 cp doc/html/*.gif       $RPM_BUILD_ROOT%{_docdir}/%{name}-doc
131
132 cd linux
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 rm -f $RPM_BUILD_ROOT%{_prefix}/lib/ltilib
137 rm -f $RPM_BUILD_ROOT%{_includedir}/ltilib
138
139 cd $RPM_BUILD_ROOT%{_prefix}/lib
140 ln -s ltilib-%{version} ltilib
141 cd $RPM_BUILD_ROOT%{_includedir}
142 ln -s ltilib-%{version} ltilib
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %doc README doc/styleguide/en/*.pdf
150 %attr(755,root,root) %{_bindir}/*
151 %{_includedir}/ltilib
152 %{_includedir}/ltilib-%{version}
153 %{_libdir}/ltilib
154 %{_libdir}/ltilib-%{version}
155
156 %files doc
157 %defattr(644,root,root,755)
158 %{_docdir}/%{name}-doc
This page took 0.104565 seconds and 3 git commands to generate.