]> git.pld-linux.org Git - packages/Insignia.git/commitdiff
- updated to 1.0.4 master
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 1 Apr 2014 19:40:14 +0000 (21:40 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 1 Apr 2014 19:40:14 +0000 (21:40 +0200)
- added c++ patch (fixes C++11 issue)

Insignia-c++.patch [new file with mode: 0644]
Insignia.spec

diff --git a/Insignia-c++.patch b/Insignia-c++.patch
new file mode 100644 (file)
index 0000000..563da4e
--- /dev/null
@@ -0,0 +1,11 @@
+--- Insignia-1.0.4/lib/InsigniaUtil.cpp.orig   2014-03-17 18:07:05.000000000 +0100
++++ Insignia-1.0.4/lib/InsigniaUtil.cpp        2014-04-01 21:06:37.307785370 +0200
+@@ -569,7 +569,7 @@
+      if (&rect != &noRect) {
+           if (!dfb_rectangle_intersect( &r, &rect )) {
+                throw new Exception( Direct::String::F( 
+-                    "PixelBuffer::dump: No intersection ["DFB_RECT_FORMAT" vs "DFB_RECT_FORMAT"] writing to '%s'!",
++                    "PixelBuffer::dump: No intersection [" DFB_RECT_FORMAT " vs " DFB_RECT_FORMAT "] writing to '%s'!",
+                     DFB_RECTANGLE_VALS(&rect), DFB_RECTANGLE_VALS(&r), filename.buffer() ) );
+           }
+      }
index aa1e9809ee3cb37b9d0bdc02feb00d01a1d014d5..889a7af56dd7d83d9d800752b80f19e768a12f63 100644 (file)
@@ -1,12 +1,13 @@
 Summary:       Insignia - DirectFB conformance test suite
 Summary(pl.UTF-8):     Insignia - zbiór testów zgodności DirectFB
 Name:          Insignia
-Version:       1.0.2
+Version:       1.0.4
 Release:       1
 License:       proprietary
 Group:         Libraries
 Source0:       http://www.directfb.org/downloads/Extras/%{name}-%{version}.tar.gz
-# NoSource0-md5:       09103054a3a97fceb079869ad8811b8d
+# NoSource0-md5:       b16fdcbd9307710bda138223fba0a749
+Patch0:                %{name}-c++.patch
 NoSource:      0
 URL:           http://www.directfb.org/
 BuildRequires: DirectFB-c++-devel >= 1:1.2.0
@@ -27,6 +28,7 @@ Insignia - zbiór testów zgodności DirectFB.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -60,7 +62,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/Insignia
 %attr(755,root,root) %{_bindir}/InsigniaRun
 %attr(755,root,root) %{_libdir}/libinsignia-1.0.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libinsignia-1.0.so.2
+%attr(755,root,root) %ghost %{_libdir}/libinsignia-1.0.so.4
 %dir %{_libdir}/Insignia
 %attr(755,root,root) %{_libdir}/Insignia/DFBTest*.Io
 %{_datadir}/Insignia
This page took 0.072906 seconds and 4 git commands to generate.