]> git.pld-linux.org Git - packages/InDependence.git/blame - InDependence.spec
- cflags, and therefore not noarch
[packages/InDependence.git] / InDependence.spec
CommitLineData
0113a9aa
ER
1Summary: RPM Dependency Tracker
2Name: InDependence
3Version: 1.0
4Release: 1
5Group: Applications/System
6Source0: %{name}_%{version}.tar.gz
7# Source0-md5: df419e1443683305891060985f723902
0a885a22 8Patch0: %{name}-rpmlib.patch
0113a9aa
ER
9License: Artistic License
10URL: http://www.cse.ogi.edu/DISC/projects/independence/
0113a9aa
ER
11BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13%description
14InDependence is a suite of tools (well two :-) designed to help RPM
15packagers and system administrators deal with the dependencies between
16RPM packages. InDependence has two major components:
17
18Dep: This tool is for the RPM packager that identifies external files
19or RPM packages that a program uses.
20
21RPMTC: "RPM Transitive Closure". This tool is for the RPM system
22administrator. "rpmtc foo.rpm" will transitively compute the -
23- *entire* set of RPMs necessary to support the foo.rpm package, i.e.
24 if foo.rpm depends on bar.rpm, and bar.rpm depends on baz.rpm, RPMTC
25 will report both bar and baz.
26
27%prep
28%setup -q -n %{name}_%{version}
29%patch0 -p1
30
31%build
0a885a22
ER
32%{__make} \
33 CC="%{__cc}"
34 CFLAGS="%{rpmcflags}" \
35 LDFLAGS="%{rpmldflags}"
0113a9aa
ER
36
37%install
38rm -rf $RPM_BUILD_ROOT
39install -d ${RPM_BUILD_ROOT}%{_bindir}
40install dep/dep ${RPM_BUILD_ROOT}%{_bindir}/dep
41install dep/swrapper.pl ${RPM_BUILD_ROOT}%{_bindir}/swrapper.pl
42install rpmtc/rpmtc ${RPM_BUILD_ROOT}%{_bindir}/rpmtc
43install rpmtc/rpmdep-pipe ${RPM_BUILD_ROOT}%{_bindir}/rpmdep-pipe
44install -d ${RPM_BUILD_ROOT}%{_mandir}/man1
45install dep/dep.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/dep.1
46install rpmtc/rpmtc.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/rpmtc.1
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(644,root,root,755)
53%doc README
54%attr(755,root,root) %{_bindir}/dep
55%attr(755,root,root) %{_bindir}/rpmdep-pipe
56%attr(755,root,root) %{_bindir}/rpmtc
57%attr(755,root,root) %{_bindir}/swrapper.pl
58%{_mandir}/man1/dep.1*
59%{_mandir}/man1/rpmtc.1*
This page took 0.059302 seconds and 4 git commands to generate.