]> git.pld-linux.org Git - packages/IRRToolSet.git/commitdiff
- new
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 3 Nov 2005 10:37:38 +0000 (10:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    IRRToolSet-build-all.patch -> 1.1
    NE.cc-20040805.patch -> 1.1

IRRToolSet-build-all.patch [new file with mode: 0644]
NE.cc-20040805.patch [new file with mode: 0644]

diff --git a/IRRToolSet-build-all.patch b/IRRToolSet-build-all.patch
new file mode 100644 (file)
index 0000000..95fd61f
--- /dev/null
@@ -0,0 +1,28 @@
+#! /bin/sh -e
+# patch by danchev@spnet.net
+
+if [ $# -ne 1 ]; then
+    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+    exit 1
+fi
+case "$1" in
+    -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
+    -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
+    *)
+       echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+       exit 1;;
+esac
+
+exit 0
+
+--- IRRToolSet-4.8.2.orig/src/Makefile.in      2005-04-16 11:54:09.614748239 +0300
++++ IRRToolSet-4.8.2/src/Makefile.in   2005-04-16 11:46:48.631288751 +0300
+@@ -16,7 +16,7 @@
+ LIBDIRS =  util gnug++ irr re2dfa normalform bgp Core rpsl
+ #TOOLDIRS = rpslcheck peval RtConfig roe prpath prtraceroute CIDRAdvisor aoe
+-TOOLDIRS = rpslcheck peval RtConfig #roe prpath prtraceroute CIDRAdvisor aoe
++TOOLDIRS = rpslcheck peval RtConfig roe prpath prtraceroute CIDRAdvisor aoe
+ SUBDIRS = $(LIBDIRS) $(TOOLDIRS)
+ # programs
diff --git a/NE.cc-20040805.patch b/NE.cc-20040805.patch
new file mode 100644 (file)
index 0000000..78c3e76
--- /dev/null
@@ -0,0 +1,20 @@
+diff -Naur IRRToolSet-original/src/normalform/NE.cc IRRToolSet/src/normalform/NE.cc
+--- IRRToolSet-original/src/normalform/NE.cc  2004-08-05 11:21:20.000000000 +0200
++++ IRRToolSet/src/normalform/NE.cc 2004-08-05 11:13:37.000000000 +0200
+@@ -1,4 +1,4 @@
+-//  $Id$
++//  $Id$
+ // Copyright (c) 2001,2002                        RIPE NCC
+ //
+ // All Rights Reserved
+@@ -355,7 +355,9 @@
+    if (typeid(*ptree) == typeid(FilterAFI)) {
+
+       ne = evaluate(((FilterAFI *) ptree)->f, peerAS, expand);
+-      ne->restrict((FilterAFI *) ptree);
++      if ((ne->singleton_flag == NormalTerm::PRFX) || 
++        (ne->singleton_flag == NormalTerm::IPV6_PRFX))
++        ne->restrict((FilterAFI *) ptree);
+       Debug(Channel(DBG_NOT) << "op1: " << *ne << "\n");
+       Debug(Channel(DBG_NOT) << "afi: " << *ne << "\n");
+       return ne;
This page took 0.071407 seconds and 4 git commands to generate.