]> git.pld-linux.org Git - packages/Glide_V5-DRI.git/commitdiff
- added gcc4 and no_redefine_macro patches (based on Debian patches), updated cpp...
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 8 Jan 2012 11:01:32 +0000 (11:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated to use modern xorg instead of X11R6
- rel 12

Changed files:
    Glide_V5-DRI.spec -> 1.29
    glide-gcc4.patch -> 1.1
    glide-no_redefine_macro.patch -> 1.1

Glide_V5-DRI.spec
glide-gcc4.patch [new file with mode: 0644]
glide-no_redefine_macro.patch [new file with mode: 0644]

index 0e186fb4c7120708f03d0f4eb5a4cb46ad237743..dc53caf6e82f4ca118234fc3e98ff2e6b7b8f06a 100644 (file)
@@ -1,13 +1,13 @@
 %define snapdate 20010309
+%define        rel     12
 Summary:       Glide runtime for 3Dfx Voodoo4 and Voodoo5 boards
 Summary(ko.UTF-8):     3Dfx 부두 벤쉬/3 비디오카드용 Glide 런타임 라이브러리
 Summary(pl.UTF-8):     Biblioteki Glide dla kart 3Dfx Voodoo4 i Voodoo5
 Name:          Glide_V5-DRI
 Version:       3.10.0
-Release:       0.%{snapdate}.11
+Release:       0.%{snapdate}.%{rel}
 Epoch:         1
 License:       3dfx Glide General Public License, 3Dfx Interactive Inc.
-Vendor:                3dfx Interactive Inc.
 Group:         X11/Libraries
 Source0:       cvs://anonymous@cvs.glide.sourceforge.net:/cvsroot/glide/glide3x-%{snapdate}.tar.gz
 # Source0-md5: 42a8e093221b2360ec96191ae0e13ce0
@@ -19,14 +19,19 @@ Patch4:             glide-am16.patch
 Patch5:                glide-gcc33.patch
 Patch6:                glide-ioctl.patch
 Patch7:                glide-morearchs.patch
+Patch8:                glide-gcc4.patch
+Patch9:                glide-no_redefine_macro.patch
 URL:           http://glide.sourceforge.net/
-BuildRequires: XFree86-devel
-BuildRequires: automake
 BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: libtool
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXext-devel
+BuildRequires: xorg-lib-libXxf86dga-devel
+BuildRequires: xorg-lib-libXxf86vm-devel
 Provides:      Glide3-DRI
 Obsoletes:     Glide_V3-DRI
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 This library allows the user to use a 3dfx Interactive Voodoo4 or
@@ -82,6 +87,8 @@ Voodoo5.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p2
+%patch9 -p1
 
 %build
 %{__libtoolize}
@@ -96,11 +103,11 @@ Voodoo5.
        --enable-amd3d
 %endif
 
-%{__make} -f makefile.autoconf all \
+%{__make} -j1 -f makefile.autoconf all \
        GLIDE_DEBUG_GCFLAGS="%{rpmcflags} -fno-expensive-optimizations %{!?debug:-fomit-frame-pointer -ffast-math}" \
        GLIDE_DEBUG_GDEFS="%{!?debug:-DBIG_OPT} %{?debug:-DGDBG_INFO_ON -DGLIDE_DEBUG}" \
-       LINK_LIBS="-L/usr/X11R6/%{_lib} -lX11 -lXext -lXxf86dga -lXxf86vm -lm" \
-       PREPROCESSOR='cpp -$$ -I.'
+       LINK_LIBS="-lX11 -lXext -lXxf86dga -lXxf86vm -lm" \
+       PREPROCESSOR='cpp -I. -x assembler-with-cpp'
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -110,6 +117,7 @@ install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/tests
 %{__make} -f makefile.autoconf install \
        GLIDE_DEBUG_GCFLAGS="%{rpmcflags} -fno-expensive-optimizations %{!?debug:-fomit-frame-pointer -ffast-math}" \
        GLIDE_DEBUG_GDEFS="%{!?debug:-DBIG_OPT} %{?debug:-DGDBG_INFO_ON -DGLIDE_DEBUG}" \
+       LINK_LIBS="-lX11 -lXext -lXxf86dga -lXxf86vm -lm" \
        DESTDIR=$RPM_BUILD_ROOT
 
 # used by tdfx_dri.so from XFree86
@@ -136,6 +144,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc glide_license.txt
 %attr(755,root,root) %{_libdir}/libglide3.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libglide3.so.3
 %attr(755,root,root) %{_libdir}/libglide3-v5.so
 %attr(755,root,root) %{_libdir}/libglide3x.so
 %attr(755,root,root) %{_libdir}/libglide3x_V5.so
@@ -143,10 +152,10 @@ rm -rf $RPM_BUILD_ROOT
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libglide3.so
-%{_libdir}/lib*.la
+%{_libdir}/libglide3.la
 %{_includedir}/glide3
 %{_examplesdir}/%{name}-%{version}
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libglide3.a
diff --git a/glide-gcc4.patch b/glide-gcc4.patch
new file mode 100644 (file)
index 0000000..ded58c2
--- /dev/null
@@ -0,0 +1,439 @@
+Status: applied
+
+Index: b/glide3x/h3/glide3/src/gaa.c
+===================================================================
+--- a/glide3x/h3/glide3/src/gaa.c
++++ b/glide3x/h3/glide3/src/gaa.c
+@@ -616,7 +616,7 @@ _grAADrawPoints(FxI32 mode, FxI32 count,
+       e = pointers;
+       if (mode)
+         e = *(float **)e;
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       
+       ptX = FARRAY(e, gc->state.vData.vertexInfo.offset);
+       ptY = FARRAY(e, gc->state.vData.vertexInfo.offset+4);
+@@ -717,7 +717,7 @@ _grAADrawPoints(FxI32 mode, FxI32 count,
+       if (mode)
+         e = *(float **)e;
+       oow = 1.0f / FARRAY(e, gc->state.vData.wInfo.offset);        
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       
+       ptX = FARRAY(e, gc->state.vData.vertexInfo.offset)
+         *oow*gc->state.Viewport.hwidth+gc->state.Viewport.ox;
+@@ -842,9 +842,9 @@ _grAADrawLineStrip(FxI32 mode, FxI32 lty
+         v1 = *(float **)v1;
+         v2 = *(float **)v2;
+       }
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       if (ltype == GR_LINES)
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+       
+       /* draw from low Y to high Y */
+       if (FARRAY(v2, gc->state.vData.vertexInfo.offset+4) < FARRAY(v1, gc->state.vData.vertexInfo.offset+4)) {
+@@ -1023,9 +1023,9 @@ _grAADrawLineStrip(FxI32 mode, FxI32 lty
+           v1 = *(float **)v1;
+           v2 = *(float **)v2;
+         }
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         if (ltype == GR_LINES)
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+         owa = oowa = 1.0f / FARRAY(v1, gc->state.vData.wInfo.offset);
+         owb = oowb = 1.0f / FARRAY(v2, gc->state.vData.wInfo.offset);
+       }
+@@ -1037,7 +1037,7 @@ _grAADrawLineStrip(FxI32 mode, FxI32 lty
+           v1 = *(float **)v1;
+           v2 = *(float **)v2;
+         }
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         owb = oowb = 1.0f / FARRAY(v2, gc->state.vData.wInfo.offset);
+       }
+       
+@@ -1373,7 +1373,7 @@ _grAADrawTriangles(FxI32 mode, FxI32 tty
+       b = *(float **)b;
+       c = *(float **)c;
+     }
+-    (float *)pointers += stride*3;
++    pointers = (float *)pointers + stride*3;
+     /* move culling test to here */
+     {
+@@ -1549,7 +1549,7 @@ _grAAVpDrawTriangles(FxI32 mode, FxI32 t
+       b = *(float **)b;
+       c = *(float **)c;
+     }
+-    (float *)pointers += stride*3;
++    pointers = (float *)pointers + stride*3;
+     oowa = 1.0f / FARRAY(a, gc->state.vData.wInfo.offset);        
+     oowb = 1.0f / FARRAY(b, gc->state.vData.wInfo.offset);        
+     oowc = 1.0f / FARRAY(c, gc->state.vData.wInfo.offset);        
+@@ -1716,7 +1716,7 @@ _grAADrawVertexList(FxU32 type, FxI32 mo
+   if (type == kSetupFan) {
+     v[0] = (mode == 0) ? pointers : *(float **)pointers;
+     while (sCount--) {
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       if (mode) {
+         v[1] = *(float **)pointers;
+         v[2] = *((float **)pointers+1);
+@@ -1758,7 +1758,7 @@ _grAADrawVertexList(FxU32 type, FxI32 mo
+         _grAADrawTriangles(1, type, 3, v);
+       else
+         _grAAVpDrawTriangles(1, type, 3, v);    
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       flip = ~flip;
+     }
+     flip = ~flip;
+Index: b/glide3x/h3/glide3/src/gdraw.c
+===================================================================
+--- a/glide3x/h3/glide3/src/gdraw.c
++++ b/glide3x/h3/glide3/src/gdraw.c
+@@ -402,7 +402,7 @@ _grDrawPoints(FxI32 mode, FxI32 count, v
+         vPtr = pointers;
+         if (mode) vPtr = *(float **)vPtr;
+         
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         GDBG_INFO_MORE(gc->myLevel, "(%f %f)\n",  
+                        FARRAY(vPtr,gc->state.vData.vertexInfo.offset), 
+@@ -491,7 +491,7 @@ _grDrawPoints(FxI32 mode, FxI32 count, v
+         if (mode)
+           vPtr = *(float **)vPtr;
+         oow = 1.0f / FARRAY(vPtr, gc->state.vData.wInfo.offset);        
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         {
+           FxU32 x, y;
+@@ -616,9 +616,9 @@ _grDrawLineStrip(FxI32 mode, FxI32 ltype
+           a = *(float **)a;
+           b = *(float **)b;
+         }
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         if (ltype == GR_LINES)
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+         
+         /*
+         ** compute absolute deltas and draw from low Y to high Y
+@@ -778,10 +778,10 @@ _grDrawLineStrip(FxI32 mode, FxI32 ltype
+             a = *(float **)a;
+             b = *(float **)b;
+           }
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+           owa = oowa = 1.0f / FARRAY(a, gc->state.vData.wInfo.offset);        
+           owb = oowb = 1.0f / FARRAY(b, gc->state.vData.wInfo.offset);        
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+         }
+         else {
+           owa = oowa = oowb;
+@@ -791,7 +791,7 @@ _grDrawLineStrip(FxI32 mode, FxI32 ltype
+             a = *(float **)a;
+             b = *(float **)b;
+           }
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+           owb = oowb = 1.0f / FARRAY(b, gc->state.vData.wInfo.offset);
+         }
+         fay = tmp1 = FARRAY(a, gc->state.vData.vertexInfo.offset+4)
+@@ -944,7 +944,7 @@ _grDrawTriangles_Default(FxI32 mode, FxI
+         vPtr = pointers;
+         if (mode)
+           vPtr = *(float **)vPtr;
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         i = gc->tsuDataList[dataElem];
+         
+@@ -984,7 +984,7 @@ _grDrawTriangles_Default(FxI32 mode, FxI
+                  *oow*gc->state.Viewport.hwidth + gc->state.Viewport.ox);
+         TRI_SETF(FARRAY(vPtr, 4)
+                  *oow*gc->state.Viewport.hheight + gc->state.Viewport.oy);
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         TRI_VP_SETFS(vPtr,oow);
+       }
+Index: b/glide3x/h3/glide3/src/gstrip.c
+===================================================================
+--- a/glide3x/h3/glide3/src/gstrip.c
++++ b/glide3x/h3/glide3/src/gstrip.c
+@@ -190,7 +190,7 @@ _grDrawVertexList(FxU32 pktype, FxU32 ty
+         vPtr = pointers;
+         if (mode)
+           vPtr = *(float **)vPtr;
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         TRI_SETF(FARRAY(vPtr, 0));
+         dataElem = 0;
+@@ -230,7 +230,7 @@ _grDrawVertexList(FxU32 pktype, FxU32 ty
+                  *oow*gc->state.Viewport.hwidth + gc->state.Viewport.ox);
+         TRI_SETF(FARRAY(vPtr, 4)
+                  *oow*gc->state.Viewport.hheight + gc->state.Viewport.oy);
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         TRI_VP_SETFS(vPtr, oow);
+       }
+Index: b/glide3x/h3/glide3/src/distrip.c
+===================================================================
+--- a/glide3x/h3/glide3/src/distrip.c
++++ b/glide3x/h3/glide3/src/distrip.c
+@@ -450,7 +450,7 @@ GR_DIENTRY(grDrawVertexArray, void , (Fx
+     else {
+       while ((int)Count >= 3) {
+         grDrawTriangle(*(float **)pointers, *((float **)pointers+1), *((float **)pointers+2));
+-        (float *)pointers += 3;
++        pointers = (float *)pointers + 3;
+         Count -= 3;
+       }
+     }
+Index: b/glide3x/h5/glide3/src/gaa.c
+===================================================================
+--- a/glide3x/h5/glide3/src/gaa.c
++++ b/glide3x/h5/glide3/src/gaa.c
+@@ -628,7 +628,7 @@ _grAADrawPoints(FxI32 mode, FxI32 count,
+       e = pointers;
+       if (mode)
+         e = *(float **)e;
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       
+       ptX = FARRAY(e, gc->state.vData.vertexInfo.offset);
+       ptY = FARRAY(e, gc->state.vData.vertexInfo.offset+4);
+@@ -729,7 +729,7 @@ _grAADrawPoints(FxI32 mode, FxI32 count,
+       if (mode)
+         e = *(float **)e;
+       oow = 1.0f / FARRAY(e, gc->state.vData.wInfo.offset);        
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       
+       ptX = FARRAY(e, gc->state.vData.vertexInfo.offset)
+         *oow*gc->state.Viewport.hwidth+gc->state.Viewport.ox;
+@@ -856,9 +856,9 @@ _grAADrawLineStrip(FxI32 mode, FxI32 lty
+         v1 = *(float **)v1;
+         v2 = *(float **)v2;
+       }
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       if (ltype == GR_LINES)
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+       
+       /* draw from low Y to high Y */
+       if (FARRAY(v2, gc->state.vData.vertexInfo.offset+4) < FARRAY(v1, gc->state.vData.vertexInfo.offset+4)) {
+@@ -1037,9 +1037,9 @@ _grAADrawLineStrip(FxI32 mode, FxI32 lty
+           v1 = *(float **)v1;
+           v2 = *(float **)v2;
+         }
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         if (ltype == GR_LINES)
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+         owa = oowa = 1.0f / FARRAY(v1, gc->state.vData.wInfo.offset);
+         owb = oowb = 1.0f / FARRAY(v2, gc->state.vData.wInfo.offset);
+       }
+@@ -1051,7 +1051,7 @@ _grAADrawLineStrip(FxI32 mode, FxI32 lty
+           v1 = *(float **)v1;
+           v2 = *(float **)v2;
+         }
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         owb = oowb = 1.0f / FARRAY(v2, gc->state.vData.wInfo.offset);
+       }
+       
+@@ -1391,7 +1391,7 @@ _grAADrawTriangles(FxI32 mode, FxI32 tty
+       b = *(float **)b;
+       c = *(float **)c;
+     }
+-    (float *)pointers += stride*3;
++    pointers = (float *)pointers + stride*3;
+     /* move culling test to here */
+     {
+@@ -1567,7 +1567,7 @@ _grAAVpDrawTriangles(FxI32 mode, FxI32 t
+       b = *(float **)b;
+       c = *(float **)c;
+     }
+-    (float *)pointers += stride*3;
++    pointers = (float *)pointers + stride*3;
+     oowa = 1.0f / FARRAY(a, gc->state.vData.wInfo.offset);        
+     oowb = 1.0f / FARRAY(b, gc->state.vData.wInfo.offset);        
+     oowc = 1.0f / FARRAY(c, gc->state.vData.wInfo.offset);        
+@@ -1734,7 +1734,7 @@ _grAADrawVertexList(FxU32 type, FxI32 mo
+   if (type == kSetupFan) {
+     v[0] = (mode == 0) ? pointers : *(float **)pointers;
+     while (sCount--) {
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       if (mode) {
+         v[1] = *(float **)pointers;
+         v[2] = *((float **)pointers+1);
+@@ -1776,7 +1776,7 @@ _grAADrawVertexList(FxU32 type, FxI32 mo
+         _grAADrawTriangles(1, type, 3, v);
+       else
+         _grAAVpDrawTriangles(1, type, 3, v);    
+-      (float *)pointers += stride;
++      pointers = (float *)pointers + stride;
+       flip = ~flip;
+     }
+     flip = ~flip;
+Index: b/glide3x/h5/glide3/src/gdraw.c
+===================================================================
+--- a/glide3x/h5/glide3/src/gdraw.c
++++ b/glide3x/h5/glide3/src/gdraw.c
+@@ -472,7 +472,7 @@ _grDrawPoints(FxI32 mode, FxI32 count, v
+         vPtr = pointers;
+         if (mode) vPtr = *(float **)vPtr;
+         
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         GDBG_INFO_MORE(gc->myLevel, "(%f %f)\n",  
+                        FARRAY(vPtr,gc->state.vData.vertexInfo.offset), 
+@@ -554,7 +554,7 @@ _grDrawPoints(FxI32 mode, FxI32 count, v
+         vPtr = pointers;
+         if (mode) vPtr = *(float **)vPtr;
+         
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         GDBG_INFO_MORE(gc->myLevel, "(%f %f)\n",  
+                        FARRAY(vPtr,gc->state.vData.vertexInfo.offset), 
+@@ -665,7 +665,7 @@ _grDrawPoints(FxI32 mode, FxI32 count, v
+         if (mode)
+           vPtr = *(float **)vPtr;
+         oow = 1.0f / FARRAY(vPtr, gc->state.vData.wInfo.offset);        
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         {        
+           float fx, fy;
+@@ -802,9 +802,9 @@ _grDrawLineStrip(FxI32 mode, FxI32 ltype
+           a = *(float **)a;
+           b = *(float **)b;
+         }
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         if (ltype == GR_LINES)
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+         
+         /*
+         ** compute absolute deltas and draw from low Y to high Y
+@@ -964,10 +964,10 @@ _grDrawLineStrip(FxI32 mode, FxI32 ltype
+             a = *(float **)a;
+             b = *(float **)b;
+           }
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+           owa = oowa = 1.0f / FARRAY(a, gc->state.vData.wInfo.offset);        
+           owb = oowb = 1.0f / FARRAY(b, gc->state.vData.wInfo.offset);        
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+         }
+         else {
+           owa = oowa = oowb;
+@@ -977,7 +977,7 @@ _grDrawLineStrip(FxI32 mode, FxI32 ltype
+             a = *(float **)a;
+             b = *(float **)b;
+           }
+-          (float *)pointers += stride;
++          pointers = (float *)pointers + stride;
+           owb = oowb = 1.0f / FARRAY(b, gc->state.vData.wInfo.offset);
+         }
+         fay = tmp1 = FARRAY(a, gc->state.vData.vertexInfo.offset+4)
+@@ -1125,7 +1125,7 @@ _grDrawTriangles_Default(FxI32 mode, FxI
+         vPtr = pointers;
+         if (mode)
+           vPtr = *(float **)vPtr;
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         i = gc->tsuDataList[dataElem];
+         
+@@ -1165,7 +1165,7 @@ _grDrawTriangles_Default(FxI32 mode, FxI
+                  *oow*gc->state.Viewport.hwidth + gc->state.Viewport.ox);
+         TRI_SETF(FARRAY(vPtr, 4)
+                  *oow*gc->state.Viewport.hheight + gc->state.Viewport.oy);
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         TRI_VP_SETFS(vPtr,oow);
+       }
+Index: b/glide3x/h5/glide3/src/gstrip.c
+===================================================================
+--- a/glide3x/h5/glide3/src/gstrip.c
++++ b/glide3x/h5/glide3/src/gstrip.c
+@@ -214,7 +214,7 @@ _grDrawVertexList(FxU32 pktype, FxU32 ty
+         vPtr = pointers;
+         if (mode)
+           vPtr = *(float **)vPtr;
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         
+         TRI_SETF(FARRAY(vPtr, 0));
+         dataElem = 0;
+@@ -254,7 +254,7 @@ _grDrawVertexList(FxU32 pktype, FxU32 ty
+                  *oow*gc->state.Viewport.hwidth + gc->state.Viewport.ox);
+         TRI_SETF(FARRAY(vPtr, 4)
+                  *oow*gc->state.Viewport.hheight + gc->state.Viewport.oy);
+-        (float *)pointers += stride;
++        pointers = (float *)pointers + stride;
+         TRI_VP_SETFS(vPtr, oow);
+       }
+Index: b/glide3x/h5/glide3/src/distrip.c
+===================================================================
+--- a/glide3x/h5/glide3/src/distrip.c
++++ b/glide3x/h5/glide3/src/distrip.c
+@@ -458,7 +458,7 @@ GR_DIENTRY(grDrawVertexArray, void , (Fx
+     else {
+       while ((int)Count >= 3) {
+         grDrawTriangle(*(float **)pointers, *((float **)pointers+1), *((float **)pointers+2));
+-        (float *)pointers += 3;
++        pointers = (float *)pointers + 3;
+         Count -= 3;
+       }
+     }
+Index: b/glide3x/h5/glide3/src/glfb.c
+===================================================================
+--- a/glide3x/h5/glide3/src/glfb.c
++++ b/glide3x/h5/glide3/src/glfb.c
+@@ -1333,8 +1333,10 @@ GR_ENTRY(grLfbReadRegion, FxBool, (GrBuf
+       while(src_height--)
+       {
+          /* adjust starting alignment */
+-         if (((FxU32)src)&3)
+-            *((FxU16 *)dst)++=*((FxU16 *)src)++;
++         if (((FxU32)src)&3) {
++            *((FxU16 *)dst)=*((FxU16 *)src);
++            dst = ((FxU16 *)dst)+1; src = ((FxU16 *)src);
++         }
+          /* read in dwords of pixels */
+          if(length)
+@@ -1353,8 +1355,8 @@ GR_ENTRY(grLfbReadRegion, FxBool, (GrBuf
+                *((FxU16 *)(((AnyPtr)dst) + byte_index))=*((FxU16 *)(((AnyPtr)src) + byte_index));
+          }
+          /* adjust for next line */
+-         ((FxU8 *)src)+=src_adjust;
+-         ((FxU8 *)dst)+=dst_adjust;
++         src=((FxU8 *)src)+src_adjust;
++         dst=((FxU8 *)dst)+dst_adjust;
+       }
+       rv=FXTRUE;
+       /* unlock buffer */
diff --git a/glide-no_redefine_macro.patch b/glide-no_redefine_macro.patch
new file mode 100644 (file)
index 0000000..4bd3ec4
--- /dev/null
@@ -0,0 +1,68 @@
+--- glide3x.orig/h3/glide3/src/xdraw2.inc.S
++++ glide3x/h3/glide3/src/xdraw2.inc.S
+@@ -59,6 +59,8 @@
+ .file "xdraw2.inc.S"
++#ifndef XDRAW2_FIFO_MACROS
++#define XDRAW2_FIFO_MACROS
+ .macro GR_FIFO_WRITE __addr __offset __data
+       mov \__data , \__offset(\__addr)
+ .endm /*  GR_FIFO_WRITE */
+@@ -72,6 +74,7 @@
+ .macro WRITE_MM1LOW_FIFO 
+       movd %mm1 , (%ebp)      /*  store current param | previous param */
+ .endm /*  WRITE_MM1LOW_FIFO */
++#endif
+ #if 0
+@@ -815,9 +818,12 @@ LOCAL(nocull):
+ #define packCol %edi
+ #define tempVal %edi
++#ifndef XDRAW2_FIFO_MACROS
++#define XDRAW2_FIFO_MACROS
+ .macro GR_FIFO_WRITE __addr __offset __data
+       mov \__data , \__offset(\__addr)
+ .endm /*  GR_FIFO_WRITE */
++#endif
+ .align 4
+ LOCAL(__triBegin):
+--- glide3x.orig/h5/glide3/src/xdraw2.inc.s
++++ glide3x/h5/glide3/src/xdraw2.inc.s
+@@ -81,6 +81,8 @@
+ .file "xdraw2.inc.S"
++#ifndef XDRAW2_FIFO_MACROS
++#define XDRAW2_FIFO_MACROS
+ .macro GR_FIFO_WRITE __addr __offset __data
+ #ifdef HAL_CSIM
+       pushad 
+@@ -121,6 +123,7 @@
+       movd %mm1 , (%ebp)      /*  store current param | previous param */
+ #endif
+ .endm /*  WRITE_MM1LOW_FIFO */
++#endif
+ #if 0
+@@ -867,6 +870,8 @@ LOCAL(nocull):
+ #define packCol %edi
+ #define tempVal %edi
++#ifndef XDRAW2_FIFO_MACROS
++#define XDRAW2_FIFO_MACROS
+ .macro GR_FIFO_WRITE __addr __offset __data
+ #ifdef HAL_CSIM
+       pushad 
+@@ -884,6 +889,7 @@ LOCAL(nocull):
+       mov \__data , \__offset(\__addr)
+ #endif
+ .endm /*  GR_FIFO_WRITE */
++#endif
+ .align 4
+ LOCAL(__triBegin):
This page took 0.087147 seconds and 4 git commands to generate.