]> git.pld-linux.org Git - packages/Glide_V3-DRI.git/commitdiff
- gulp... added asm code fix to h3 and h5 patches - on Linux gc is passed on Glide_V3-DRI-3_10_0-0_20010309_1 Glide_V5-DRI-3_10_0-0_20010309_2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 3 Aug 2001 21:50:57 +0000 (21:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  stack, not in edx (funny that edx may contain correct value - depending on
  optimizations)

Changed files:
    Glide_V3-DRI.spec -> 1.12
    glide-h3.patch -> 1.2
    glide-h5.patch -> 1.2

Glide_V3-DRI.spec
glide-h3.patch
glide-h5.patch

index 9faba3467678dc70a4c8ba202696ee71f7fc42c0..d4087a1b068c854cfbcdc5175678e023960356bc 100644 (file)
@@ -35,7 +35,7 @@ or non-DRI versions of Glide.
 %description -l pl
 Ta biblioteka pozwala u¿ytkownikowi na u¿ywanie kart 3dfx Interactive
 Voodoo Banshee lub Voodoo3 pod Linux'em z DRI. Ta wersja zawiera
-wsparcie dla wersji Glide'a z DRI i bez DRI.
+wsparcie dla wersji Glide z DRI i bez DRI.
 
 %package devel
 Summary:       Development headers for Glide 3.x
@@ -49,7 +49,7 @@ Requires:     %{name} = %{version}
 %description devel
 This package includes the headers files, documentation, and test files
 necessary for developing applications that use the 3Dfx Interactive
-Voodoo Banshe or Voodoo3 cards.
+Voodoo Banshee or Voodoo3 cards.
 
 %description -l pl devel
 Ten pakiet zawiera pliki nag³ówkowe, dokumentacje, oraz pliki tekstowe
@@ -66,10 +66,12 @@ Group(pl):  X11/Programowanie/Biblioteki
 Requires:      %{name} = %{version}
 
 %description static
-This package includes the static Glide3 library.
+This package includes the static Glide3 library for Voodoo Banshee or
+Voodoo3 cards.
 
 %description -l pl static
-Ten pakiet zawiera statyczne biblioteki Glide3.
+Ten pakiet zawiera statyczne biblioteki Glide3 dla kart Voodoo Banshee
+lub Voodoo3.
 
 %prep
 %setup -q -n glide3x-%{snapdate}
index d0cc2f208b80481eea46390fb3847faa4b731b07..ce2d91275e8602bc885d993689f6b6916508b297 100644 (file)
  
  endif
  
+--- glide3x-20010309/h3/glide3/src/xdraw2.inc.S.orig   Fri Oct 20 21:07:00 2000
++++ glide3x-20010309/h3/glide3/src/xdraw2.inc.S        Fri Aug  3 22:56:46 2001
+@@ -246,7 +246,7 @@
+       push %edi       /*  save caller's register variable */
+       push %esi       /*  save caller's register variable  */
+-      mov %edx , gc   /*  gc in edx from caller */
++      mov _gc-8(%esp) , gc    /*  gc on stack (NOT!!! in edx) from caller */
+       push %ebx       /*  save caller's register variable */
+       push %ebp       /*  save frame pointer */
index e9d9fd188dfd3d5d47842ce0a9e1c89fc4449a91..bda7b2c047c5ea7d18fd7c3ddb9952fff231672f 100644 (file)
  {
    long rVal = 0;
  
+--- glide3x-20010309/h5/glide3/src/xdraw2.inc.s.orig   Fri Nov 17 22:31:06 2000
++++ glide3x-20010309/h5/glide3/src/xdraw2.inc.s        Fri Aug  3 22:55:09 2001
+@@ -295,7 +295,7 @@
+       push %edi       /*  save caller's register variable */
+       push %esi       /*  save caller's register variable  */
+-      mov %edx , gc   /*  gc in edx from caller */
++      mov _gc-8(%esp) , gc    /*  gc on stack (NOT!!! in edx) from caller */
+       push %ebx       /*  save caller's register variable */
+       push %ebp       /*  save frame pointer */
This page took 0.038869 seconds and 4 git commands to generate.