]> git.pld-linux.org Git - packages/GeoIP.git/blob - GeoIP.spec
- updated to 1.6.12
[packages/GeoIP.git] / GeoIP.spec
1 Summary:        Library to find what country an IP address or hostnames originate from
2 Summary(pl.UTF-8):      Biblioteka do sprawdzenia z jakiego kraju pochodzi adres IP lub domena
3 Name:           GeoIP
4 Version:        1.6.11
5 Release:        1
6 License:        LGPL v2.1+ (library), CC-BY-SA v3.0 (database)
7 Group:          Libraries
8 #Source0Download: https://github.com/maxmind/geoip-api-c/releases
9 Source0:        https://github.com/maxmind/geoip-api-c/releases/download/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  1e08aeb2b87d8908249998b3019d0fd7
11 Patch0:         %{name}-no_tests.patch
12 # note: "c" is a filename, do not add '/'
13 URL:            http://www.maxmind.com/app/c
14 BuildRequires:  autoconf >= 2.63
15 BuildRequires:  automake >= 1:1.10
16 BuildRequires:  libtool
17 Requires:       %{name}-libs = %{version}-%{release}
18 Requires:       GeoIP-db-Country >= 2009.05.02
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 GeoIP is a C library that enables the user to find the country that
23 any IP address or hostname originates from. It uses a file based
24 database that is accurate as of March 2003. This database simply
25 contains IP blocks as keys, and countries as values. This database
26 should be more complete and accurate than using reverse DNS lookups.
27 Commercial databases and automatic update services are available from
28 <http://www.maxmind.com/>.
29
30 This library can be used to automatically select the geographically
31 closest mirror, to analyze your web server logs to determine the
32 countries of your visitors, for credit card fraud detection, and for
33 software export controls.
34
35 %description -l pl.UTF-8
36 GeoIP jest biblioteką napisaną w C umożliwiającą użytkownikowi
37 odnalezienie państwa, z którego pochodzi dany adres IP lub domena.
38 Używa do tego zapisanej w pliku bazy danych (z marca 2003). W bazie
39 tej adresy IP są kluczami, a państwa wartościami. Powinna ona być
40 dokładniejsza niż sprawdzanie odwrotnego DNS. Komercyjne bazy oraz
41 usługi automatycznych aktualizacji dostępne są na stronie
42 <http://www.maxmind.com/>.
43
44 Ta biblioteka może być używana do automatycznego wyboru najbliższego
45 geograficznie mirrora, analizy logów serwera WWW w celu określenia
46 kraju, z którego pochodzą odwiedzający, do wykrywania oszustw
47 dotyczących kart kredytowych oraz kontroli eksportu oprogramowania.
48
49 %package libs
50 Summary:        GeoIP library for GeoIP Legacy database format
51 Summary(pl.UTF-8):      Biblioteka GeoIP do obsługi baz danych w formacie GeoIP Legacy
52 License:        LGPL v2.1+
53 Group:          Libraries
54 Conflicts:      GeoIP < 1.4.0-2
55
56 %description libs
57 GeoIP library for GeoIP Legacy (dat) database format.
58
59 %description libs -l pl.UTF-8
60 Biblioteka GeoIP do obsługi baz danych w formacie GeoIP Legacy (dat).
61
62 %package devel
63 Summary:        Header files for GeoIP library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GeoIP
65 License:        LGPL v2.1+
66 Group:          Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68
69 %description devel
70 Header files for GeoIP library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki GeoIP.
74
75 %package static
76 Summary:        Static GeoIP library
77 Summary(pl.UTF-8):      Statyczna biblioteka GeoIP
78 License:        LGPL v2.1+
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static GeoIP library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka GeoIP.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__automake}
97 %configure
98 %{__make}
99
100 %{__make} check
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_datadir}/GeoIP
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   libs -p /sbin/ldconfig
113 %postun libs -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog LICENSE NEWS.md README.md
118 %attr(755,root,root) %{_bindir}/geoiplookup
119 %attr(755,root,root) %{_bindir}/geoiplookup6
120 %{_mandir}/man1/geoiplookup.1*
121 %{_mandir}/man1/geoiplookup6.1*
122
123 %files libs
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libGeoIP.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libGeoIP.so.1
127 %dir %{_datadir}/GeoIP
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libGeoIP.so
132 %{_libdir}/libGeoIP.la
133 %{_includedir}/GeoIP.h
134 %{_includedir}/GeoIPCity.h
135 %{_pkgconfigdir}/geoip.pc
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libGeoIP.a
This page took 0.074879 seconds and 3 git commands to generate.