]> git.pld-linux.org Git - packages/Gauche.git/blob - Gauche.spec
- tabs in preamle
[packages/Gauche.git] / Gauche.spec
1 Summary:        Scheme script interpreter with multibyte character handling
2 Summary(pl.UTF-8):      Interpreter Scheme obsługujący wielobajtowe kodowanie znaków
3 Name:           Gauche
4 Version:        0.5.5
5 Release:        2
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://dl.sourceforge.net/gauche/%{name}-%{version}.tgz
9 # Source0-md5:  8e2d65afc7669858557166568030d555
10 Patch0:         %{name}-install.patch
11 URL:            http://www.shiro.dreamhost.com/scheme/gauche/
12 BuildRequires:  automake
13 BuildRequires:  gdbm-devel >= 1.8.0
14 BuildRequires:  slib
15 Requires:       slib
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Gauche is a Scheme interpreter conforming Revised^5 Report on
20 Algorithmic Language Scheme. It is designed for rapid development of
21 daily tools like system management and text processing. It can handle
22 multibyte character strings natively. This package is compiled with
23 utf-8 as the native character encoding.
24
25 %description -l pl.UTF-8
26 Gauche jest interpreterem języka Scheme zgodnym z "Revised^5 Report on
27 Algorithmic Language Scheme". Jest on zaprojektowany do szybkiego
28 tworzenia codziennych narzędzi, jak zarządzania systemem lub
29 przetwarzanie tekstu. Potrafi on obsługiwać natywnie wielobajtowe
30 kodowanie znaków (jak na przykład unicode). Ten pakiet jest
31 skompilowany z utf-8 jako natywnym kodowaniem znaków.
32
33 %package static
34 Summary:        Static version of Gauche runtime libary
35 Summary(pl.UTF-8):      Statyczna wersja biblioteki czasu wykonania Gauche
36 Group:          Development/Languages
37 Requires:       %{name} = %{version}-%{release}
38
39 %description static
40 Static version of Gauche runtime libary.
41
42 %description static -l pl.UTF-8
43 Statyczna wersja biblioteki czasu wykonania Gauche.
44
45 %package dbm
46 Summary:        Gauche bindings for GDBM library
47 Summary(pl.UTF-8):      Wiązania do biblioteki GDBM dla Gauche
48 Group:          Development/Languages
49 Requires:       %{name} = %{version}-%{release}
50
51 %description dbm
52 Gauche bindings for GDBM library.
53
54 %description dbm -l pl.UTF-8
55 Wiązania do biblioteki GDBM dla Gauche.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 %build
62 %configure \
63         --enable-multibyte=utf-8 \
64         --with-slib=%{_datadir}/guile/slib \
65         --with-pthread
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT
72
73 echo "echo $RPM_BUILD_ROOT\$(sh $(pwd)/src/gauche-config \"\$@\")" >src/gauche-config-install
74
75 %{__make} \
76         LIB_INSTALL_DIR=$RPM_BUILD_ROOT%{_libdir} \
77         BIN_INSTALL_DIR=$RPM_BUILD_ROOT%{_bindir} \
78         DATA_INSTALL_DIR=$RPM_BUILD_ROOT%{_datadir} \
79         GAUCHE_DATA_DIR=$RPM_BUILD_ROOT%{_datadir}/gauche \
80         GAUCHE_ARCH_DIR=$RPM_BUILD_ROOT%{_libdir}/gauche \
81         SCM_INSTALL_DIR=$RPM_BUILD_ROOT%{_datadir}/gauche/%{version}/lib \
82         GAUCHE_CONFIG="sh $(pwd)/src/gauche-config-install" \
83         install-rpm
84
85 install -d $RPM_BUILD_ROOT%{_includedir}
86 mv $RPM_BUILD_ROOT%{_libdir}/gauche/%{version}/include/* $RPM_BUILD_ROOT%{_includedir}
87
88 install -d $RPM_BUILD_ROOT%{_mandir}/man1
89 install doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
90
91 install -d $RPM_BUILD_ROOT%{_aclocaldir}
92 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/gauche.m4
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 # creates slib catalog, if possible.
99 /usr/bin/gosh -u slib -e "(require 'logical)" -e "(exit 0)" > /dev/null 2>&1 || :
100 /sbin/ldconfig
101
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc COPYING ChangeLog
107 %attr(755,root,root) %{_bindir}/gosh
108 %attr(755,root,root) %{_bindir}/gauche-config
109 %attr(755,root,root) %{_libdir}/libgauche.so
110 %dir %{_libdir}/gauche
111 %dir %{_libdir}/gauche/%{version}
112 %dir %{_libdir}/gauche/%{version}/*
113 %attr(755,root,root) %{_libdir}/gauche/%{version}/*/*
114 %exclude %attr(755,root,root) %{_libdir}/gauche/%{version}/*/[nog]dbm.so
115 %dir %{_libdir}/gauche/site
116 %dir %{_libdir}/gauche/site/%{version}
117 %dir %{_libdir}/gauche/site/%{version}/*
118 %dir %{_datadir}/gauche
119 %dir %{_datadir}/gauche/%{version}
120 %{_datadir}/gauche/%{version}/lib
121 %exclude %{_datadir}/gauche/%{version}/lib/dbm*
122 %dir %{_datadir}/gauche/site/lib
123 %{_includedir}/gauche
124 %{_includedir}/gauche.h
125 %{_mandir}/man1/*
126 %{_aclocaldir}/*.m4
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libgauche.a
131
132 %files dbm
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/gauche/%{version}/*/[nog]dbm.so
135 %{_datadir}/gauche/%{version}/lib/dbm
136 %{_datadir}/gauche/%{version}/lib/dbm.scm
This page took 0.052968 seconds and 3 git commands to generate.