]> git.pld-linux.org Git - packages/GPI2.git/commitdiff
- up to 1.2.0 master
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 17 Jun 2015 15:01:06 +0000 (17:01 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 17 Jun 2015 15:01:06 +0000 (17:01 +0200)
- updated nosse,format patches
- package gaspi_logger only on x86_64 (precompiled binary)

GPI2-format.patch
GPI2-nosse.patch
GPI2.spec

index ce4ebaeac2373d810f2de2b6f032369cefad2183..caa52d24f19847f8bb1faeedcac79ea7c069d3fc 100644 (file)
@@ -1,11 +1,11 @@
---- GPI2-1.1.0/src/GPI2_Logger.c.orig  2014-06-18 21:42:30.000000000 +0200
-+++ GPI2-1.1.0/src/GPI2_Logger.c       2014-09-03 17:47:28.132279202 +0200
-@@ -191,7 +191,7 @@
-       vsnprintf (buf + sl, 1024 - sl, fmt, ap);
-       va_end (ap);
+--- GPI2-1.2.0/src/GPI2_Logger.c.orig  2015-06-16 21:56:40.249062867 +0200
++++ GPI2-1.2.0/src/GPI2_Logger.c       2015-06-16 21:58:07.382392548 +0200
+@@ -93,7 +93,7 @@
  
--      fprintf (stdout, buf);
-+      fputs (buf, stdout);
+   if( ! glb_gaspi_init )
+     {
+-      fprintf(stdout, buf);
++      fputs(buf, stdout);
        fflush (stdout);
        goto endL;
+     }
index 98da6f9550b8ec51b36aa9317022868cbcb29726..49a97df96f4c01cea1357c3b864759d2370c037c 100644 (file)
@@ -1,5 +1,5 @@
---- GPI2-1.1.0/src/GPI2_Utility.h.orig 2014-09-03 17:40:08.285630994 +0200
-+++ GPI2-1.1.0/src/GPI2_Utility.h      2014-09-03 17:36:54.835639111 +0200
+--- GPI2-1.2.0/src/GPI2_Utility.h.orig 2015-05-13 17:42:36.000000000 +0200
++++ GPI2-1.2.0/src/GPI2_Utility.h      2015-06-16 21:56:09.572397490 +0200
 @@ -25,7 +25,6 @@
  #include <stdlib.h>
  #include <stdio.h>
@@ -7,12 +7,12 @@
 -#include <xmmintrin.h>
  
  #ifdef DEBUG
- #define gaspi_print_error(msg, ...)                                   \
-@@ -51,7 +50,12 @@
+ #include "GPI2.h"
+@@ -56,7 +55,12 @@
  #ifdef MIC
- #define gaspi_delay()   _mm_delay_32(32)
+ #define gaspi_delay() _mm_delay_32(32)
  #else
--#define gaspi_delay()   _mm_pause()
+-#define gaspi_delay() _mm_pause()
 +#if defined(__i386__) || defined(__x86_64__)
 +#define gaspi_delay()   __builtin_ia32_pause()
 +#else
index f4b90b6ab96addaa01c2759a3f4e7088e38fe83e..ea2ce9be7bbccca309daf65f86877d8e626c4146 100644 (file)
--- a/GPI2.spec
+++ b/GPI2.spec
@@ -1,18 +1,22 @@
 # TODO: CUDA, MPI, Load Leveler(?)
-# - find gaspi_logger sources and compile it
 #
 # Conditional build:
 %bcond_without f90     # Fortran bindings
+%bcond_without logger  # gaspi_logger utility
 #
+%ifnarch %{x8664}
+# no sources, only x86_64 binary included
+%undefine      with_logger
+%endif
 Summary:       GPI-2 - API for asynchronous communication
 Summary(pl.UTF-8):     GPI-2 - API do komunikacji asynchronicznej
 Name:          GPI2
-Version:       1.1.1
+Version:       1.2.0
 Release:       0.1
 License:       GPL v3
 Group:         Applications
 Source0:       https://www.openfabrics.org/downloads/gpi2/%{name}-%{version}.tar.gz
-# Source0-md5: 83598c7cfacf5b47892af667729a111b
+# Source0-md5: 985ef97215563f5af5e71833a490ef97
 Patch0:                %{name}-nosse.patch
 Patch1:                %{name}-format.patch
 URL:           http://www.gpi-site.com/gpi2/
@@ -20,8 +24,6 @@ BuildRequires:        doxygen
 %{?with_f90:BuildRequires:     gcc-fortran >= 5:4.0}
 BuildRequires: libibverbs-devel >= 1.1.6
 Requires:      libibverbs >= 1.1.6
-# FIXME: gaspi_logger sources are missing
-ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -46,9 +48,11 @@ skalowalny i odporny na awarie interfejs do aplikacji równoległych.
 %patch0 -p1
 %patch1 -p1
 
+%if %{without logger}
 # precompiled binaries
 # FIXME: sources are missing
-#%{__rm} bin/gaspi_logger
+%{__rm} bin/gaspi_logger
+%endif
 
 %build
 %{__make} clean
@@ -71,7 +75,10 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}}
 
 install bin/gaspi_run.ssh $RPM_BUILD_ROOT%{_bindir}/gaspi_run
-install bin/ssh.spawner bin/gaspi_cleanup bin/gaspi_logger $RPM_BUILD_ROOT%{_bindir}
+install bin/ssh.spawner bin/gaspi_cleanup $RPM_BUILD_ROOT%{_bindir}
+%if %{with logger}
+install bin/gaspi_logger $RPM_BUILD_ROOT%{_bindir}
+%endif
 cp -pr include $RPM_BUILD_ROOT%{_includedir}
 cp -p lib64/lib* $RPM_BUILD_ROOT%{_libdir}
 
@@ -82,12 +89,15 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README docs/html
 %attr(755,root,root) %{_bindir}/gaspi_cleanup
+%if %{with logger}
 %attr(755,root,root) %{_bindir}/gaspi_logger
+%endif
 %attr(755,root,root) %{_bindir}/gaspi_run
 %attr(755,root,root) %{_bindir}/ssh.spawner
 %{_libdir}/libGPI2.a
 %{_libdir}/libGPI2-dbg.a
 %{_includedir}/GASPI.h
+%{_includedir}/GASPI_Ext.h
 %{_includedir}/GASPI_GPU.h
 %{_includedir}/GASPI_Threads.h
 %{_includedir}/PGASPI.h
This page took 0.15102 seconds and 4 git commands to generate.