]> git.pld-linux.org Git - packages/GLStats.git/commitdiff
- new master auto/th/GLStats-0.3.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 21 Dec 2014 09:02:21 +0000 (10:02 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 21 Dec 2014 09:02:21 +0000 (10:02 +0100)
GLStats-cmake.patch [new file with mode: 0644]
GLStats-shared.patch [new file with mode: 0644]
GLStats.spec [new file with mode: 0644]

diff --git a/GLStats-cmake.patch b/GLStats-cmake.patch
new file mode 100644 (file)
index 0000000..ae27bf9
--- /dev/null
@@ -0,0 +1,14 @@
+--- GLStats-0.3.1/CMakeLists.txt.orig  2014-10-07 11:54:53.000000000 +0200
++++ GLStats-0.3.1/CMakeLists.txt       2014-12-20 21:44:32.998326854 +0100
+@@ -19,11 +19,6 @@
+ include(Common)
+-include(Buildyard)
+-if(BUILDYARD_STOP)
+-  return()
+-endif()
+-
+ set(FIND_PACKAGES_DEFINES GLSTATS_STATIC)
+ include(FindPackages)
+ set(GLSTATS_DEPENDENT_LIBRARIES Lunchbox)
diff --git a/GLStats-shared.patch b/GLStats-shared.patch
new file mode 100644 (file)
index 0000000..e4145bb
--- /dev/null
@@ -0,0 +1,11 @@
+--- GLStats-0.3.1/GLStats/CMakeLists.txt.orig  2014-12-21 09:02:36.729952851 +0100
++++ GLStats-0.3.1/GLStats/CMakeLists.txt       2014-12-21 09:02:41.406619323 +0100
+@@ -5,7 +5,7 @@
+ list(APPEND GLSTATS_LINK_LIBRARIES ${Boost_PROGRAM_OPTIONS_LIBRARY})
+-set(GLSTATS_LIBRARY_TYPE STATIC)
++set(GLSTATS_LINK_LIBRARIES GL)
+ common_library(GLStats)
+ # Grouping files in VisualStudio
diff --git a/GLStats.spec b/GLStats.spec
new file mode 100644 (file)
index 0000000..975ba42
--- /dev/null
@@ -0,0 +1,108 @@
+#
+# Conditional build:
+%bcond_with    apidocs         # build and package API docs (empty as of 0.3.1)
+#
+Summary:       Generic OpenGL overlay statistics renderer
+Summary(pl.UTF-8):     Ogólna biblioteka do renderowania statystyk na nakładce OpenGL
+Name:          GLStats
+Version:       0.3.1
+Release:       1
+License:       LGPL v2.1
+Group:         Libraries
+Source0:       https://github.com/Eyescale/GLStats/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: ed80f815bdfdb714aa6269d35c6bfcc1
+Patch0:                %{name}-cmake.patch
+Patch1:                %{name}-shared.patch
+URL:           https://github.com/Eyescale/GLStats/
+BuildRequires: Eyescale-CMake
+BuildRequires: Lunchbox-devel >= 1.10
+BuildRequires: OpenGL-devel
+BuildRequires: boost-devel >= 1.41.0
+BuildRequires: cmake >= 2.8
+%{?with_apidocs:BuildRequires: doxygen}
+BuildRequires: libstdc++-devel
+BuildRequires: pkgconfig
+Requires:      Lunchbox >= 1.10
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Generic OpenGL overlay statistics renderer.
+
+%description -l pl.UTF-8
+Ogólna biblioteka do renderowania statystyk na nakładce OpenGL.
+
+%package devel
+Summary:       Header files for GLStats library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki GLStats
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      Lunchbox-devel >= 1.10
+Requires:      libstdc++-devel
+
+%description devel
+Header files for GLStats library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki GLStats.
+
+%package apidocs
+Summary:       GLStats API documentation
+Summary(pl.UTF-8):     Dokumentacja API biblioteki GLStats
+Group:         Documentation
+
+%description apidocs
+API documentation for GLStats library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki GLStats.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+ln -s %{_datadir}/Eyescale-CMake CMake/common
+%{__rm} .gitexternals
+
+%build
+install -d build
+cd build
+%cmake ..
+
+%{__make}
+
+%if %{with apidocs}
+doxygen doc/Doxyfile
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc LICENSE.txt README.md
+%attr(755,root,root) %{_libdir}/libGLStats.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libGLStats.so.1
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libGLStats.so
+%{_includedir}/GLStats
+%{_pkgconfigdir}/GLStats.pc
+%dir %{_datadir}/GLStats
+%{_datadir}/GLStats/CMake
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc build/doc/html/*
+%endif
This page took 0.158744 seconds and 4 git commands to generate.