]> git.pld-linux.org Git - packages/GLStats.git/blob - GLStats.spec
- new
[packages/GLStats.git] / GLStats.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # build and package API docs (empty as of 0.3.1)
4 #
5 Summary:        Generic OpenGL overlay statistics renderer
6 Summary(pl.UTF-8):      Ogólna biblioteka do renderowania statystyk na nakładce OpenGL
7 Name:           GLStats
8 Version:        0.3.1
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        https://github.com/Eyescale/GLStats/archive/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  ed80f815bdfdb714aa6269d35c6bfcc1
14 Patch0:         %{name}-cmake.patch
15 Patch1:         %{name}-shared.patch
16 URL:            https://github.com/Eyescale/GLStats/
17 BuildRequires:  Eyescale-CMake
18 BuildRequires:  Lunchbox-devel >= 1.10
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  boost-devel >= 1.41.0
21 BuildRequires:  cmake >= 2.8
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  pkgconfig
25 Requires:       Lunchbox >= 1.10
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Generic OpenGL overlay statistics renderer.
30
31 %description -l pl.UTF-8
32 Ogólna biblioteka do renderowania statystyk na nakładce OpenGL.
33
34 %package devel
35 Summary:        Header files for GLStats library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GLStats
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       Lunchbox-devel >= 1.10
40 Requires:       libstdc++-devel
41
42 %description devel
43 Header files for GLStats library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki GLStats.
47
48 %package apidocs
49 Summary:        GLStats API documentation
50 Summary(pl.UTF-8):      Dokumentacja API biblioteki GLStats
51 Group:          Documentation
52
53 %description apidocs
54 API documentation for GLStats library.
55
56 %description apidocs -l pl.UTF-8
57 Dokumentacja API biblioteki GLStats.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63
64 ln -s %{_datadir}/Eyescale-CMake CMake/common
65 %{__rm} .gitexternals
66
67 %build
68 install -d build
69 cd build
70 %cmake ..
71
72 %{__make}
73
74 %if %{with apidocs}
75 doxygen doc/Doxyfile
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} -C build install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc LICENSE.txt README.md
93 %attr(755,root,root) %{_libdir}/libGLStats.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libGLStats.so.1
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libGLStats.so
99 %{_includedir}/GLStats
100 %{_pkgconfigdir}/GLStats.pc
101 %dir %{_datadir}/GLStats
102 %{_datadir}/GLStats/CMake
103
104 %if %{with apidocs}
105 %files apidocs
106 %defattr(644,root,root,755)
107 %doc build/doc/html/*
108 %endif
This page took 0.078829 seconds and 3 git commands to generate.