]> git.pld-linux.org Git - packages/GLM.git/blob - GLM.spec
disable debug packages
[packages/GLM.git] / GLM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 %bcond_with     p7zip           # plain p7zip (compatible with both rpm4/rpm5)
5 #
6 Summary:        OpenGL Mathematics (GLM) - C++ mathematics library for GLSL
7 Summary(pl.UTF-8):      OpenGL Mathematics (GLM) - biblioteka matematyczna C++ dla GLSL
8 Name:           GLM
9 Version:        0.9.6.3
10 Release:        1
11 License:        MIT
12 Group:          Development/Libraries
13 Source0:        http://downloads.sourceforge.net/ogl-math/glm-%{version}.7z
14 # Source0-md5:  044224370047034c3d9340550e0ed52a
15 Patch0:         %{name}-opt.patch
16 URL:            http://glm.g-truc.net/
17 BuildRequires:  cmake
18 %if %{with p7zip}
19 BuildRequires:  p7zip
20 %else
21 BuildRequires:  p7zip-standalone
22 BuildRequires:  rpm-build >= 5
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 OpenGL Mathematics (GLM) is a C++ mathematics library for graphics
28 software based on the OpenGL Shading Language (GLSL) specification.
29
30 GLM is a header only library, there is nothing to build, just include
31 it.
32
33 %description -l pl.UTF-8
34 OpenGL Mathematics (GLM) to biblioteka matematyczna C++ dla programów
35 graficznych opartych na specyfikacji OpenGL Shading Language (GLSL).
36
37 %prep
38 %if %{with p7zip}
39 %setup -q -c -T -n glm
40 7z x %{SOURCE0} -o..
41 %else
42 %setup -q -n glm
43 %endif
44 %patch0 -p1
45
46 %build
47 mkdir build
48 cd build
49 %cmake .. \
50         -DGLM_TEST_ENABLE:BOOL=%{!?with_tests:OFF}%{?with_tests:ON}
51
52 %{?with_tests:%{__make}}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} -C build install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc readme.txt doc/glm.pdf
66 %attr(755,root,root) %{_includedir}/glm
67 %{_libdir}/cmake/FindGLM.cmake
This page took 0.137137 seconds and 3 git commands to generate.