]> git.pld-linux.org Git - packages/FreeWnn.git/commitdiff
- added format patch (allow build with -Werror=format-security)
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 17 Nov 2012 16:02:20 +0000 (17:02 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 17 Nov 2012 16:02:20 +0000 (17:02 +0100)
- use make -j1 (parallel build broken on dicts)

FreeWnn-format.patch [new file with mode: 0644]
FreeWnn.spec

diff --git a/FreeWnn-format.patch b/FreeWnn-format.patch
new file mode 100644 (file)
index 0000000..ad5fa9a
--- /dev/null
@@ -0,0 +1,26 @@
+--- FreeWnn-1.1.1-a021/Wnn/jutil/wddel.c.orig  2002-05-13 00:51:17.000000000 +0200
++++ FreeWnn-1.1.1-a021/Wnn/jutil/wddel.c       2012-11-17 16:52:08.354757471 +0100
+@@ -95,8 +95,8 @@ usage ()
+ static void
+ err ()
+ {
+-  printf ((char *) wnn_perror ());
+-  printf ("\n bye.\n");
++  puts ((char *) wnn_perror ());
++  printf (" bye.\n");
+   exit (1);
+ }
+--- FreeWnn-1.1.1-a021/Wnn/jutil/wdreg.c.orig  2002-05-13 00:51:17.000000000 +0200
++++ FreeWnn-1.1.1-a021/Wnn/jutil/wdreg.c       2012-11-17 16:52:18.701902804 +0100
+@@ -95,8 +95,8 @@ usage ()
+ static void
+ err ()
+ {
+-  printf ((char *) wnn_perror ());
+-  printf ("\n bye.\n");
++  puts ((char *) wnn_perror ());
++  printf (" bye.\n");
+   exit (1);
+ }
index 2230224f177b70446abb5144a4a874d5a855b0d8..f7bf083b8d274913cf037ed61c77402fc00b012f 100644 (file)
@@ -24,6 +24,7 @@ Patch6:               %{name}-libtool.patch
 Patch7:                %{name}-cpp.patch
 Patch8:                %{name}-install.patch
 Patch9:                %{name}-link.patch
+Patch10:       %{name}-format.patch
 URL:           http://www.freewnn.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -259,6 +260,7 @@ Ten pakiet zawiera statycznÄ… wersjÄ™ biblioteki kWnn.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 cp -p Wnn-consortium/dic/README README.Wnn-consortium.dic
 
@@ -269,8 +271,7 @@ cp -p Wnn-consortium/dic/README README.Wnn-consortium.dic
 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
 %configure
 
-%{__make}
-#      CDEBUGFLAGS="%{rpmcflags} -I/usr/include/ncurses"
+%{__make} -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.287198 seconds and 4 git commands to generate.