]> git.pld-linux.org Git - packages/FreeMat.git/blob - FreeMat.spec
- massive change ( validate errors warrings from desktop-file-validate)
[packages/FreeMat.git] / FreeMat.spec
1 # TODO:
2 # - look at MPI support - doesn't work with lam for me :/
3 # - build with CYCLE COUNTER (required fftw_cycle.h)
4 #
5 %define         fversion        %(echo %{version} |tr r -)
6 %define         mversion        %(echo %{version} |cut -f -1 -d r)
7 Summary:        FreeMat - an environment for rapid engineering and scientific processing
8 Summary(pl.UTF-8):      FreeMat - środowisko do szybkiego przetwarzania inżynieryjnego i naukowego
9 Name:           FreeMat
10 Version:        3.5
11 Release:        1
12 License:        MIT
13 Group:          Applications/Math
14 Source0:        http://dl.sourceforge.net/freemat/%{name}-%{fversion}.tar.gz
15 # Source0-md5:  4cc41c1f9265a86134fd338076d1a65f
16 Source1:        %{name}.desktop
17 Patch0:         %{name}-qt4.patch
18 Patch1:         %{name}-link.patch
19 URL:            http://freemat.sourceforge.net
20 BuildRequires:  QtCore-devel
21 BuildRequires:  QtGui-devel
22 BuildRequires:  QtOpenGL-devel
23 BuildRequires:  QtNetwork-devel
24 BuildRequires:  QtXml-devel
25 BuildRequires:  UMFPACK-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  arpack-devel
29 BuildRequires:  ffcall-devel
30 BuildRequires:  fftw3-devel
31 BuildRequires:  fftw3-single-devel
32 BuildRequires:  gcc-g77
33 BuildRequires:  lapack-devel
34 BuildRequires:  ncurses-devel
35 BuildRequires:  pcre-devel
36 BuildRequires:  portaudio-devel
37 BuildRequires:  qt4-build
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 FreeMat is a free environment for rapid entineering and scientific
42 prototyping and data processing. It is similar to commercial systems
43 such as MATLAB from Mathworks, and IDL from Research Systems, but is
44 Open Source. FreeMat includes several novel features such as a
45 codeless interface to external C/C++/FORTRAN code,
46 parallel/distributed algorithm development (via MPI), and plotting and
47 visualiation capabilities.
48
49 %description -l pl.UTF-8
50 FreeMat jest darmowym środowiskiem do szybkiego przetwarzania
51 prototypów i danych dla inżynierów i naukowców. Jest podobny do
52 komercyjnych systemów takich jak MATLAB z Mathworks i IDL z Research
53 Group, ale na licencji Open Source. FreeMat cechuje się między innymi
54 bezkodowym interfejsem do zewnętrznego kodu C/C++/FORTRAN,
55 równoległym/rozproszonym algorytmem obliczeń (poprzez MPI), oraz
56 rysowaniem i wyświetlaniem możliwości.
57
58 %prep
59 %setup -q -n %{name}-%{mversion}
60 %patch0 -p1
61 %patch1 -p1
62
63 %build
64 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
65 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
66 %{__aclocal}
67 %{__autoconf}
68 %{__automake}
69 %configure \
70         --with-ncurses
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_infodir},%{_desktopdir}}
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT \
80         prefix=$RPM_BUILD_ROOT%{_prefix}
81
82 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_bindir}/%{name}
90 %{_datadir}/%{name}-%{version}
91 %{_desktopdir}/%{name}.desktop
This page took 0.056204 seconds and 3 git commands to generate.