]> git.pld-linux.org Git - packages/FlightGear.git/commitdiff
- updated to 2016.2.1
authorBartek Szady <bszx@pld-linux.org>
Sat, 23 Jul 2016 20:17:30 +0000 (22:17 +0200)
committerBartek Szady <bszx@bszx.eu>
Sat, 23 Jul 2016 20:19:22 +0000 (22:19 +0200)
FlightGear.spec
OpenSceneGraph-3.3.2.patch [deleted file]
flightgear-cmake.patch
rtti-fix.patch [deleted file]

index 609a168734ab46e8807adcda37fd7b9ab3aead67..de2369de8e5d276b2b010140c2490703c080f5b8 100644 (file)
@@ -9,19 +9,15 @@
 Summary:       Free Flight Simulator
 Summary(pl.UTF-8):     darmowy symulator lotu
 Name:          FlightGear
-Version:       3.2.0
-Release:       3
+Version:       2016.2.1
+Release:       1
 License:       GPL
 Group:         X11/Applications/Games
-Source0:       ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/flightgear-%{version}.tar.bz2
-# Source0-md5: 0a16920cc22ea070f8bb345e76c55e05
-Source1:       ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Shared/%{name}-data-%{version}.tar.bz2
-# Source1-md5: 24774fae7199bcbc5e23672f4a586884
-#Source2:      ftp://ftp.flightgear.org/pub/fgfs/Everything-0.7/Base-Packages/fgfs-docs-0.7.7.tar.gz
-## Source2-md5:        31f35d3e63e522565e8990ead99e7507
+Source0:       http://downloads.sourceforge.net/project/flightgear/release-2016.2/flightgear-%{version}.tar.bz2
+# Source0-md5: 04b4817ba9d8953013c43f5f201b495f
+Source1:       http://downloads.sourceforge.net/project/flightgear/release-2016.2//%{name}-%{version}-data.tar.bz2
+# Source1-md5: f118026487513e16d0aad185d3818f7b
 Patch0:                flightgear-cmake.patch
-Patch1:                OpenSceneGraph-3.3.2.patch
-Patch2:                rtti-fix.patch
 URL:           http://www.flightgear.org/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-devel
@@ -44,6 +40,7 @@ Requires:     plib >= 1.8.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
+%define                filterout       -flto
 
 %description
 The Flight Gear project is working to create a sophisticated flight
@@ -70,8 +67,6 @@ installed
 %prep
 %setup -q -n flightgear-%{version} %{?with_data:-a 1}
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
 
 cat > runfgfs <<'EOF'
 #!/bin/sh
diff --git a/OpenSceneGraph-3.3.2.patch b/OpenSceneGraph-3.3.2.patch
deleted file mode 100644 (file)
index e84b8b7..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
---- flightgear-3.2.0/src/Model/panelnode.cxx.orig      2014-08-17 15:40:24.000000000 +0200
-+++ flightgear-3.2.0/src/Model/panelnode.cxx   2014-11-02 12:27:29.031193511 +0100
-@@ -10,6 +10,7 @@
- #include <osg/Geode>
- #include <osg/Switch>
- #include <osg/BlendFunc>
-+#include <osg/Version>
- #include <simgear/compiler.h>
- #include <simgear/structure/exception.hxx>
-@@ -315,7 +316,11 @@
- }
- osg::BoundingBox
-+#if OSG_VERSION_LESS_THAN(3,3,2)
- FGPanelNode::computeBound() const
-+#else
-+FGPanelNode::computeBoundingBox() const
-+#endif
- {
-   osg::Vec3 coords[3];
---- flightgear-3.2.0/src/Model/panelnode.hxx.orig      2014-08-17 15:40:24.000000000 +0200
-+++ flightgear-3.2.0/src/Model/panelnode.hxx   2014-11-02 12:27:11.551194127 +0100
-@@ -4,6 +4,7 @@
- #include <osg/Vec3>
- #include <osg/Matrix>
- #include <osg/Drawable>
-+#include <osg/Version>
- #include <memory>
- #include <simgear/structure/SGSharedPtr.hxx>
-@@ -30,7 +31,11 @@
-     { drawImplementation(*renderInfo.getState()); }
-   
-     void drawImplementation(osg::State& state) const;
-+#if OSG_VERSION_LESS_THAN(3,3,2)
-     virtual osg::BoundingBox computeBound() const;
-+#else
-+    virtual osg::BoundingBox computeBoundingBox() const;
-+#endif
-     /** Return true, FGPanelNode does support accept(PrimitiveFunctor&). */
-     virtual bool supports(const osg::PrimitiveFunctor&) const { return true; }
index 5d84cb89ddd956fa6fe5bb14743783b9254aac9b..aa854cf4e3c096f364aa79ad8d7ecc787a26bc8d 100644 (file)
@@ -7,3 +7,14 @@
  
  add_executable(fgadmin fgadmin_funcs.cxx main.cxx untarka.c)
  add_dependencies(fgadmin FGAdminUI)
+--- flightgear-2016.2.1/src/GUI/CMakeLists.txt.orig    2016-05-17 10:36:25.000000000 +0200
++++ flightgear-2016.2.1/src/GUI/CMakeLists.txt 2016-07-23 14:46:33.380230285 +0200
+@@ -80,7 +80,7 @@
+     qt5_add_resources(qrc_sources resources.qrc)
+-    add_library(fglauncher QtLauncher.cxx
++    add_library(fglauncher STATIC QtLauncher.cxx
+                             QtLauncher.hxx
+                             QtLauncher_private.hxx
+                             BaseDiagram.cxx
diff --git a/rtti-fix.patch b/rtti-fix.patch
deleted file mode 100644 (file)
index 0dfb4b8..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-commit 4f91a31f05adb9b5a3c4d044c96837f853e13497
-Author: Torsten Dreyer <Torsten@t3r.de>
-Date:   Sun Aug 17 22:36:19 2014 +0200
-
-    Quick and dirty repair of linux build with RTI enabled
-
-diff --git a/utils/fgai/AIBVHPager.cxx b/utils/fgai/AIBVHPager.cxx
-index a5cc139..9aee79d 100644
---- a/utils/fgai/AIBVHPager.cxx
-+++ b/utils/fgai/AIBVHPager.cxx
-@@ -18,6 +18,7 @@
- #ifdef HAVE_CONFIG_H
- #include <config.h>
- #endif
-+#include <osg/Referenced>
- #include "AIBVHPager.hxx"
This page took 0.084083 seconds and 4 git commands to generate.