]> git.pld-linux.org Git - packages/Firebird.git/blobdiff - Firebird.spec
- rel 7
[packages/Firebird.git] / Firebird.spec
index 6875811caf5bd523dffc86b47c19bfcd3945b1c7..6d913c0127aa584fa1cc922d0e8310c3073b5d4c 100644 (file)
@@ -1,35 +1,59 @@
+# TODO:
+# - kill unaligned accesses (create_db,gpre_current,gbak_static,isql_static) on alpha
+# - create classic server/super server subpackages and drop bcond
+#   (see firebird2 on debian how to do it)
+%bcond_with    ss      # Super Server
 Summary:       Firebird SQL Database Server and Client tools
+Summary(de):   Firebird - relationalen Open-Source- Datenbankmanagementsystems
 Summary(pl):   Firebird - serwer baz danych SQL oraz narzêdzia klienckie
 Name:          Firebird
 # FirebirdCS/FirebirdSS (Classic Server/Super Server)?
-Version:       1.5.1.4500
-Release:       0.1
+Version:       1.5.3.4870
+Release:       7
 License:       Interbase Public License 1.0
 Group:         Applications/Databases
 Source0:       http://dl.sourceforge.net/firebird/firebird-%{version}.tar.bz2
-# Source0-md5: d4594415a3615dd06192abdad57ae04d
+# Source0-md5: 559d005ab6622274f9448687f930393c
 Source1:       http://www.ibphoenix.com/downloads/60All.zip
 # Source1-md5: f86a132012361cd4ae88563105741a4c
 Source2:       http://www.ibphoenix.com/downloads/ib_4_0_docs.tar.gz
 # Source2-md5: f4176d5dec952ee774bb8ee74c1f715d
 Source3:       http://www.ibphoenix.com/downloads/isc_docs.zip
 # Source3-md5: 66eef71c188215d10988788282c014a7
+Source4:       firebird.init
+Source5:       firebird.sysconfig
+Source6:       firebird.inetd
 Patch0:                %{name}-chmod.patch
 Patch1:                %{name}-editline.patch
-Patch2:                %{name}-env-overflows.patch
-Patch3:                %{name}-sparc.patch
-Patch4:                %{name}-va.patch
-Patch5:                %{name}-morearchs.patch
-URL:           http://firebird.sourceforge.net/
+Patch2:                %{name}-va.patch
+Patch3:                %{name}-morearchs.patch
+Patch4:                %{name}-gcc4.patch
+Patch5:                %{name}-fix-os-detection.dpatch
+Patch6:                %{name}-fix-pthreads-detect.dpatch
+Patch7:                %{name}-link-with-g++.dpatch
+Patch8:                %{name}-no-custom-errno-and-sys_XXerrXX.dpatch
+Patch9:                %{name}-opt-bypass-redundant-sort.dpatch
+Patch10:       %{name}-security-remote-preauth-crash.dpatch
+Patch11:       %{name}-separate-file-and-sem-perms.dpatch
+Patch12:       %{name}-ppc.patch
+URL:           http://www.firebirdsql.org/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: bison
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
 BuildRequires: ncurses-devel
+BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: unzip
 Requires:      %{name}-lib = %{version}-%{release}
-# official ports are x86, sparc and amd64
-# ppc added in morearchs patch
-# see morearchs patch if you want to add support for more 32-bit archs
-# (64-bit port is currently broken, types patch is not sufficient)
-ExclusiveArch: %{ix86} amd64 sparc sparcv9 ppc
+%if %{with ss}
+Requires(post,preun):  /sbin/chkconfig
+Requires:      rc-scripts
+%endif
+# official ports are x86, sparc and x86_64
+# alpha and ppc added in morearchs patch
+# see morearchs patch if you want to add support for more archs
+ExclusiveArch: %{ix86} %{x8664} sparc sparcv9 alpha ppc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                ibdir   %{_libdir}/interbase
@@ -45,6 +69,19 @@ Firebird jest pot
 danych zaprojektowanym do osadzania w aplikacjach na wielu
 platformach.
 
+%description -l de
+Firebird ist der Open-Source-Spin-Off des weiterhin kommerziell von
+Borland vertriebenen relationalen Datenbankmanagementsystemes
+InterBase. Die Abspaltung erfolgte im Jahre 2000 als kurz vor Freigabe
+der Version 6 des kommerziellen Vorgängers Interbase bei Borland
+ernsthafte Überlegungen im Gange waren, die Weiterentwicklung
+einzustellen.
+
+Aus Interbase 6.0 wurde Firebird 1.0, wobei dies als eine
+Bugfix-Version mit nur wenigen Erweiterungen angesehen werden kann.
+Eine Erweiterung von Firebird 1.0 ist der 64-Bit File I/O, so dass
+auch Datenbankdateien über 2GB erzeugt werden können.
+
 %package lib
 Summary:       Firebird shared library
 Summary(pl):   Biblioteka wspó³dzielona Firebird
@@ -100,7 +137,13 @@ Obszerna dokumentacja do baz InterBase i Firebird.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
 install -d docs/{IB3.0,IB4.0,IB6.0}
 unzip -q %{SOURCE1} -d docs/IB6.0
 tar xzf %{SOURCE2} -C docs/IB4.0
@@ -108,6 +151,9 @@ unzip -q %{SOURCE3} -d docs/IB3.0
 # standardize extension, also avoids gzipping by compress-doc
 mv -f docs/IB6.0/LANGREF.{PDF,pdf}
 
+# force rebuild
+rm -f src/dsql/parse.cpp
+
 %build
 cd src/extern/editline
 cp -f /usr/share/automake/config.* .
@@ -118,26 +164,55 @@ cd ../../..
 %{__autoconf}
 
 %configure \
+       %{?with_ss:--enable-superserver} \
        --prefix=%{ibdir} \
        %{?debug:--enable-debug}
-# --enable-superserver
 
 # OPTFLAGS for editline
 export OPTFLAGS="%{rpmcflags}"
+DARCH=""
+%ifarch %{x8664}
+DARCH="-DAMD64"
+%endif
+%ifarch sparc sparcv9
+DARCH="-Dsparc"
+%endif
+%ifarch ppc
+DARCH="-DPPC"
+%endif
+
 %{__make} -j1 \
-       PROD_FLAGS="%{rpmcflags} -DNDEBUG -DLINUX -pipe -MMD -fPIC" \
-       DEV_FLAGS="%{rpmcflags} -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -fPIC -Wall -Wno-switch" \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
+       PROD_FLAGS="%{rpmcflags} -DNDEBUG -DLINUX -pipe -MMD -fPIC $DARCH" \
+       DEV_FLAGS="%{rpmcflags} -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -fPIC -Wall -Wno-switch $DARCH" \
+       LIB_LINK_RPATH_LINE= \
+       LIB_CLIENT_LINK_OPTIONS="-lpthread"
+
+# my name is hack. dirty hack.
+# why isn't that build in previous make call?
+%{__make} -C src -f ../gen/Makefile.libfbembed libfbembed \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
+       PROD_FLAGS="%{rpmcflags} -DNDEBUG -DLINUX -pipe -MMD -fPIC $DARCH" \
+       DEV_FLAGS="%{rpmcflags} -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -fPIC -Wall -Wno-switch $DARCH" \
        LIB_LINK_RPATH_LINE= \
        LIB_CLIENT_LINK_OPTIONS="-lpthread"
 
+# fb_lock_mgr is started during build - try to stop it (if /proc is mounted...)
+/sbin/fuser -k gen/firebird/bin/fb_lock_mgr 2>/dev/null || :
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} -C src -f ../gen/Makefile.install buildImageDir
 
+install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig/rc-inetd}
 install -d $RPM_BUILD_ROOT{%{ibdir},%{_libdir},%{_includedir}} \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
 install gen/firebird/lib/libfb*.a $RPM_BUILD_ROOT%{_libdir}
+install gen/firebird/lib/libfbembed.so* $RPM_BUILD_ROOT%{_libdir}
 cd gen/buildroot/%{ibdir}
 
 cp -af UDF bin help intl aliases.conf firebird.conf firebird.msg security.fdb \
@@ -147,14 +222,40 @@ cp -df lib/* $RPM_BUILD_ROOT%{_libdir}
 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 # or libfbembed?
-ln -sf libfbclient.so.1.5.0 $RPM_BUILD_ROOT%{_libdir}/libgds.so.0
+ln -sf libfbclient.so.1 $RPM_BUILD_ROOT%{_libdir}/libgds.so.0
 ln -sf libfbclient.so.1 $RPM_BUILD_ROOT%{_libdir}/libgds.so
 
 ln -sf libfbstatic.a $RPM_BUILD_ROOT%{_libdir}/libgds.a
 
+install %{SOURCE4}     $RPM_BUILD_ROOT/etc/rc.d/init.d/firebird
+install %{SOURCE5}      $RPM_BUILD_ROOT/etc/sysconfig/firebird
+install %{SOURCE6}     $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/firebird
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+%groupadd -g 145 firebird
+%useradd -u 145 -d %{ibdir} -s /bin/sh -g firebird -c "Firebird Server" firebird
+
+%if %{with ss}
+%post
+/sbin/chkconfig --add firebird
+%service firebird restart
+
+%preun
+if [ "$1" = "0" ]; then
+       %service firebird stop
+       /sbin/chkconfig --del firebird
+fi
+%endif
+
+%postun
+if [ "$1" = "0" ]; then
+       %userremove firebird
+       %groupremove firebird
+fi
+
 %post  lib -p /sbin/ldconfig
 %postun        lib -p /sbin/ldconfig
 
@@ -162,17 +263,23 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc doc/{sql.extensions,Firebird_conf.txt,README.user*,WhatsNew,fb2-todo.txt}
 %attr(755,root,root) %{_libdir}/libib_util.so
-%dir %{ibdir}
+%dir %attr(770,root,firebird) %{ibdir}
 %attr(755,root,root) %{ibdir}/UDF
 %attr(755,root,root) %{ibdir}/bin
 %{ibdir}/help
-%dir %{ibdir}/intl
+%dir %attr(770,root,firebird) %{ibdir}/intl
 %attr(755,root,root) %{ibdir}/intl/fbintl
 %{ibdir}/firebird.msg
 # following files should be in /var (*.fdb) and /etc (*.conf)?
-%{ibdir}/security.fdb
-%{ibdir}/aliases.conf
-%{ibdir}/firebird.conf
+%attr(660,root,firebird) %config(noreplace) %verify(not md5 mtime size) %{ibdir}/security.fdb
+%attr(640,root,firebird) %config(noreplace) %verify(not md5 mtime size) %{ibdir}/aliases.conf
+%attr(640,root,firebird) %config(noreplace) %verify(not md5 mtime size) %{ibdir}/firebird.conf
+%if %{with ss}
+%attr(754,root,root) /etc/rc.d/init.d/firebird
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/firebird
+%else
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/firebird
+%endif
 
 %files lib
 %defattr(644,root,root,755)
This page took 0.035277 seconds and 4 git commands to generate.