]> git.pld-linux.org Git - packages/Firebird.git/blob - Firebird.spec
- added link patch to fix libgds linking (use -ldl -lcrypt, added soname)
[packages/Firebird.git] / Firebird.spec
1 Summary:        Firebird SQL Database Server and Client tools
2 Summary(pl):    Firebird - serwer baz danych SQL oraz narzêdzia klienckie
3 Name:           Firebird
4 # FirebirdCS/FirebirdSS (Classic Server/Super Server)?
5 Version:        1.0.2.908
6 Release:        2
7 License:        Interbase Public License 1.0
8 Group:          Applications/Databases
9 Source0:        http://dl.sourceforge.net/firebird/%{name}-%{version}.src.tar.gz
10 # Source0-md5: 8ca9aac6cfe2670659d00bb2decb3456
11 Source1:        http://dl.sourceforge.net/firebird/bootkit-%{version}.tar.gz
12 # Source1-md5: 3ce1d058d568242843fa0f92d5ae7018
13 Source2:        http://www.ibphoenix.com/downloads/60All.zip
14 # Source2-md5:  f86a132012361cd4ae88563105741a4c
15 Source3:        http://www.ibphoenix.com/downloads/ib_4_0_docs.tar.gz
16 # Source3-md5: f4176d5dec952ee774bb8ee74c1f715d
17 Source4:        http://www.ibphoenix.com/downloads/isc_docs.zip
18 # Source4-md5:  66eef71c188215d10988788282c014a7
19 # dirty "fixes" for missing error contants and conflict with isql from unixODBC
20 # (gds__bad_{limit,skip}_param are defined in supplied codes.h, but removed
21 #  by codes.h regeneration from messages.gbak(?))
22 Patch0:         %{name}-fix.patch
23 Patch1:         %{name}-gcc33.patch
24 Patch2:         %{name}-link.patch
25 Patch3:         %{name}-chmod.patch
26 Patch4:         %{name}-env-overflows.patch
27 URL:            http://firebird.sourceforge.net/
28 BuildRequires:  unzip
29 Requires:       %{name}-lib = %{version}-%{release}
30 # see firebird-*/jrd/{common.h,gds.h,ibase.h} if you want to add support for more
31 ExclusiveArch:  %{ix86}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         ibdir   %{_libdir}/interbase
35
36 %description
37 Firebird is a powerful, high-performance relational database designed
38 to be embedded into applications on multiple platforms.
39
40 %description -l pl
41 Firebird jest potê¿nym, wysoko wydajnym systemem relacyjnych baz
42 danych zaprojektowanym do osadzania w aplikacjach na wielu
43 platformach.
44
45 %package lib
46 Summary:        Firebird shared library
47 Summary(pl):    Biblioteka wspó³dzielona Firebird
48 Group:          Libraries
49
50 %description lib
51 Firebird shared library (libgds).
52
53 %description lib -l pl
54 Biblioteka wspó³dzielona Firebird (libgds).
55
56 %package devel
57 Summary:        Header files for Firebird library
58 Summary(pl):    Pliki nag³ówkowe biblioteki Firebird
59 Group:          Development/Libraries
60 Requires:       %{name}-lib = %{version}-%{release}
61
62 %description devel
63 Header files for Firebird library.
64
65 %description devel -l pl
66 Pliki nag³ówkowe biblioteki Firebird.
67
68 %package static
69 Summary:        Static Firebird library
70 Summary(pl):    Statyczna biblioteka Firebird
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Firebird library (libgds).
76
77 %description static -l pl
78 Statyczna biblioteka Firebird (libgds).
79
80 %package doc
81 Summary:        Extensive InterBase and Firebird documentation
82 Summary(pl):    Obszerna dokumentacja do baz InterBase i Firebird
83 Group:          Documentation
84
85 %description doc
86 Extensive InterBase and Firebird documentation.
87
88 %description doc -l pl
89 Obszerna dokumentacja do baz InterBase i Firebird.
90
91 %prep
92 %setup -q -n firebird-%{version} -a1
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96 %patch3 -p1
97 %patch4 -p1
98
99 install -d docs/{IB3.0,IB4.0,IB6.0}
100 unzip -q %{SOURCE2} -d docs/IB6.0
101 tar xzf %{SOURCE3} -C docs/IB4.0
102 unzip -q %{SOURCE4} -d docs/IB3.0
103 # standardize extension, also avoids gzipping by compress-doc
104 mv -f docs/IB6.0/LANGREF.{PDF,pdf}
105
106 %build
107 INTERBASE=/usr/lib/interbase; export INTERBASE
108 echo 'y' | ./Configure.sh PROD
109 . ./Configure_SetupEnv.sh
110
111 %{__make} firebird \
112         CC="%{__cc}" \
113         PROD_CFLAGS="%{rpmcflags} -fpic -DFLINTSTONE"
114
115 # classic/super - what's the difference?
116 #%%{__make} super_firebird
117
118 #-Isource/interbase/include"
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 INTERBASE=/usr/lib/interbase; export INTERBASE
123 . ./Configure_SetupEnv.sh
124
125 %{__make} buildclassicimage -f firebird/install/linux/Makefile
126
127 install -d $RPM_BUILD_ROOT{%{ibdir},%{_libdir},%{_includedir}} \
128         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
129 cd buildroot/opt/interbase
130 rm -f bin/isc4.gbak
131 cp -af UDF bin help intl interbase.msg isc4.gdb isc_config \
132         $RPM_BUILD_ROOT%{ibdir}
133 install include/* $RPM_BUILD_ROOT%{_includedir}
134 install lib/* $RPM_BUILD_ROOT%{_libdir}
135 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %doc builds_win32/install/{*License,Readme}.txt
143 %attr(755,root,root) %{_libdir}/libib_util.so
144 %dir %{ibdir}
145 %attr(755,root,root) %{ibdir}/UDF
146 %attr(755,root,root) %{ibdir}/bin
147 %{ibdir}/help
148 %{ibdir}/intl
149 %{ibdir}/interbase.msg
150 # following two files should be in /var and /etc resp.?
151 %{ibdir}/isc4.gdb
152 %{ibdir}/isc_config
153
154 %files lib
155 %defattr(644,root,root,755)
156 # .so link needed here - library doesn't have SONAME
157 %attr(755,root,root) %{_libdir}/libgds.so*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %{_includedir}/*
162 %{_examplesdir}/%{name}-%{version}
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libgds.a
167
168 %files doc
169 %defattr(644,root,root,755)
170 %doc docs/*
This page took 0.048028 seconds and 4 git commands to generate.