]> git.pld-linux.org Git - packages/Firebird.git/blob - Firebird.spec
- merged DEVEL
[packages/Firebird.git] / Firebird.spec
1 Summary:        Firebird SQL Database Server and Client tools
2 Summary(pl):    Firebird - serwer baz danych SQL oraz narzêdzia klienckie
3 Name:           Firebird
4 # FirebirdCS/FirebirdSS (Classic Server/Super Server)?
5 Version:        1.5.0.4290
6 Release:        0.1
7 License:        Interbase Public License 1.0
8 Group:          Applications/Databases
9 Source0:        http://dl.sourceforge.net/firebird/firebird-%{version}.tar.bz2
10 # Source0-md5:  c088ccf4d149ecc1fa03ee27e9043701
11 #Source1:       http://dl.sourceforge.net/firebird/bootkit-%{version}.tar.gz
12 ## Source1-md5: 3ce1d058d568242843fa0f92d5ae7018
13 Source2:        http://www.ibphoenix.com/downloads/60All.zip
14 # Source2-md5:  f86a132012361cd4ae88563105741a4c
15 Source3:        http://www.ibphoenix.com/downloads/ib_4_0_docs.tar.gz
16 # Source3-md5:  f4176d5dec952ee774bb8ee74c1f715d
17 Source4:        http://www.ibphoenix.com/downloads/isc_docs.zip
18 # Source4-md5:  66eef71c188215d10988788282c014a7
19 Patch0:         %{name}-chmod.patch
20 Patch1:         %{name}-link.patch
21 Patch2:         %{name}-env-overflows.patch
22 Patch3:         %{name}-sparc.patch
23 Patch4:         %{name}-va.patch
24 Patch5:         %{name}-types.patch
25 Patch6:         %{name}-morearchs.patch
26 URL:            http://firebird.sourceforge.net/
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  ncurses-devel
29 BuildRequires:  unzip
30 Requires:       %{name}-lib = %{version}-%{release}
31 # official ports are x86 and sparc(32)
32 # ppc added in morearchs patch
33 # see morearchs patch if you want to add support for more 32-bit archs
34 # (64-bit port is currently broken, types patch is not sufficient)
35 ExclusiveArch:  %{ix86} sparc sparcv9 ppc
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         ibdir   %{_libdir}/interbase
39 %define         specflags       -fno-strict-aliasing
40 %define         debugcflags     -O1 -g -Wall -fno-strict-aliasing
41
42 %description
43 Firebird is a powerful, high-performance relational database designed
44 to be embedded into applications on multiple platforms.
45
46 %description -l pl
47 Firebird jest potê¿nym, wysoko wydajnym systemem relacyjnych baz
48 danych zaprojektowanym do osadzania w aplikacjach na wielu
49 platformach.
50
51 %package lib
52 Summary:        Firebird shared library
53 Summary(pl):    Biblioteka wspó³dzielona Firebird
54 Group:          Libraries
55
56 %description lib
57 Firebird shared library (libgds).
58
59 %description lib -l pl
60 Biblioteka wspó³dzielona Firebird (libgds).
61
62 %package devel
63 Summary:        Header files for Firebird library
64 Summary(pl):    Pliki nag³ówkowe biblioteki Firebird
65 Group:          Development/Libraries
66 Requires:       %{name}-lib = %{version}-%{release}
67 Requires:       libstdc++-devel
68
69 %description devel
70 Header files for Firebird library.
71
72 %description devel -l pl
73 Pliki nag³ówkowe biblioteki Firebird.
74
75 %package static
76 Summary:        Static Firebird library
77 Summary(pl):    Statyczna biblioteka Firebird
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static Firebird library (libgds).
83
84 %description static -l pl
85 Statyczna biblioteka Firebird (libgds).
86
87 %package doc
88 Summary:        Extensive InterBase and Firebird documentation
89 Summary(pl):    Obszerna dokumentacja do baz InterBase i Firebird
90 Group:          Documentation
91
92 %description doc
93 Extensive InterBase and Firebird documentation.
94
95 %description doc -l pl
96 Obszerna dokumentacja do baz InterBase i Firebird.
97
98 %prep
99 %setup -q -n firebird-%{version}
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103 %patch3 -p1
104 %patch4 -p1
105 # incomplete, 64-bit port is broken
106 #%patch5 -p1
107 %patch6 -p1
108
109 install -d docs/{IB3.0,IB4.0,IB6.0}
110 unzip -q %{SOURCE2} -d docs/IB6.0
111 tar xzf %{SOURCE3} -C docs/IB4.0
112 unzip -q %{SOURCE4} -d docs/IB3.0
113 # standardize extension, also avoids gzipping by compress-doc
114 mv -f docs/IB6.0/LANGREF.{PDF,pdf}
115
116 %build
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120
121 %configure \
122         --prefix=%{ibdir} \
123         %{?debug:--enable-debug}
124 # --enable-superserver
125
126 %{__make} -j1 \
127         PROD_FLAGS="%{rpmcflags} -DNDEBUG -DLINUX -pipe -MMD -fPIC" \
128         DEV_FLAGS="%{rpmcflags} -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -fPIC -Wall -Wno-switch" \
129         LIB_LINK_RPATH_LINE= \
130         LIB_CLIENT_LINK_OPTIONS="-lpthread"
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} -C src -f ../gen/Makefile.install buildImageDir
136
137 install -d $RPM_BUILD_ROOT{%{ibdir},%{_libdir},%{_includedir}} \
138         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
139 install gen/firebird/lib/libfb*.a $RPM_BUILD_ROOT%{_libdir}
140 cd gen/buildroot/%{ibdir}
141
142 cp -af UDF bin help intl aliases.conf firebird.conf firebird.msg security.fdb \
143         $RPM_BUILD_ROOT%{ibdir}
144 install include/* $RPM_BUILD_ROOT%{_includedir}
145 cp -df lib/* $RPM_BUILD_ROOT%{_libdir}
146 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
147
148 # or libfbembed?
149 ln -sf libfbclient.so.1.5.0 $RPM_BUILD_ROOT%{_libdir}/libgds.so.0
150 ln -sf libfbclient.so.1 $RPM_BUILD_ROOT%{_libdir}/libgds.so
151
152 ln -sf libfbstatic.a $RPM_BUILD_ROOT%{_libdir}/libgds.a
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   lib -p /sbin/ldconfig
158 %postun lib -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 %doc doc/{sql.extensions,Firebird_conf.txt,README.user*,WhatsNew,fb2-todo.txt}
163 %attr(755,root,root) %{_libdir}/libib_util.so
164 %dir %{ibdir}
165 %attr(755,root,root) %{ibdir}/UDF
166 %attr(755,root,root) %{ibdir}/bin
167 %{ibdir}/help
168 %{ibdir}/intl
169 %{ibdir}/firebird.msg
170 # following files should be in /var (*.fdb) and /etc (*.conf)?
171 %{ibdir}/security.fdb
172 %{ibdir}/aliases.conf
173 %{ibdir}/firebird.conf
174
175 %files lib
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/libfbclient.so.*.*.*
178 %attr(755,root,root) %{_libdir}/libfbembed.so.*.*.*
179 # InterBase/old Firebird compatibility symlinks
180 %attr(755,root,root) %{_libdir}/libgds.so.0
181 # needed here - original libgds.so.0 didn't have soname, so some old
182 # (possibly not open-source) apps may be linked with libgds.so
183 %attr(755,root,root) %{_libdir}/libgds.so
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libfbclient.so
188 %attr(755,root,root) %{_libdir}/libfbembed.so
189 %{_includedir}/*.h
190 %{_examplesdir}/%{name}-%{version}
191
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/libfbcommon.a
195 %{_libdir}/libfbstatic.a
196 # compat link
197 %{_libdir}/libgds.a
198
199 %files doc
200 %defattr(644,root,root,755)
201 %doc docs/*
This page took 0.037625 seconds and 4 git commands to generate.