]> git.pld-linux.org Git - packages/Firebird.git/blob - Firebird.spec
- massive attack: perl -pi -e "s/^#+\%\{/#\%\%\{/"
[packages/Firebird.git] / Firebird.spec
1 Summary:        Firebird SQL Database Server and Client tools
2 Summary(pl):    Firebird - serwer baz danych SQL oraz narzêdzia klienckie
3 Name:           Firebird
4 # FirebirdCS/FirebirdSS (Classic Server/Super Server)?
5 Version:        1.0.2.908
6 Release:        1
7 License:        Interbase Public License 1.0
8 Group:          Applications/Databases
9 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/firebird/%{name}-%{version}.src.tar.gz
10 Source1:        ftp://ftp.sourceforge.net/pub/sourceforge/firebird/bootkit-%{version}.tar.gz
11 Source2:        http://www.ibphoenix.com/downloads/60All.zip
12 Source3:        http://www.ibphoenix.com/downloads/ib_4_0_docs.tar.gz
13 Source4:        http://www.ibphoenix.com/downloads/isc_docs.zip
14 # dirty "fixes" for missing error contants and conflict with isql from unixODBC
15 # (gds__bad_{limit,skip}_param are defined in supplied codes.h, but removed
16 #  by codes.h regeneration from messages.gbak(?))
17 Patch0:         %{name}-fix.patch
18 URL:            http://firebird.sourceforge.net/
19 BuildRequires:  unzip
20 Requires:       %{name}-lib = %{version}
21 # see firebird-*/jrd/{common.h,gds.h,ibase.h} if you want to add support for more
22 ExclusiveArch:  %{ix86}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         ibdir   %{_libdir}/interbase
26
27 %description
28 Firebird is a powerful, high-performance relational database designed
29 to be embedded into applications on multiple platforms.
30
31 %description -l pl
32 Firebird jest potê¿nym, wysoko wydajnym systemem relacyjnych baz
33 danych zaprojektowanym do osadzania w aplikacjach na wielu
34 platformach.
35
36 %package lib
37 Summary:        Firebird shared library
38 Summary(pl):    Biblioteka wspó³dzielona Firebird
39 Group:          Libraries
40
41 %description lib
42 Firebird shared library (libgds).
43
44 %description lib -l pl
45 Biblioteka wspó³dzielona Firebird (libgds).
46
47 %package devel
48 Summary:        Header files for Firebird library
49 Summary(pl):    Pliki nag³ówkowe biblioteki Firebird
50 Group:          Development/Libraries
51 Requires:       %{name}-lib = %{version}
52
53 %description devel
54 Header files for Firebird library.
55
56 %description devel -l pl
57 Pliki nag³ówkowe biblioteki Firebird.
58
59 %package static
60 Summary:        Static Firebird library
61 Summary(pl):    Statyczna biblioteka Firebird
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}
64
65 %description static
66 Static Firebird library (libgds).
67
68 %description static -l pl
69 Statyczna biblioteka Firebird (libgds).
70
71 %package doc
72 Summary:        Extensive InterBase and Firebird documentation
73 Summary(pl):    Obszerna dokumentacja do baz InterBase i Firebird
74 Group:          Documentation
75
76 %description doc
77 Extensive InterBase and Firebird documentation.
78
79 %description doc -l pl
80 Obszerna dokumentacja do baz InterBase i Firebird.
81
82 %prep
83 %setup -q -n firebird-%{version} -a1
84 %patch0 -p1
85
86 install -d docs/{IB3.0,IB4.0,IB6.0}
87 unzip -q %{SOURCE2} -d docs/IB6.0
88 tar xzf %{SOURCE3} -C docs/IB4.0
89 unzip -q %{SOURCE4} -d docs/IB3.0
90 # standardize extension, also avoids gzipping by compress-doc
91 mv -f docs/IB6.0/LANGREF.{PDF,pdf}
92
93 %build
94 INTERBASE=/usr/lib/interbase; export INTERBASE
95 echo 'y' | ./Configure.sh PROD
96 . ./Configure_SetupEnv.sh
97
98 %{__make} firebird \
99         CC="%{__cc}" \
100         PROD_CFLAGS="%{rpmcflags} -fpic -DFLINTSTONE"
101
102 # classic/super - what's the difference?
103 #%%{__make} super_firebird
104
105 #-Isource/interbase/include"
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 INTERBASE=/usr/lib/interbase; export INTERBASE
110 . ./Configure_SetupEnv.sh
111
112 %{__make} buildclassicimage -f firebird/install/linux/Makefile
113
114 install -d $RPM_BUILD_ROOT{%{ibdir},%{_libdir},%{_includedir}} \
115         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
116 cd buildroot/opt/interbase
117 rm -f bin/isc4.gbak
118 cp -af UDF bin help intl interbase.msg isc4.gdb isc_config \
119         $RPM_BUILD_ROOT%{ibdir}
120 install include/* $RPM_BUILD_ROOT%{_includedir}
121 install lib/* $RPM_BUILD_ROOT%{_libdir}
122 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc builds_win32/install/{*License,Readme}.txt
130 %attr(755,root,root) %{_libdir}/libib_util.so
131 %dir %{ibdir}
132 %attr(755,root,root) %{ibdir}/UDF
133 %attr(755,root,root) %{ibdir}/bin
134 %{ibdir}/help
135 %{ibdir}/intl
136 %{ibdir}/interbase.msg
137 # following two files should be in /var and /etc resp.?
138 %{ibdir}/isc4.gdb
139 %{ibdir}/isc_config
140
141 %files lib
142 %defattr(644,root,root,755)
143 # .so link needed here - library doesn't have SONAME
144 %attr(755,root,root) %{_libdir}/libgds.so*
145
146 %files devel
147 %defattr(644,root,root,755)
148 %{_includedir}/*
149 %{_examplesdir}/%{name}-%{version}
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libgds.a
154
155 %files doc
156 %defattr(644,root,root,755)
157 %doc docs/*
This page took 0.043043 seconds and 4 git commands to generate.