]> git.pld-linux.org Git - packages/Firebird.git/blob - Firebird.spec
6d913c0127aa584fa1cc922d0e8310c3073b5d4c
[packages/Firebird.git] / Firebird.spec
1 # TODO:
2 # - kill unaligned accesses (create_db,gpre_current,gbak_static,isql_static) on alpha
3 # - create classic server/super server subpackages and drop bcond
4 #   (see firebird2 on debian how to do it)
5 %bcond_with     ss      # Super Server
6 Summary:        Firebird SQL Database Server and Client tools
7 Summary(de):    Firebird - relationalen Open-Source- Datenbankmanagementsystems
8 Summary(pl):    Firebird - serwer baz danych SQL oraz narzêdzia klienckie
9 Name:           Firebird
10 # FirebirdCS/FirebirdSS (Classic Server/Super Server)?
11 Version:        1.5.3.4870
12 Release:        7
13 License:        Interbase Public License 1.0
14 Group:          Applications/Databases
15 Source0:        http://dl.sourceforge.net/firebird/firebird-%{version}.tar.bz2
16 # Source0-md5:  559d005ab6622274f9448687f930393c
17 Source1:        http://www.ibphoenix.com/downloads/60All.zip
18 # Source1-md5:  f86a132012361cd4ae88563105741a4c
19 Source2:        http://www.ibphoenix.com/downloads/ib_4_0_docs.tar.gz
20 # Source2-md5:  f4176d5dec952ee774bb8ee74c1f715d
21 Source3:        http://www.ibphoenix.com/downloads/isc_docs.zip
22 # Source3-md5:  66eef71c188215d10988788282c014a7
23 Source4:        firebird.init
24 Source5:        firebird.sysconfig
25 Source6:        firebird.inetd
26 Patch0:         %{name}-chmod.patch
27 Patch1:         %{name}-editline.patch
28 Patch2:         %{name}-va.patch
29 Patch3:         %{name}-morearchs.patch
30 Patch4:         %{name}-gcc4.patch
31 Patch5:         %{name}-fix-os-detection.dpatch
32 Patch6:         %{name}-fix-pthreads-detect.dpatch
33 Patch7:         %{name}-link-with-g++.dpatch
34 Patch8:         %{name}-no-custom-errno-and-sys_XXerrXX.dpatch
35 Patch9:         %{name}-opt-bypass-redundant-sort.dpatch
36 Patch10:        %{name}-security-remote-preauth-crash.dpatch
37 Patch11:        %{name}-separate-file-and-sem-perms.dpatch
38 Patch12:        %{name}-ppc.patch
39 URL:            http://www.firebirdsql.org/
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  bison
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  ncurses-devel
46 BuildRequires:  rpmbuild(macros) >= 1.268
47 BuildRequires:  unzip
48 Requires:       %{name}-lib = %{version}-%{release}
49 %if %{with ss}
50 Requires(post,preun):   /sbin/chkconfig
51 Requires:       rc-scripts
52 %endif
53 # official ports are x86, sparc and x86_64
54 # alpha and ppc added in morearchs patch
55 # see morearchs patch if you want to add support for more archs
56 ExclusiveArch:  %{ix86} %{x8664} sparc sparcv9 alpha ppc
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         ibdir   %{_libdir}/interbase
60 %define         specflags       -fno-strict-aliasing
61 %define         debugcflags     -O1 -g -Wall -fno-strict-aliasing
62
63 %description
64 Firebird is a powerful, high-performance relational database designed
65 to be embedded into applications on multiple platforms.
66
67 %description -l pl
68 Firebird jest potê¿nym, wysoko wydajnym systemem relacyjnych baz
69 danych zaprojektowanym do osadzania w aplikacjach na wielu
70 platformach.
71
72 %description -l de
73 Firebird ist der Open-Source-Spin-Off des weiterhin kommerziell von
74 Borland vertriebenen relationalen Datenbankmanagementsystemes
75 InterBase. Die Abspaltung erfolgte im Jahre 2000 als kurz vor Freigabe
76 der Version 6 des kommerziellen Vorgängers Interbase bei Borland
77 ernsthafte Überlegungen im Gange waren, die Weiterentwicklung
78 einzustellen.
79
80 Aus Interbase 6.0 wurde Firebird 1.0, wobei dies als eine
81 Bugfix-Version mit nur wenigen Erweiterungen angesehen werden kann.
82 Eine Erweiterung von Firebird 1.0 ist der 64-Bit File I/O, so dass
83 auch Datenbankdateien über 2GB erzeugt werden können.
84
85 %package lib
86 Summary:        Firebird shared library
87 Summary(pl):    Biblioteka wspó³dzielona Firebird
88 Group:          Libraries
89
90 %description lib
91 Firebird shared library (libgds).
92
93 %description lib -l pl
94 Biblioteka wspó³dzielona Firebird (libgds).
95
96 %package devel
97 Summary:        Header files for Firebird library
98 Summary(pl):    Pliki nag³ówkowe biblioteki Firebird
99 Group:          Development/Libraries
100 Requires:       %{name}-lib = %{version}-%{release}
101 Requires:       libstdc++-devel
102
103 %description devel
104 Header files for Firebird library.
105
106 %description devel -l pl
107 Pliki nag³ówkowe biblioteki Firebird.
108
109 %package static
110 Summary:        Static Firebird library
111 Summary(pl):    Statyczna biblioteka Firebird
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114
115 %description static
116 Static Firebird library (libgds).
117
118 %description static -l pl
119 Statyczna biblioteka Firebird (libgds).
120
121 %package doc
122 Summary:        Extensive InterBase and Firebird documentation
123 Summary(pl):    Obszerna dokumentacja do baz InterBase i Firebird
124 Group:          Documentation
125
126 %description doc
127 Extensive InterBase and Firebird documentation.
128
129 %description doc -l pl
130 Obszerna dokumentacja do baz InterBase i Firebird.
131
132 %prep
133 %setup -q -n firebird-%{version}
134 %patch0 -p1
135 %patch1 -p1
136 %patch2 -p1
137 %patch3 -p1
138 %patch4 -p1
139 %patch5 -p1
140 %patch6 -p1
141 %patch7 -p1
142 %patch8 -p1
143 %patch9 -p1
144 %patch10 -p1
145 %patch11 -p1
146 %patch12 -p1
147 install -d docs/{IB3.0,IB4.0,IB6.0}
148 unzip -q %{SOURCE1} -d docs/IB6.0
149 tar xzf %{SOURCE2} -C docs/IB4.0
150 unzip -q %{SOURCE3} -d docs/IB3.0
151 # standardize extension, also avoids gzipping by compress-doc
152 mv -f docs/IB6.0/LANGREF.{PDF,pdf}
153
154 # force rebuild
155 rm -f src/dsql/parse.cpp
156
157 %build
158 cd src/extern/editline
159 cp -f /usr/share/automake/config.* .
160 %{__autoconf}
161 cd ../../..
162 %{__libtoolize}
163 %{__aclocal}
164 %{__autoconf}
165
166 %configure \
167         %{?with_ss:--enable-superserver} \
168         --prefix=%{ibdir} \
169         %{?debug:--enable-debug}
170
171 # OPTFLAGS for editline
172 export OPTFLAGS="%{rpmcflags}"
173 DARCH=""
174 %ifarch %{x8664}
175 DARCH="-DAMD64"
176 %endif
177 %ifarch sparc sparcv9
178 DARCH="-Dsparc"
179 %endif
180 %ifarch ppc
181 DARCH="-DPPC"
182 %endif
183
184 %{__make} -j1 \
185         CC="%{__cc}" \
186         CXX="%{__cxx}" \
187         PROD_FLAGS="%{rpmcflags} -DNDEBUG -DLINUX -pipe -MMD -fPIC $DARCH" \
188         DEV_FLAGS="%{rpmcflags} -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -fPIC -Wall -Wno-switch $DARCH" \
189         LIB_LINK_RPATH_LINE= \
190         LIB_CLIENT_LINK_OPTIONS="-lpthread"
191
192 # my name is hack. dirty hack.
193 # why isn't that build in previous make call?
194 %{__make} -C src -f ../gen/Makefile.libfbembed libfbembed \
195         CC="%{__cc}" \
196         CXX="%{__cxx}" \
197         PROD_FLAGS="%{rpmcflags} -DNDEBUG -DLINUX -pipe -MMD -fPIC $DARCH" \
198         DEV_FLAGS="%{rpmcflags} -DLINUX -DDEBUG_GDS_ALLOC -pipe -MMD -fPIC -Wall -Wno-switch $DARCH" \
199         LIB_LINK_RPATH_LINE= \
200         LIB_CLIENT_LINK_OPTIONS="-lpthread"
201
202 # fb_lock_mgr is started during build - try to stop it (if /proc is mounted...)
203 /sbin/fuser -k gen/firebird/bin/fb_lock_mgr 2>/dev/null || :
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207
208 %{__make} -C src -f ../gen/Makefile.install buildImageDir
209
210 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig/rc-inetd}
211 install -d $RPM_BUILD_ROOT{%{ibdir},%{_libdir},%{_includedir}} \
212         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
213
214 install gen/firebird/lib/libfb*.a $RPM_BUILD_ROOT%{_libdir}
215 install gen/firebird/lib/libfbembed.so* $RPM_BUILD_ROOT%{_libdir}
216 cd gen/buildroot/%{ibdir}
217
218 cp -af UDF bin help intl aliases.conf firebird.conf firebird.msg security.fdb \
219         $RPM_BUILD_ROOT%{ibdir}
220 install include/* $RPM_BUILD_ROOT%{_includedir}
221 cp -df lib/* $RPM_BUILD_ROOT%{_libdir}
222 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
223
224 # or libfbembed?
225 ln -sf libfbclient.so.1 $RPM_BUILD_ROOT%{_libdir}/libgds.so.0
226 ln -sf libfbclient.so.1 $RPM_BUILD_ROOT%{_libdir}/libgds.so
227
228 ln -sf libfbstatic.a $RPM_BUILD_ROOT%{_libdir}/libgds.a
229
230 install %{SOURCE4}      $RPM_BUILD_ROOT/etc/rc.d/init.d/firebird
231 install %{SOURCE5}      $RPM_BUILD_ROOT/etc/sysconfig/firebird
232 install %{SOURCE6}      $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/firebird
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %pre
238 %groupadd -g 145 firebird
239 %useradd -u 145 -d %{ibdir} -s /bin/sh -g firebird -c "Firebird Server" firebird
240
241 %if %{with ss}
242 %post
243 /sbin/chkconfig --add firebird
244 %service firebird restart
245
246 %preun
247 if [ "$1" = "0" ]; then
248         %service firebird stop
249         /sbin/chkconfig --del firebird
250 fi
251 %endif
252
253 %postun
254 if [ "$1" = "0" ]; then
255         %userremove firebird
256         %groupremove firebird
257 fi
258
259 %post   lib -p /sbin/ldconfig
260 %postun lib -p /sbin/ldconfig
261
262 %files
263 %defattr(644,root,root,755)
264 %doc doc/{sql.extensions,Firebird_conf.txt,README.user*,WhatsNew,fb2-todo.txt}
265 %attr(755,root,root) %{_libdir}/libib_util.so
266 %dir %attr(770,root,firebird) %{ibdir}
267 %attr(755,root,root) %{ibdir}/UDF
268 %attr(755,root,root) %{ibdir}/bin
269 %{ibdir}/help
270 %dir %attr(770,root,firebird) %{ibdir}/intl
271 %attr(755,root,root) %{ibdir}/intl/fbintl
272 %{ibdir}/firebird.msg
273 # following files should be in /var (*.fdb) and /etc (*.conf)?
274 %attr(660,root,firebird) %config(noreplace) %verify(not md5 mtime size) %{ibdir}/security.fdb
275 %attr(640,root,firebird) %config(noreplace) %verify(not md5 mtime size) %{ibdir}/aliases.conf
276 %attr(640,root,firebird) %config(noreplace) %verify(not md5 mtime size) %{ibdir}/firebird.conf
277 %if %{with ss}
278 %attr(754,root,root) /etc/rc.d/init.d/firebird
279 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/firebird
280 %else
281 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/firebird
282 %endif
283
284 %files lib
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_libdir}/libfbclient.so.*.*.*
287 %attr(755,root,root) %{_libdir}/libfbembed.so.*.*.*
288 # InterBase/old Firebird compatibility symlinks
289 %attr(755,root,root) %{_libdir}/libgds.so.0
290 # needed here - original libgds.so.0 didn't have soname, so some old
291 # (possibly not open-source) apps may be linked with libgds.so
292 %attr(755,root,root) %{_libdir}/libgds.so
293
294 %files devel
295 %defattr(644,root,root,755)
296 %attr(755,root,root) %{_libdir}/libfbclient.so
297 %attr(755,root,root) %{_libdir}/libfbembed.so
298 %{_includedir}/*.h
299 %{_examplesdir}/%{name}-%{version}
300
301 %files static
302 %defattr(644,root,root,755)
303 %{_libdir}/libfbcommon.a
304 %{_libdir}/libfbstatic.a
305 # compat link
306 %{_libdir}/libgds.a
307
308 %files doc
309 %defattr(644,root,root,755)
310 %doc docs/*
This page took 0.039152 seconds and 2 git commands to generate.