]> git.pld-linux.org Git - packages/Firebird.git/blob - Firebird.spec
56a583146600a3724d8ef105fa43483e982f5974
[packages/Firebird.git] / Firebird.spec
1 Summary:        Firebird SQL Database Server and Client tools
2 Summary(pl):    Firebird - serwer baz danych SQL oraz narzêdzia klienckie
3 Name:           Firebird
4 # FirebirdCS/FirebirdSS (Classic Server/Super Server)?
5 Version:        1.0.2.908
6 Release:        1
7 License:        Interbase Public License 1.0
8 Group:          Applications/Databases
9 Source0:        http://dl.sourceforge.net/firebird/%{name}-%{version}.src.tar.gz
10 # Source0-md5: 8ca9aac6cfe2670659d00bb2decb3456
11 Source1:        http://dl.sourceforge.net/firebird/bootkit-%{version}.tar.gz
12 # Source1-md5: 3ce1d058d568242843fa0f92d5ae7018
13 Source2:        http://www.ibphoenix.com/downloads/60All.zip
14 Source3:        http://www.ibphoenix.com/downloads/ib_4_0_docs.tar.gz
15 # Source3-md5: f4176d5dec952ee774bb8ee74c1f715d
16 Source4:        http://www.ibphoenix.com/downloads/isc_docs.zip
17 # dirty "fixes" for missing error contants and conflict with isql from unixODBC
18 # (gds__bad_{limit,skip}_param are defined in supplied codes.h, but removed
19 #  by codes.h regeneration from messages.gbak(?))
20 Patch0:         %{name}-fix.patch
21 URL:            http://firebird.sourceforge.net/
22 BuildRequires:  unzip
23 Requires:       %{name}-lib = %{version}
24 # see firebird-*/jrd/{common.h,gds.h,ibase.h} if you want to add support for more
25 ExclusiveArch:  %{ix86}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         ibdir   %{_libdir}/interbase
29
30 %description
31 Firebird is a powerful, high-performance relational database designed
32 to be embedded into applications on multiple platforms.
33
34 %description -l pl
35 Firebird jest potê¿nym, wysoko wydajnym systemem relacyjnych baz
36 danych zaprojektowanym do osadzania w aplikacjach na wielu
37 platformach.
38
39 %package lib
40 Summary:        Firebird shared library
41 Summary(pl):    Biblioteka wspó³dzielona Firebird
42 Group:          Libraries
43
44 %description lib
45 Firebird shared library (libgds).
46
47 %description lib -l pl
48 Biblioteka wspó³dzielona Firebird (libgds).
49
50 %package devel
51 Summary:        Header files for Firebird library
52 Summary(pl):    Pliki nag³ówkowe biblioteki Firebird
53 Group:          Development/Libraries
54 Requires:       %{name}-lib = %{version}
55
56 %description devel
57 Header files for Firebird library.
58
59 %description devel -l pl
60 Pliki nag³ówkowe biblioteki Firebird.
61
62 %package static
63 Summary:        Static Firebird library
64 Summary(pl):    Statyczna biblioteka Firebird
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}
67
68 %description static
69 Static Firebird library (libgds).
70
71 %description static -l pl
72 Statyczna biblioteka Firebird (libgds).
73
74 %package doc
75 Summary:        Extensive InterBase and Firebird documentation
76 Summary(pl):    Obszerna dokumentacja do baz InterBase i Firebird
77 Group:          Documentation
78
79 %description doc
80 Extensive InterBase and Firebird documentation.
81
82 %description doc -l pl
83 Obszerna dokumentacja do baz InterBase i Firebird.
84
85 %prep
86 %setup -q -n firebird-%{version} -a1
87 %patch0 -p1
88
89 install -d docs/{IB3.0,IB4.0,IB6.0}
90 unzip -q %{SOURCE2} -d docs/IB6.0
91 tar xzf %{SOURCE3} -C docs/IB4.0
92 unzip -q %{SOURCE4} -d docs/IB3.0
93 # standardize extension, also avoids gzipping by compress-doc
94 mv -f docs/IB6.0/LANGREF.{PDF,pdf}
95
96 %build
97 INTERBASE=/usr/lib/interbase; export INTERBASE
98 echo 'y' | ./Configure.sh PROD
99 . ./Configure_SetupEnv.sh
100
101 %{__make} firebird \
102         CC="%{__cc}" \
103         PROD_CFLAGS="%{rpmcflags} -fpic -DFLINTSTONE"
104
105 # classic/super - what's the difference?
106 #%%{__make} super_firebird
107
108 #-Isource/interbase/include"
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 INTERBASE=/usr/lib/interbase; export INTERBASE
113 . ./Configure_SetupEnv.sh
114
115 %{__make} buildclassicimage -f firebird/install/linux/Makefile
116
117 install -d $RPM_BUILD_ROOT{%{ibdir},%{_libdir},%{_includedir}} \
118         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
119 cd buildroot/opt/interbase
120 rm -f bin/isc4.gbak
121 cp -af UDF bin help intl interbase.msg isc4.gdb isc_config \
122         $RPM_BUILD_ROOT%{ibdir}
123 install include/* $RPM_BUILD_ROOT%{_includedir}
124 install lib/* $RPM_BUILD_ROOT%{_libdir}
125 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc builds_win32/install/{*License,Readme}.txt
133 %attr(755,root,root) %{_libdir}/libib_util.so
134 %dir %{ibdir}
135 %attr(755,root,root) %{ibdir}/UDF
136 %attr(755,root,root) %{ibdir}/bin
137 %{ibdir}/help
138 %{ibdir}/intl
139 %{ibdir}/interbase.msg
140 # following two files should be in /var and /etc resp.?
141 %{ibdir}/isc4.gdb
142 %{ibdir}/isc_config
143
144 %files lib
145 %defattr(644,root,root,755)
146 # .so link needed here - library doesn't have SONAME
147 %attr(755,root,root) %{_libdir}/libgds.so*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %{_includedir}/*
152 %{_examplesdir}/%{name}-%{version}
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libgds.a
157
158 %files doc
159 %defattr(644,root,root,755)
160 %doc docs/*
This page took 0.04654 seconds and 2 git commands to generate.