]> git.pld-linux.org Git - packages/Firebird.git/blob - Firebird.spec
- added some InterBase/Firebird docs (as subpackage - it's huge, even package)
[packages/Firebird.git] / Firebird.spec
1 Summary:        Firebird SQL Database Server and Client tools
2 Summary(pl):    Firebird - serwer baz danych SQL oraz narzêdzia klienckie
3 Name:           Firebird
4 # FirebirdCS/FirebirdSS (Classic Server/Super Server)?
5 Version:        1.0.0.796
6 Release:        1
7 License:        Interbase Public License 1.0
8 Group:          Applications/Databases
9 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/firebird/%{name}-%{version}.src.tar.gz
10 Source1:        ftp://ftp.sourceforge.net/pub/sourceforge/firebird/bootkit-%{version}.tar.gz
11 Source2:        http://www.ibphoenix.com/downloads/60All.zip
12 Source3:        http://www.ibphoenix.com/downloads/ib_4_0_docs.tar.gz
13 Source4:        http://www.ibphoenix.com/downloads/isc_docs.zip
14 # missing isc4.gbak generated by: make isql || : ; make gdef gsec secutity_db
15 Source5:        %{name}-isc4.gbak
16 # missing save.c generated by gpre after building pixar w/o save.o and then other stuff
17 Patch0:         %{name}-bootkit-missing.patch
18 # dirty "fixes" for missing error contants and conflict with isql from unixODBC
19 Patch1:         %{name}-fix.patch
20 # ksh supports only [! ] globs, not [^ ]
21 Patch2:         %{name}-ksh.patch
22 URL:            http://firebird.sourceforge.net/
23 BuildRequires:  unzip
24 Requires:       %{name}-lib = %{version}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         ibdir   %{_libdir}/interbase
28
29 %description
30 Firebird is a powerful, high-performance relational database designed
31 to be embedded into applications on multiple platforms.
32
33 %description -l pl
34 Firebird jest potê¿nym, wysoko wydajnym systemem relacyjnych baz
35 danych zaprojektowanym do osadzania w aplikacjach na wielu
36 platformach.
37
38 %package lib
39 Summary:        Firebird shared library
40 Summary(pl):    Biblioteka wspó³dzielona Firebird
41 Group:          Libraries
42
43 %description lib
44 Firebird shared library (libgds).
45
46 %description lib -l pl
47 Biblioteka wspó³dzielona Firebird (libgds).
48
49 %package devel
50 Summary:        Header files for Firebird library
51 Summary(pl):    Pliki nag³ówkowe biblioteki Firebird
52 Group:          Development/Libraries
53 Requires:       %{name}-lib = %{version}
54
55 %description devel
56 Header files for Firebird library.
57
58 %description devel -l pl
59 Pliki nag³ówkowe biblioteki Firebird.
60
61 %package static
62 Summary:        Static Firebird library
63 Summary(pl):    Statyczna biblioteka Firebird
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}
66
67 %description static
68 Static Firebird library (libgds).
69
70 %description static -l pl
71 Statyczna biblioteka Firebird (libgds).
72
73 %package doc
74 Summary:        Extensive InterBase and Firebird documentation
75 Summary(pl):    Obszerna dokumentacja do baz InterBase i Firebird
76 Group:          Documentation
77
78 %description doc
79 Extensive InterBase and Firebird documentation.
80
81 %description doc -l pl
82 Obszerna dokumentacja do baz InterBase i Firebird.
83
84 %prep
85 %setup -q -n firebird-%{version} -a1
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 chmod u+w -R .
91 cp -f %{SOURCE5} misc/isc4.gbak
92
93 install -d docs/{IB3.0,IB4.0,IB6.0}
94 unzip -q %{SOURCE2} -d docs/IB6.0
95 tar xzf %{SOURCE3} -C docs/IB4.0
96 unzip -q %{SOURCE4} -d docs/IB3.0
97 # standardize extension, also avoids gzipping by compress-doc
98 mv -f docs/IB6.0/LANGREF.{PDF,pdf}
99
100 %build
101 INTERBASE=/usr/lib/interbase; export INTERBASE
102 echo 'y' | ./Configure.sh PROD
103 . ./Configure_SetupEnv.sh
104
105 %{__make} firebird \
106         CC="%{__cc}" \
107         PROD_CFLAGS="%{rpmcflags} -fpic -DFLINTSTONE"
108
109 # classic/super - what's the difference?
110 #%{__make} super_firebird
111
112 #-Isource/interbase/include"
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 INTERBASE=/usr/lib/interbase; export INTERBASE
117 . ./Configure_SetupEnv.sh
118
119 %{__make} buildclassicimage -f firebird/install/linux/Makefile
120
121 install -d $RPM_BUILD_ROOT{%{ibdir},%{_libdir},%{_includedir}} \
122         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
123 cd buildroot/opt/interbase
124 rm -f bin/isc4.gbak
125 cp -af UDF bin help intl interbase.msg isc4.gdb isc_config \
126         $RPM_BUILD_ROOT%{ibdir}
127 install include/* $RPM_BUILD_ROOT%{_includedir}
128 install lib/* $RPM_BUILD_ROOT%{_libdir}
129 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc builds_win32/install/{*License,Readme}.txt
137 %attr(755,root,root) %{_libdir}/libib_util.so
138 %dir %{ibdir}
139 %attr(755,root,root) %{ibdir}/UDF
140 %attr(755,root,root) %{ibdir}/bin
141 %{ibdir}/help
142 %{ibdir}/intl
143 %{ibdir}/interbase.msg
144 # following two files should be in /var and /etc resp.?
145 %{ibdir}/isc4.gdb
146 %{ibdir}/isc_config
147
148 %files lib
149 %defattr(644,root,root,755)
150 # .so link needed here - library doesn't have SONAME
151 %attr(755,root,root) %{_libdir}/libgds.so*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %{_includedir}/*
156 %{_examplesdir}/%{name}-%{version}
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libgds.a
161
162 %files doc
163 %defattr(644,root,root,755)
164 %doc docs/*
This page took 0.033341 seconds and 3 git commands to generate.