- updated for 1.5.4.4910
[packages/Firebird.git] / Firebird-security-remote-preauth-crash.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## security-remote-preauth-crash.dpatch by  <divanov@creditreform.bg>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: No description.
6
7 @DPATCH@
8 diff -urNad firebird2-1.5.3.4870~/src/jrd/unix.cpp firebird2-1.5.3.4870/src/jrd/unix.cpp
9 --- firebird2-1.5.3.4870~/src/jrd/unix.cpp      2004-03-29 06:50:11.000000000 +0300
10 +++ firebird2-1.5.3.4870/src/jrd/unix.cpp       2006-03-20 11:46:53.000000000 +0200
11 @@ -643,6 +643,8 @@
12         if (string) {
13                 ptr = string;
14                 if (length) {
15 +                        if (length >= sizeof(temp)) length = sizeof(temp) - 1;
16 +
17                         MOVE_FAST(string, temp, length);
18                         temp[length] = 0;
19                         ptr = temp;
20 @@ -651,6 +653,8 @@
21         else {
22                 ptr = file_name;
23                 if (file_length) {
24 +                        if (file_length >= sizeof(temp)) file_length = sizeof(temp) - 1;
25 +
26                         MOVE_FAST(file_name, temp, file_length);
27                         temp[file_length] = 0;
28                         ptr = temp;
This page took 0.068241 seconds and 3 git commands to generate.