]> git.pld-linux.org Git - packages/FileZilla.git/commitdiff
- 3.0.7 auto/th/FileZilla-3_0_7-1
authorPaweł Gołaszewski <blues@pld-linux.org>
Thu, 14 Feb 2008 21:46:11 +0000 (21:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    FileZilla-locales.patch -> 1.2
    FileZilla.spec -> 1.20

FileZilla-locales.patch
FileZilla.spec

index 09d675ca64fd3962e84150627df018c0104de7ce..067f3a476f531e5dacf01bade4b8de1f2a6e4fde 100644 (file)
@@ -1,9 +1,40 @@
---- ./src/interface/FileZilla.cpp.org  2007-10-17 20:22:26.000000000 +0200
-+++ ./src/interface/FileZilla.cpp      2007-10-21 21:09:28.312100761 +0200
-@@ -509,25 +509,7 @@ bool CFileZillaApp::InitSettingsDir()
+--- ./locales/Makefile.am.org  2008-02-14 00:47:56.000000000 +0100
++++ ./locales/Makefile.am      2008-02-14 22:27:31.221778064 +0100
+@@ -7,13 +7,13 @@ install-data-local: install-filezilla-ca
+ install-filezilla-catalogs: allmo
+       for i in @FILEZILLA_LINGUAS@ ; do \
+-        $(mkinstalldirs) $(DESTDIR)$(localedir)/$$i ; \
+-        $(INSTALL_DATA) $$i.mo $(DESTDIR)$(localedir)/$$i/filezilla.mo ; \
++        $(mkinstalldirs) $(DESTDIR)$(localedir)/$$i/LC_MESSAGES ; \
++        $(INSTALL_DATA) $$i.mo $(DESTDIR)$(localedir)/$$i/LC_MESSAGES/filezilla.mo ; \
+       done
+ uninstall-local:
+       for i in @FILEZILLA_LINGUAS@ ; do \
+-        rm $(DESTDIR)$(localedir)/$$i/filezilla.mo ; \
++        rm $(DESTDIR)$(localedir)/$$i/LC_MESSAGES/filezilla.mo ; \
+       done
+@@ -22,8 +22,8 @@ uninstall-local:
+ #install-wxstd-catalogs:
+ #     for i in $(WXWIN_LINGUAS) ; do \
+-#       $(mkinstalldirs) $(DESTDIR)$(localedir)/$$i ; \
+-#       $(INSTALL_DATA) wxwin/$$i.mo $(DESTDIR)$(localedir)/$$i/filezilla-wxstd.mo ; \
++#       $(mkinstalldirs) $(DESTDIR)$(localedir)/$$i/LC_MESSAGES ; \
++#       $(INSTALL_DATA) wxwin/$$i.mo $(DESTDIR)$(localedir)/$$i/LC_MESSAGES/filezilla-wxstd.mo ; \
+ #     done
+--- ./src/interface/FileZilla.cpp.org  2008-02-14 00:47:59.000000000 +0100
++++ ./src/interface/FileZilla.cpp      2008-02-14 22:23:45.254013629 +0100
+@@ -578,29 +578,7 @@ bool CFileZillaApp::InitSettingsDir()
  
  bool CFileZillaApp::LoadLocales()
  {
+-#ifndef __WXMAC__
 -      m_localesDir = GetDataDir(_T("/../locale/*/filezilla.mo"));
 -      if (m_localesDir != _T(""))
 -      {
 -                      m_localesDir += _T("locales");
 -              }
 -      }
+-#else
+-      m_localesDir = wxStandardPaths::Get().GetDataDir() + _T("/locales");
+-#endif
 +      m_localesDir = _T("/usr/share/locale/");
  
        if (m_localesDir != _T(""))
        {
---- ./src/interface/optionspage_language.cpp.org       2007-10-17 20:22:25.000000000 +0200
-+++ ./src/interface/optionspage_language.cpp   2007-10-21 21:13:01.894158243 +0200
-@@ -33,7 +33,7 @@ bool COptionsPageLanguage::LoadPage()
+--- ./src/interface/optionspage_language.cpp.org       2008-02-14 00:47:57.000000000 +0100
++++ ./src/interface/optionspage_language.cpp   2008-02-14 22:25:47.313341533 +0100
+@@ -36,7 +36,7 @@ bool COptionsPageLanguage::LoadPage()
        wxString locale;
        for (bool found = dir.GetFirst(&locale); found; found = dir.GetNext(&locale))
        {
                        continue;
  
                wxString name;
---- ./src/interface/wrapengine.cpp.org 2007-10-17 20:22:25.000000000 +0200
-+++ ./src/interface/wrapengine.cpp     2007-10-21 21:14:14.681600817 +0200
-@@ -949,7 +949,7 @@ bool CWrapEngine::LoadCache()
-               wxString locale;
-               for (bool found = dir.GetFirst(&locale); found; found = dir.GetNext(&locale))
-               {
--                      if (!wxFileName::FileExists(localesDir + locale + _T("/filezilla.mo")))
-+                      if (!wxFileName::FileExists(localesDir + locale + _T("/LC_MESSAGES/filezilla.mo")))
-                               continue;
-                       wxString name;
-@@ -957,7 +957,7 @@ bool CWrapEngine::LoadCache()
-                       if (!pInfo)
-                               continue;
--                      wxFileName fn(localesDir + locale + _T("/filezilla.mo"));
-+                      wxFileName fn(localesDir + locale + _T("/LC_MESSAGES/filezilla.mo"));
-                       wxDateTime date = fn.GetModificationTime();
-                       wxLongLong ticks = date.GetTicks();
---- ./locales/Makefile.am.org  2007-10-17 20:22:19.000000000 +0200
-+++ ./locales/Makefile.am      2007-10-21 21:11:20.075076784 +0200
-@@ -7,13 +7,13 @@ install-data-local: install-filezilla-ca
- install-filezilla-catalogs: allmo
-       for i in @FILEZILLA_LINGUAS@ ; do \
--        $(mkinstalldirs) $(DESTDIR)$(localedir)/$$i ; \
--        $(INSTALL_DATA) $$i.mo $(DESTDIR)$(localedir)/$$i/filezilla.mo ; \
-+        $(mkinstalldirs) $(DESTDIR)$(localedir)/$$i/LC_MESSAGES ; \
-+        $(INSTALL_DATA) $$i.mo $(DESTDIR)$(localedir)/$$i/LC_MESSAGES/filezilla.mo ; \
-       done
- uninstall-local:
-       for i in @FILEZILLA_LINGUAS@ ; do \
--        rm $(DESTDIR)$(localedir)/$$i/filezilla.mo ; \
-+        rm $(DESTDIR)$(localedir)/$$i/LC_MESSAGES/filezilla.mo ; \
-       done
index 267c3a3e9412120dae9db431d9e1e160b092e124..9c70ac10beec89bed7ae177c6a37af3a9a45b315 100644 (file)
@@ -9,12 +9,12 @@ Summary(pt_BR.UTF-8): Cliente FTP para o X Window
 Summary(ru.UTF-8):     FTP клиент для X Window
 Summary(uk.UTF-8):     FTP клієнт для X Window
 Name:          FileZilla
-Version:       3.0.6
+Version:       3.0.7
 Release:       1
 License:       GPL
 Group:         X11/Applications/Networking
 Source0:       http://dl.sourceforge.net/filezilla/%{name}_%{version}_src.tar.bz2
-# Source0-md5: 02e0924a6a6038f8cf47230d98b578b6
+# Source0-md5: 18ed4c2f9ba6e724c38a51d9f283527b
 Patch0:                %{name}-desktop.patch
 Patch1:                %{name}-locales.patch
 URL:           http://filezilla-project.org/
@@ -44,21 +44,15 @@ opcjami oraz intuicyjnym interfejsem.
 
 cd locales
 mv bg{_BG,}.po
-mv ca{_ES,}.po
 mv cs{_CZ,}.po
 mv da{_DK,}.po
-mv de{_DE,}.po
-mv el{_GR,}.po
-mv es{_ES,}.po
 mv et{_EE,}.po
 mv eu{_ES,}.po
 mv fi{_FI,}.po
-mv fr{_FR,}.po
 mv gl{_ES,}.po
 mv he{_IL,}.po
 mv hu{_HU,}.po
 mv id{_ID,}.po
-mv it{_IT,}.po
 mv ja{_JP,}.po
 mv km{_KH,}.po
 mv ko{_KR,}.po
@@ -66,15 +60,12 @@ mv lt{_LT,}.po
 mv lv{_LV,}.po
 mv mk{_MK,}.po
 mv nb{_NO,}.po
-mv nl{_NL,}.po
 mv pl{_PL,}.po
 mv pt{_PT,}.po
 mv ro{_RO,}.po
-mv ru{_RU,}.po
 mv sk{_SK,}.po
 mv sl{_SI,}.po
-mv sv{_SE,}.po
-mv tr{_TR,}.po
+mv th{_TH,}.po
 
 %build
 %{__libtoolize}
This page took 0.13343 seconds and 4 git commands to generate.