]> git.pld-linux.org Git - packages/Field3D.git/commitdiff
force c++14 standard to fix build with gcc 11
authorJan Palus <atler@pld-linux.org>
Tue, 10 Aug 2021 15:55:03 +0000 (17:55 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 10 Aug 2021 15:55:03 +0000 (17:55 +0200)
gcc 11 defaults to c++17 which breaks build due to dynamic throw clauses
still used in Field3D (indirectly through OpenEXR headers). use c++14
instead which gcc defaulted to at the time last version was released.

Field3D.spec

index 5aaacc0b9a498fe02aa0042794767c98e021cc5f..4c48788c98cc2a38d46b3c480ecef2402b6d770b 100644 (file)
@@ -66,6 +66,7 @@ Dokumentacja API biblioteki Field3D.
 # main build system is scons, but there is cmake alternative, which is slightly more usable in rpm building
 install -d build
 cd build
+export CXXFLAGS="%{rpmcxxflags} %{rpmcppflags} -std=c++14"
 %cmake ..
 
 %{__make}
This page took 0.182248 seconds and 4 git commands to generate.