]> git.pld-linux.org Git - packages/Field3D.git/blob - Field3D.spec
boost rebuild
[packages/Field3D.git] / Field3D.spec
1 # TODO: (optional) MPI?
2 Summary:        Field3D - open source library for storing voxel data
3 Summary(pl.UTF-8):      Field3D - mająca otwarte źródła biblioteka do przechowywania danych vokseli
4 Name:           Field3D
5 Version:        1.7.3
6 Release:        3
7 License:        BSD
8 Group:          Libraries
9 #Source0Download: https://github.com/imageworks/Field3D/releases
10 Source0:        https://github.com/imageworks/Field3D/archive/v%{version}/%{name}-%{version}.tar.gz
11 # Source0-md5:  536198b1b4840a5b35400ccf05d4431c
12 URL:            http://opensource.imageworks.com/?p=field3d
13 BuildRequires:  cmake >= 2.8
14 BuildRequires:  boost-devel >= 1.34.0
15 BuildRequires:  doxygen
16 BuildRequires:  hdf5-devel >= 1.8
17 BuildRequires:  ilmbase-devel >= 1.0.1
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  rpmbuild(macros) >= 1.605
20 Requires:       hdf5 >= 1.8
21 Requires:       ilmbase >= 1.0.1
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Field3D is an open source library for storing voxel data. It provides
26 C++ classes that handle in-memory storage and a file format based on
27 HDF5 that allows the C++ objects to be written to and read from disk.
28
29 %description -l pl.UTF-8
30 Field3D to mająca otwarte źródła biblioteka do przechowywania danych
31 vokseli. Udostępnia klasy C++ obsługujące przechowywanie ich w pamięci
32 oraz format plików oparty na HDF5 pozwalający na zapis i odczyt
33 obiektów C++ z dysku.
34
35 %package devel
36 Summary:        Header files for Field3D library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Field3D
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       boost-devel >= 1.34.0
41 Requires:       hdf5-devel >= 1.8
42 Requires:       ilmbase-devel >= 1.0.1
43 Requires:       libstdc++-devel
44
45 %description devel
46 Header files for Field3D library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki Field3D.
50
51 %package apidocs
52 Summary:        Field3D API documentation
53 Summary(pl.UTF-8):      Dokumentacja API biblioteki Field3D
54 Group:          Documentation
55 BuildArch:      noarch
56
57 %description apidocs
58 API and internal documentation for Field3D library.
59
60 %description apidocs -l pl.UTF-8
61 Dokumentacja API biblioteki Field3D.
62
63 %prep
64 %setup -q
65
66 %build
67 # main build system is scons, but there is cmake alternative, which is slightly more usable in rpm building
68 install -d build
69 cd build
70 export CXXFLAGS="%{rpmcxxflags} %{rpmcppflags} -std=c++14"
71 %cmake ..
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/docs
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc CHANGES COPYING README
92 %attr(755,root,root) %{_bindir}/f3dinfo
93 %attr(755,root,root) %{_libdir}/libField3D.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libField3D.so.1.7
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libField3D.so
99 %{_includedir}/Field3D
100
101 %files apidocs
102 %defattr(644,root,root,755)
103 %doc docs/html/*.{css,html,js,png}
This page took 0.146172 seconds and 3 git commands to generate.