]> git.pld-linux.org Git - packages/FHS.git/blob - FHS.spec
f6f8c5faba1a97ba7a0331da5124bec61450214b
[packages/FHS.git] / FHS.spec
1 # NOTE
2 # - don't use %{_*dir} macros for paths defined by FHS
3 # - do not add any dependencies to this pkg, FHS should be the first package being installed
4 # - do not use any other user/group than "root", as then we have to depend on "setup" package.
5 #   But: root %attr+chown in %post means integrity verification (rpm -V) error.
6 #   Maybe use non-root %attr+numeric chown in %post (without setup dependency)? The only disadvantage
7 #   seems to be a warning message on install.
8 Summary:        Basic FHS %{version} filesystem layout
9 Summary(de.UTF-8):      Grundlegende Dateisystemstruktur
10 Summary(fr.UTF-8):      Arborescence de base du système de fichiers
11 Summary(pl.UTF-8):      Podstawowy układ katalogów systemu Linux zgodny z FHS %{version}
12 Summary(tr.UTF-8):      Temel dosya sistemi yapısı
13 Name:           FHS
14 Version:        3.0
15 Release:        1
16 License:        GPL
17 Group:          Base
18 URL:            http://refspecs.linuxfoundation.org/fhs.shtml
19 # list of languages for localized man pages directories
20 Source0:        locale-dirs
21 BuildRequires:  mktemp
22 BuildRequires:  rpmbuild(macros) >= 1.213
23 Conflicts:      setup < 2.7
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # nothing to put there
27 %define         _enable_debug_packages  0
28
29 %if "%{_lib}" == "lib64"
30 %define         with_lib64      1
31 %endif
32 %if "%{_lib}" == "libx32"
33 %define         with_libx32     1
34 %define         with_lib64      1
35 %else
36 %ifarch %{x8664}
37 # x32 as additional ABI
38 %define         with_libx32     1
39 %endif
40 %endif
41
42 # avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
43 %define         __spec_clean_body       %{nil}
44
45 # doesn't contain any files, but we're not noarch package
46 %define         no_install_post_strip   1
47 %define         no_install_post_chrpath 1
48 %define         no_install_post_compress_modules        1
49
50 # we have to use numeric uids/groups. see comment above
51
52 %define         gid_uucp        14
53 %define         gid_mail        12
54
55 %description
56 This package contains the basic directory layout for a Linux system,
57 including the proper permissions for the directories. This layout
58 conforms to the Filesystem Hierarchy Standard (FHS) %{version}.
59
60 %description -l de.UTF-8
61 Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
62 Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
63 Struktur entspricht dem Filesystem Hierarchy Standard (FHS) %{version}.
64
65 %description -l fr.UTF-8
66 Ce package contient l'arborescence type pour système Linux y compris
67 les permissions adéquates pour les répertoires. Cette arborescence est
68 conforme au standard "Filesystem Hierarchy Standard" (FHS) %{version}.
69
70 %description -l pl.UTF-8
71 Pakiet ten zawiera informacje o podstawowej strukturze katalogów
72 systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
73 %{version}.
74
75 %prep
76 %setup -qcT
77 cp -p %{SOURCE0} .
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 install -d \
83         $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,run,srv,sys} \
84         $RPM_BUILD_ROOT/etc/{X11,opt} \
85         $RPM_BUILD_ROOT/lib/modules \
86         $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
87         $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
88         $RPM_BUILD_ROOT/usr/share/{color/icc,dict,doc,games,info,misc,ppd,tmac,xml} \
89         $RPM_BUILD_ROOT/usr/lib/games \
90         $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{color/icc,doc,info,man},src} \
91         $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/{color/icc,misc},local,lock,log,mail,opt,run,spool,tmp,yp}
92
93 %if %{with lib64}
94 install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
95 %endif
96 %if %{with libx32}
97 install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
98 %endif
99
100 install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
101 install -d $RPM_BUILD_ROOT/usr/local/share/man/man{1,2,3,4,5,6,7,8}
102
103 > %{name}.lang
104 for mloc in $(cat locale-dirs); do
105         echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
106         for manp in man{1,2,3,4,5,6,7,8}; do
107                 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
108                 echo "%%lang($mloc) %dir /usr/share/man/${mloc}/${manp}" >> %{name}.lang
109         done
110 done
111
112 %clean
113 cd $RPM_BUILD_ROOT
114
115 check_filesystem_dirs() {
116         RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
117         TMPFILE=$(mktemp)
118         find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
119
120         # find finds also '.', so use option -B for diff
121         if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
122                 rm -rf $RPM_BUILD_ROOT
123         else
124                 echo -e "\nNot so good, some directories are not included in package\n"
125                 exit 1
126         fi
127         rm -f $TMPFILE
128 }
129 check_filesystem_dirs
130
131 %pretrans -p <lua>
132 st = posix.stat("/usr/local/share/man")
133 if st and st.type == "link" then
134     os.remove("/usr/local/share/man")
135 end
136
137 %post -p <lua>
138 --# XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
139 posix.chown("/var/mail", 0, %{gid_mail})
140 posix.chown("/var/lock", 0, %{gid_uucp})
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %dir /
145 %dir /bin
146 %dir /boot
147 %dir /dev
148 %dir /etc
149 %dir /etc/X11
150 %dir /etc/opt
151 %dir /home
152 %dir /lib
153 %dir /lib/modules
154 %dir /media
155 %dir /mnt
156 %dir /opt
157 %dir %attr(555,root,root) %verify(not group) /proc
158 %dir %attr(700,root,root) /root
159 %dir %attr(700,root,root) /root/tmp
160 %dir /run
161 %dir /sbin
162 %dir %attr(755,root,root) /srv
163 %dir /sys
164 %dir %attr(1777,root,root) /tmp
165 %dir /usr
166 %dir /usr/bin
167 %dir /usr/games
168 %dir /usr/include
169 %dir /usr/lib
170 %dir /usr/lib/games
171 %dir /usr/sbin
172 %dir /usr/share
173 %dir /usr/share/color
174 %dir /usr/share/color/icc
175 %dir /usr/share/dict
176 %dir /usr/share/doc
177 %dir /usr/share/games
178 %dir /usr/share/info
179 %dir /usr/share/man
180 %dir /usr/share/man/man[1-8]
181 %dir /usr/share/misc
182 %dir /usr/share/ppd
183 %dir /usr/share/tmac
184 %dir /usr/share/xml
185 %dir /usr/src
186 %dir /usr/local
187 %dir /usr/local/bin
188 %dir /usr/local/etc
189 %dir /usr/local/games
190 %dir /usr/local/include
191 %dir /usr/local/lib
192 %dir /usr/local/sbin
193 %dir /usr/local/share
194 %dir /usr/local/share/color
195 %dir /usr/local/share/color/icc
196 %dir /usr/local/share/doc
197 %dir /usr/local/share/info
198 %dir /usr/local/share/man
199 %dir /usr/local/share/man/man[1-8]
200 %dir /usr/local/src
201 %dir /var
202 %dir /var/cache
203 %dir /var/crash
204 %dir /var/db
205 %dir /var/games
206 %dir /var/lib
207 %dir /var/lib/color
208 %dir /var/lib/color/icc
209 %dir /var/lib/misc
210 %dir /var/local
211 %dir %attr(1771,root,root) /var/lock
212 %dir %attr(751,root,root) /var/log
213 %dir %attr(2775,root,root) /var/mail
214 %dir /var/opt
215 %dir /var/run
216 %dir /var/spool
217 %dir /var/yp
218 %dir %attr(1777,root,root) /var/tmp
219 %if %{with lib64}
220 %dir /lib64
221 %dir /usr/lib64
222 %dir /usr/lib64/games
223 %dir /usr/local/lib64
224 %endif
225 %if %{with libx32}
226 %dir /libx32
227 %dir /usr/libx32
228 %dir /usr/libx32/games
229 %dir /usr/local/libx32
230 %endif
This page took 0.041236 seconds and 2 git commands to generate.