]> git.pld-linux.org Git - packages/FHS.git/blame - FHS.spec
- added x32 arch libdirs
[packages/FHS.git] / FHS.spec
CommitLineData
2fccd05c
ER
1# NOTE
2# - don't use %{_*dir} macros for paths defined by FHS
05fbeea7
ER
3# - do not add any dependencies to this pkg, FHS should be the first package being installed
4# - do not use any other user/group than "root", as then we have to depend on "setup" package.
7807a3bf 5Summary: Basic FHS 2.3 filesystem layout
d280bbd7
ER
6Summary(de.UTF-8): Grundlegende Dateisystemstruktur
7Summary(fr.UTF-8): Arborescence de base du système de fichiers
8Summary(pl.UTF-8): Podstawowy układ katalogów systemu Linux zgodny z FHS 2.3
9Summary(tr.UTF-8): Temel dosya sistemi yapısı
b3b300be 10Name: FHS
7807a3bf 11Version: 2.3
9d2de01c 12Release: 36
15c9b486 13License: GPL
14Group: Base
8eaadcf0 15URL: http://www.pathname.com/fhs/
38ec8b96 16Source0: locale-dirs
2fccd05c 17BuildRequires: mktemp
73559f52 18BuildRequires: rpmbuild(macros) >= 1.213
05fbeea7 19Conflicts: setup < 2.7
8ad4c704 20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15c9b486 21
5a4e441c
ER
22# nothing to put there
23%define _enable_debug_packages 0
24
25# avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
26%define __spec_clean_body %{nil}
27
1a35d806 28%define _locmandir /usr/local/man
2fccd05c 29
6c95f275 30# doesn't contain any files, but we're not noarch package
99177468 31%define no_install_post_strip 1
6c95f275
ER
32%define no_install_post_chrpath 1
33%define no_install_post_compress_modules 1
0fa811e0 34
05fbeea7
ER
35# we have to use numeric uids/groups. see comment above
36
37%define gid_uucp 14
38%define gid_mail 12
39
15c9b486 40%description
aac153be 41This package contains the basic directory layout for a Linux system,
42including the proper permissions for the directories. This layout
7807a3bf 43conforms to the Filesystem Hierarchy Standard (FHS) 2.3.
15c9b486 44
fdedb1f3
JR
45%description -l de.UTF-8
46Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
47Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
7807a3bf 48Struktur entspricht dem Filesystem Hierarchy Standard (FHS) 2.3.
15c9b486 49
fdedb1f3
JR
50%description -l fr.UTF-8
51Ce package contient l'arborescence type pour système Linux y compris
52les permissions adéquates pour les répertoires. Cette arborescence est
69503c43 53conforme au standard "Filesystem Hierarchy Standard" (FHS) 2.3.
15c9b486 54
fdedb1f3
JR
55%description -l pl.UTF-8
56Pakiet ten zawiera informacje o podstawowej strukturze katalogów
57systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
7807a3bf 582.3.
aac153be 59
fdedb1f3
JR
60%description -l tr.UTF-8
61Bu paket GNU makro işleme dilini içerir. Mantıksal olarak
62ayrıştırılabilen metin dosyaları yazımı için yararlıdır.
15c9b486 63
64%prep
40188a0f 65%setup -qcT
38ec8b96 66cp -a %{SOURCE0} .
15c9b486 67
68%install
69rm -rf $RPM_BUILD_ROOT
70
d8cf4cdf
JB
71install -d \
72 $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,srv} \
73 $RPM_BUILD_ROOT/etc/{X11,opt} \
74 $RPM_BUILD_ROOT/lib/modules \
d13739ad 75 $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
d8cf4cdf 76 $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
017dd5c9 77 $RPM_BUILD_ROOT/usr/share/{dict,doc,games,info,misc,tmac,xml} \
d8cf4cdf
JB
78 $RPM_BUILD_ROOT/usr/lib/games \
79 $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{doc,info},src} \
48784dc4 80 $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/misc,local,lock,log,mail,opt,run,spool,tmp,yp}
d8cf4cdf
JB
81
82%if "%{_lib}" == "lib64"
83install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
9d2de01c
JR
84%ifarch %{x8664}
85install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
86%endif
87%endif
88
89%if "%{_lib}" == "libx32"
90install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
76796e14
JB
91%endif
92
42b7266a
ER
93install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
94install -d $RPM_BUILD_ROOT%{_locmandir}/man{1,2,3,4,5,6,7,8}
0fa811e0 95
d8cf4cdf 96# "/usr/local/share/man and /usr/local/man must be synonomous" per FHS 2.3
9d1c44e3
JB
97ln -sf ../man $RPM_BUILD_ROOT/usr/local/share/man
98
42b7266a
ER
99> %{name}.lang
100for mloc in $(cat locale-dirs); do
101 echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
102 for manp in man{1,2,3,4,5,6,7,8}; do
103 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
104 echo "%%lang($mloc) %dir /usr/share/man/${mloc}/${manp}" >> %{name}.lang
105 done
106done
107
15c9b486 108%clean
fa9aa6bf 109cd $RPM_BUILD_ROOT
0a75495b 110
2fccd05c 111check_filesystem_dirs() {
2fccd05c
ER
112 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
113 TMPFILE=$(mktemp)
48e57f98 114 find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
2fccd05c
ER
115
116 # find finds also '.', so use option -B for diff
117 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
118 rm -rf $RPM_BUILD_ROOT
119 else
120 echo -e "\nNot so good, some directories are not included in package\n"
121 exit 1
122 fi
123 rm -f $TMPFILE
124}
125check_filesystem_dirs
15c9b486 126
05fbeea7
ER
127# XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
128%post -p <lua>
129posix.chown("/var/mail", 0, %{gid_mail})
130posix.chown("/var/lock", 0, %{gid_uucp})
131
42b7266a 132%files -f %{name}.lang
bfef5768 133%defattr(644,root,root,755)
52e00ac5 134%dir /
d8cf4cdf
JB
135%dir /bin
136%dir /boot
137%dir /dev
2d4f80d5 138%dir /etc
d8cf4cdf
JB
139%dir /etc/X11
140%dir /etc/opt
b9fc8087 141%dir /home
d8cf4cdf
JB
142%dir /lib
143%dir /lib/modules
d13739ad 144%dir /media
d8cf4cdf
JB
145%dir /mnt
146%dir /opt
6c511447
ER
147%dir %attr(555,root,root) %verify(not group) /proc
148%dir %attr(700,root,root) /root
ef2d028b 149%dir %attr(700,root,root) /root/tmp
15c9b486 150%dir /sbin
6c511447
ER
151%dir %attr(755,root,root) /srv
152%dir %attr(1777,root,root) /tmp
d8cf4cdf
JB
153%dir /usr
154%dir /usr/bin
155%dir /usr/games
156%dir /usr/include
157%dir /usr/lib
158%dir /usr/lib/games
159%dir /usr/sbin
160%dir /usr/share
161%dir /usr/share/dict
162%dir /usr/share/doc
163%dir /usr/share/games
164%dir /usr/share/info
d8cf4cdf
JB
165%dir /usr/share/man
166%dir /usr/share/man/man[1-8]
d8cf4cdf
JB
167%dir /usr/share/misc
168%dir /usr/share/tmac
017dd5c9 169%dir /usr/share/xml
d8cf4cdf
JB
170%dir /usr/src
171%dir /usr/local
172%dir /usr/local/bin
173%dir /usr/local/etc
174%dir /usr/local/games
175%dir /usr/local/include
176%dir /usr/local/lib
177%dir /usr/local/sbin
178%dir /usr/local/share
179%dir /usr/local/share/doc
180%dir /usr/local/share/info
181/usr/local/share/man
0fa811e0 182%{_locmandir}
d8cf4cdf 183%dir /usr/local/src
15c9b486 184%dir /var
d8cf4cdf 185%dir /var/cache
0a75495b 186%dir /var/crash
15c9b486 187%dir /var/db
15c9b486 188%dir /var/games
dff2ec9d 189%dir /var/lib
0a75495b 190%dir /var/lib/misc
e7f27a78 191%dir /var/local
6c511447
ER
192%dir %attr(1771,root,root) /var/lock
193%dir %attr(751,root,root) /var/log
194%dir %attr(2775,root,root) /var/mail
15c9b486 195%dir /var/opt
0a75495b 196%dir /var/run
2d4f80d5 197%dir /var/spool
48784dc4 198%dir /var/yp
6c511447 199%dir %attr(1777,root,root) /var/tmp
d8cf4cdf
JB
200%if "%{_lib}" == "lib64"
201%dir /lib64
202%dir /usr/lib64
203%dir /usr/lib64/games
204%dir /usr/local/lib64
9d2de01c
JR
205%ifarch %{x8664}
206%dir /libx32
207%dir /usr/libx32
208%dir /usr/libx32/games
209%dir /usr/local/libx32
210%endif
211%endif
212%if "%{_lib}" == "libx32"
213%dir /libx32
214%dir /usr/libx32
215%dir /usr/libx32/games
216%dir /usr/local/libx32
76796e14 217%endif
This page took 0.058305 seconds and 4 git commands to generate.