]> git.pld-linux.org Git - packages/FHS.git/blame - FHS.spec
Release 4 (by relup.sh)
[packages/FHS.git] / FHS.spec
CommitLineData
2fccd05c
ER
1# NOTE
2# - don't use %{_*dir} macros for paths defined by FHS
05fbeea7
ER
3# - do not add any dependencies to this pkg, FHS should be the first package being installed
4# - do not use any other user/group than "root", as then we have to depend on "setup" package.
4e9a06c3
JB
5# But: root %attr+chown in %post means integrity verification (rpm -V) error.
6# Maybe use non-root %attr+numeric chown in %post (without setup dependency)? The only disadvantage
7# seems to be a warning message on install.
d6daf6dc 8Summary: Basic FHS 3.0 filesystem layout
d280bbd7
ER
9Summary(de.UTF-8): Grundlegende Dateisystemstruktur
10Summary(fr.UTF-8): Arborescence de base du système de fichiers
d6daf6dc 11Summary(pl.UTF-8): Podstawowy układ katalogów systemu Linux zgodny z FHS 3.0
d280bbd7 12Summary(tr.UTF-8): Temel dosya sistemi yapısı
b3b300be 13Name: FHS
4e9a06c3 14Version: 3.0
731074a8 15Release: 4
15c9b486 16License: GPL
17Group: Base
e38ba8ca 18URL: http://refspecs.linuxfoundation.org/fhs.shtml
4e9a06c3 19# list of languages for localized man pages directories
38ec8b96 20Source0: locale-dirs
2fccd05c 21BuildRequires: mktemp
73559f52 22BuildRequires: rpmbuild(macros) >= 1.213
05fbeea7 23Conflicts: setup < 2.7
8ad4c704 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15c9b486 25
5a4e441c
ER
26# nothing to put there
27%define _enable_debug_packages 0
28
335736da
JB
29%if "%{_lib}" == "lib64"
30%define with_lib64 1
335736da
JB
31%endif
32%if "%{_lib}" == "libx32"
33%define with_libx32 1
57d439f5 34%define with_lib64 1
335736da
JB
35%else
36%ifarch %{x8664}
37# x32 as additional ABI
38%define with_libx32 1
39%endif
40%endif
41
5a4e441c
ER
42# avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
43%define __spec_clean_body %{nil}
44
6c95f275 45# doesn't contain any files, but we're not noarch package
99177468 46%define no_install_post_strip 1
6c95f275
ER
47%define no_install_post_chrpath 1
48%define no_install_post_compress_modules 1
0fa811e0 49
05fbeea7 50# we have to use numeric uids/groups. see comment above
05fbeea7
ER
51%define gid_uucp 14
52%define gid_mail 12
53
15c9b486 54%description
aac153be 55This package contains the basic directory layout for a Linux system,
56including the proper permissions for the directories. This layout
4e9a06c3 57conforms to the Filesystem Hierarchy Standard (FHS) %{version}.
15c9b486 58
fdedb1f3
JR
59%description -l de.UTF-8
60Dieses Paket enthält die grundlegende Verzeichnisstruktur eines
61Linux-Systems, einschließlich der entsprechenden Zugriffsrechte. Diese
4e9a06c3 62Struktur entspricht dem Filesystem Hierarchy Standard (FHS) %{version}.
15c9b486 63
fdedb1f3
JR
64%description -l fr.UTF-8
65Ce package contient l'arborescence type pour système Linux y compris
66les permissions adéquates pour les répertoires. Cette arborescence est
4e9a06c3 67conforme au standard "Filesystem Hierarchy Standard" (FHS) %{version}.
15c9b486 68
fdedb1f3
JR
69%description -l pl.UTF-8
70Pakiet ten zawiera informacje o podstawowej strukturze katalogów
71systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
4e9a06c3 72%{version}.
aac153be 73
15c9b486 74%prep
40188a0f 75%setup -qcT
c5fb118b 76cp -p %{SOURCE0} .
15c9b486 77
78%install
79rm -rf $RPM_BUILD_ROOT
80
d8cf4cdf 81install -d \
4e9a06c3 82 $RPM_BUILD_ROOT/{bin,boot,dev,etc,home,opt,run,srv,sys} \
d8cf4cdf
JB
83 $RPM_BUILD_ROOT/etc/{X11,opt} \
84 $RPM_BUILD_ROOT/lib/modules \
d13739ad 85 $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
17f3eba2 86 $RPM_BUILD_ROOT/usr/{bin,games,include,lib,libexec,sbin,share,src} \
4e9a06c3 87 $RPM_BUILD_ROOT/usr/share/{color/icc,dict,doc,games,info,misc,ppd,tmac,xml} \
d8cf4cdf 88 $RPM_BUILD_ROOT/usr/lib/games \
17f3eba2 89 $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,libexec,sbin,share/{color/icc,doc,info,man},src} \
c5fb118b 90 $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/{color/icc,misc},local,lock,log,mail,opt,run,spool,tmp,yp}
d8cf4cdf 91
335736da 92%if %{with lib64}
d8cf4cdf 93install -d $RPM_BUILD_ROOT{/lib64,/usr/lib64/games,/usr/local/lib64}
9d2de01c 94%endif
335736da 95%if %{with libx32}
9d2de01c 96install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
76796e14
JB
97%endif
98
42b7266a 99install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
4e9a06c3 100install -d $RPM_BUILD_ROOT/usr/local/share/man/man{1,2,3,4,5,6,7,8}
9d1c44e3 101
42b7266a
ER
102> %{name}.lang
103for mloc in $(cat locale-dirs); do
104 echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
105 for manp in man{1,2,3,4,5,6,7,8}; do
106 install -d $RPM_BUILD_ROOT/usr/share/man/${mloc}/${manp}
107 echo "%%lang($mloc) %dir /usr/share/man/${mloc}/${manp}" >> %{name}.lang
108 done
109done
110
15c9b486 111%clean
fa9aa6bf 112cd $RPM_BUILD_ROOT
0a75495b 113
2fccd05c 114check_filesystem_dirs() {
2fccd05c
ER
115 RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
116 TMPFILE=$(mktemp)
e75de10d 117 find | sed -e 's|^\.||g' -e '/^$/d' | LC_ALL=C sort > $TMPFILE
2fccd05c 118
e75de10d 119 if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -u $TMPFILE - ; then
2fccd05c
ER
120 rm -rf $RPM_BUILD_ROOT
121 else
122 echo -e "\nNot so good, some directories are not included in package\n"
123 exit 1
124 fi
125 rm -f $TMPFILE
126}
127check_filesystem_dirs
15c9b486 128
4e9a06c3 129%pretrans -p <lua>
c5fb118b
JB
130st = posix.stat("/usr/local/share/man")
131if st and st.type == "link" then
132 os.remove("/usr/local/share/man")
133end
4e9a06c3 134
05fbeea7 135%post -p <lua>
c5fb118b 136--# XXX: it is 2009, what uucp?! but we use /var/lock/subsys, so change it just to root?
05fbeea7
ER
137posix.chown("/var/mail", 0, %{gid_mail})
138posix.chown("/var/lock", 0, %{gid_uucp})
139
42b7266a 140%files -f %{name}.lang
bfef5768 141%defattr(644,root,root,755)
52e00ac5 142%dir /
d8cf4cdf
JB
143%dir /bin
144%dir /boot
145%dir /dev
2d4f80d5 146%dir /etc
d8cf4cdf
JB
147%dir /etc/X11
148%dir /etc/opt
b9fc8087 149%dir /home
d8cf4cdf
JB
150%dir /lib
151%dir /lib/modules
d13739ad 152%dir /media
d8cf4cdf
JB
153%dir /mnt
154%dir /opt
6c511447
ER
155%dir %attr(555,root,root) %verify(not group) /proc
156%dir %attr(700,root,root) /root
ef2d028b 157%dir %attr(700,root,root) /root/tmp
4e9a06c3 158%dir /run
15c9b486 159%dir /sbin
6c511447 160%dir %attr(755,root,root) /srv
4e9a06c3 161%dir /sys
6c511447 162%dir %attr(1777,root,root) /tmp
d8cf4cdf
JB
163%dir /usr
164%dir /usr/bin
165%dir /usr/games
166%dir /usr/include
167%dir /usr/lib
d49d853d 168%dir /usr/libexec
d8cf4cdf
JB
169%dir /usr/lib/games
170%dir /usr/sbin
171%dir /usr/share
4e9a06c3
JB
172%dir /usr/share/color
173%dir /usr/share/color/icc
d8cf4cdf
JB
174%dir /usr/share/dict
175%dir /usr/share/doc
176%dir /usr/share/games
177%dir /usr/share/info
d8cf4cdf
JB
178%dir /usr/share/man
179%dir /usr/share/man/man[1-8]
d8cf4cdf 180%dir /usr/share/misc
4e9a06c3 181%dir /usr/share/ppd
d8cf4cdf 182%dir /usr/share/tmac
017dd5c9 183%dir /usr/share/xml
d8cf4cdf
JB
184%dir /usr/src
185%dir /usr/local
186%dir /usr/local/bin
187%dir /usr/local/etc
188%dir /usr/local/games
189%dir /usr/local/include
190%dir /usr/local/lib
d49d853d 191%dir /usr/local/libexec
d8cf4cdf
JB
192%dir /usr/local/sbin
193%dir /usr/local/share
4e9a06c3
JB
194%dir /usr/local/share/color
195%dir /usr/local/share/color/icc
d8cf4cdf
JB
196%dir /usr/local/share/doc
197%dir /usr/local/share/info
4e9a06c3
JB
198%dir /usr/local/share/man
199%dir /usr/local/share/man/man[1-8]
d8cf4cdf 200%dir /usr/local/src
15c9b486 201%dir /var
d8cf4cdf 202%dir /var/cache
0a75495b 203%dir /var/crash
15c9b486 204%dir /var/db
15c9b486 205%dir /var/games
dff2ec9d 206%dir /var/lib
4e9a06c3
JB
207%dir /var/lib/color
208%dir /var/lib/color/icc
0a75495b 209%dir /var/lib/misc
e7f27a78 210%dir /var/local
6c511447
ER
211%dir %attr(1771,root,root) /var/lock
212%dir %attr(751,root,root) /var/log
213%dir %attr(2775,root,root) /var/mail
15c9b486 214%dir /var/opt
0a75495b 215%dir /var/run
2d4f80d5 216%dir /var/spool
48784dc4 217%dir /var/yp
6c511447 218%dir %attr(1777,root,root) /var/tmp
335736da 219%if %{with lib64}
d8cf4cdf
JB
220%dir /lib64
221%dir /usr/lib64
222%dir /usr/lib64/games
223%dir /usr/local/lib64
9d2de01c 224%endif
335736da 225%if %{with libx32}
9d2de01c
JR
226%dir /libx32
227%dir /usr/libx32
228%dir /usr/libx32/games
229%dir /usr/local/libx32
76796e14 230%endif
This page took 0.084625 seconds and 4 git commands to generate.