]> git.pld-linux.org Git - packages/DirectFB.git/commitdiff
- rel 3; fix ffmpeg 2.4 build auto/th/DirectFB-1.7.6-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 7 Oct 2014 20:52:41 +0000 (22:52 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 7 Oct 2014 20:52:41 +0000 (22:52 +0200)
DirectFB-ffmpeg.patch
DirectFB.spec

index 3428a28f611b8275f1183b13cbf489e4d07bfa43..8dd1bcbe0f5d4a0c80e63bc59a857d18457ee6fd 100644 (file)
                 data->audio.st    = NULL;
                 data->audio.ctx   = NULL;
                 data->audio.codec = NULL;
+--- DirectFB-1.7.6/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_ffmpeg.c.org       2014-10-07 22:09:44.408929059 +0200
++++ DirectFB-1.7.6/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_ffmpeg.c   2014-10-07 22:13:49.765446586 +0200
+@@ -931,11 +931,19 @@
+           /* Ugly hack to fix a bug (segfault) in url_fclose() */
+           if (!(iformat->flags & AVFMT_NOFILE)) {
+                iformat->flags |= AVFMT_NOFILE;
++#if 0
+                av_close_input_file( data->context );
++#else
++             avformat_close_input( &data->context);
++#endif
+                iformat->flags ^= AVFMT_NOFILE;
+           }
+           else {
++#if 0
+                av_close_input_file( data->context );
++#else
++             avformat_close_input( &data->context);
++#endif
+           }
+      }
+@@ -1815,7 +1823,7 @@
+           return DFB_FAILURE;
+      }
+-     if (av_find_stream_info( data->context ) < 0) {
++     if (avformat_find_stream_info( data->context, NULL ) < 0) {
+           D_ERROR( "IDirectFBVideoProvider_FFmpeg: "
+                    "couldn't find stream info!\n" );
+           IDirectFBVideoProvider_FFmpeg_Destruct( thiz );
+@@ -1867,8 +1875,12 @@
+           IDirectFBVideoProvider_FFmpeg_Destruct( thiz );
+           return DFB_FAILURE;
+      }
+-     
++    
++#if 0
+      data->video.src_frame = avcodec_alloc_frame();
++#else
++     data->video.src_frame = av_frame_alloc();
++#endif
+      if (!data->video.src_frame) {
+           IDirectFBVideoProvider_FFmpeg_Destruct( thiz );
+           return D_OOM();
+--- DirectFB-1.7.6/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_ffmpeg.c.org 2014-10-07 22:40:52.350475804 +0200
++++ DirectFB-1.7.6/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_ffmpeg.c     2014-10-07 22:42:19.896406741 +0200
+@@ -444,11 +444,11 @@
+           /* Ugly hack to fix a bug (segfault) in url_fclose() */
+           if (!(iformat->flags & AVFMT_NOFILE)) {
+                iformat->flags |= AVFMT_NOFILE;
+-               av_close_input_file( data->ctx );
++             avformat_close_input( &data->ctx );
+                iformat->flags ^= AVFMT_NOFILE;
+           }
+           else {
+-               av_close_input_file( data->ctx );
++             avformat_close_input( &data->ctx );
+           }
+      }
+@@ -1311,7 +1311,7 @@
+           return DR_FAILURE;
+      }
+-     if (av_find_stream_info( data->ctx ) < 0) {
++     if (avformat_find_stream_info( data->ctx, NULL ) < 0) {
+           D_ERROR( "IFusionSoundMusicProvider_FFmpeg: couldn't find stream info!\n" );
+           IFusionSoundMusicProvider_FFmpeg_Destruct( thiz );
+           return DR_FAILURE;
index b5e787d09626333267dd4e9135ce1596bc347f9e..61bc3a3fcbf697eb1e5fa8788b46b1af7b649975 100644 (file)
@@ -25,7 +25,7 @@ Summary:      DirectFB - Hardware graphics acceleration
 Summary(pl.UTF-8):     DirectFB - Wspomaganie grafiki
 Name:          DirectFB
 Version:       1.7.6
-Release:       2
+Release:       3
 Epoch:         1
 License:       LGPL v2+
 Group:         Libraries
This page took 0.042267 seconds and 4 git commands to generate.