]> git.pld-linux.org Git - packages/DirectFB.git/commitdiff
- updated for 1.2.3
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 3 Sep 2008 19:15:22 +0000 (19:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    DirectFB-gcc4.patch -> 1.5
    DirectFB-link.patch -> 1.3

DirectFB-gcc4.patch
DirectFB-link.patch

index a05e451cdd8415c3c97b2477b187475d51e29977..b247fcffff692c5825059b1f0ba92ef6474abf14 100644 (file)
@@ -1,16 +1,6 @@
-diff -ur DirectFB-1.0.0.orig/include/directfb.h DirectFB-1.0.0/include/directfb.h
---- DirectFB-1.0.0.orig/include/directfb.h     2007-03-09 11:43:31.000000000 +0100
-+++ DirectFB-1.0.0/include/directfb.h  2007-03-09 14:22:40.000000000 +0100
-@@ -674,7 +674,7 @@
-      DSBLIT_SRC_PREMULTCOLOR   = 0x00000200, /* modulates the source color with the color alpha */
-      DSBLIT_XOR                = 0x00000400, /* bitwise xor the destination pixels with the
-                                                 source pixels after premultiplication */
--     DSBLIT_INDEX_TRANSLATION  = 0x00000800, /* do fast indexed to indexed translation,
-+     DSBLIT_INDEX_TRANSLATION  = 0x00000800  /* do fast indexed to indexed translation,
-                                                 this flag is mutual exclusive with all others */
- } DFBSurfaceBlittingFlags;
-@@ -846,7 +846,7 @@
+--- DirectFB-1.2.3/include/directfb.h.orig     2008-08-19 11:25:16.000000000 +0200
++++ DirectFB-1.2.3/include/directfb.h  2008-09-03 17:34:21.868983118 +0200
+@@ -970,7 +970,7 @@
                                             any character advance of fixed or
                                             proportional fonts */
       DFDESC_FRACT_HEIGHT = 0x00000020,  /* fractional height is set */
@@ -19,16 +9,7 @@ diff -ur DirectFB-1.0.0.orig/include/directfb.h DirectFB-1.0.0/include/directfb.
  } DFBFontDescriptionFlags;
  
  /*
-@@ -1295,7 +1295,7 @@
-      DVCAPS_HUE         = 0x00000040,  /* supports Hue adjustment          */
-      DVCAPS_SATURATION  = 0x00000080,  /* supports Saturation adjustment   */
-      DVCAPS_INTERACTIVE = 0x00000100,  /* supports SendEvent               */
--     DVCAPS_VOLUME      = 0x00000200,  /* supports Volume adjustment       */
-+     DVCAPS_VOLUME      = 0x00000200   /* supports Volume adjustment       */
- } DFBVideoProviderCapabilities;
- /*
-@@ -2878,7 +2878,7 @@
+@@ -3108,7 +3108,7 @@
       DSPD_SRC_ATOP       =  9, /* fs: da      fd: 1.0-sa */
       DSPD_DST_ATOP       = 10, /* fs: 1.0-da  fd: sa     */
       DSPD_ADD            = 11, /* fs: 1.0     fd: 1.0    */
index 6699057545e5d0b70b9b511bb96d6633e9869732..a604dc0128dd0b8261e364b9f67e4dfbaf53ba97 100644 (file)
@@ -1,47 +1,12 @@
---- DirectFB-0.9.25.1/wm/unique/Makefile.am~   2006-05-03 10:22:38.000000000 +0300
-+++ DirectFB-0.9.25.1/wm/unique/Makefile.am    2006-11-07 09:27:04.794005664 +0200
-@@ -19,7 +19,7 @@
- uwmdump_SOURCES = uwmdump.c
- uwmdump_LDADD = \
--      libuniquewm.la                                  \
-+      ./libuniquewm.la        \
-       $(top_builddir)/lib/direct/libdirect.la         \
-       $(top_builddir)/lib/fusion/libfusion.la         \
-       $(top_builddir)/src/libdirectfb.la
-@@ -28,7 +28,7 @@
- test_color_SOURCES = test_color.c
- test_color_LDADD = \
--      libuniquewm.la                                  \
-+      ./libuniquewm.la        \
-       $(top_builddir)/lib/direct/libdirect.la         \
-       $(top_builddir)/lib/fusion/libfusion.la         \
-       $(top_builddir)/src/libdirectfb.la
-@@ -37,7 +37,7 @@
- test_foo_SOURCES = test_foo.c
- test_foo_LDADD = \
--      libuniquewm.la                                  \
-+      ./libuniquewm.la        \
-       $(top_builddir)/lib/direct/libdirect.la         \
-       $(top_builddir)/lib/fusion/libfusion.la         \
-       $(top_builddir)/src/libdirectfb.la
-@@ -46,7 +46,7 @@
- stret_test_SOURCES = stret_test.c
- stret_test_LDADD = \
--      libuniquewm.la                                  \
-+      ./libuniquewm.la        \
-       $(top_builddir)/lib/fusion/libfusion.la         \
-       $(top_builddir)/lib/direct/libdirect.la         \
-       $(top_builddir)/src/libdirectfb.la
-@@ -69,7 +69,7 @@
- libdirectfbwm_unique_la_LIBADD = \
-       $(top_builddir)/lib/direct/libdirect.la \
-       $(top_builddir)/lib/fusion/libfusion.la \
--      libuniquewm.la
-+      ./libuniquewm.la
- libdirectfbwm_unique_la_LDFLAGS = \
-       -avoid-version  \
+--- DirectFB-1.2.3/gfxdrivers/sh7722/Makefile.am.orig  2008-08-08 16:10:55.000000000 +0200
++++ DirectFB-1.2.3/gfxdrivers/sh7722/Makefile.am       2008-09-03 18:43:14.512984794 +0200
+@@ -23,6 +23,9 @@
+       sh7722_jpeglib.c        \
+       sh7722_jpeglib.h
++libsh7722_jpeg_la_LIBADD = \
++      $(top_builddir)/src/libdirectfb.la
++
+ libsh7722_jpeg_la_LDFLAGS = \
+       -export-dynamic         \
+       -avoid-version
This page took 0.073539 seconds and 4 git commands to generate.