]> git.pld-linux.org Git - packages/DevIL.git/commitdiff
- rediffed patches, added jasper3 patch to adjust to jasper 3.0.x API; release 2 master auto/th/DevIL-1.8.0-2
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 25 Mar 2023 10:00:00 +0000 (11:00 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 25 Mar 2023 10:00:00 +0000 (11:00 +0100)
DevIL-cmake.patch
DevIL-jasper3.patch [new file with mode: 0644]
DevIL.spec

index 483531bc2a1c6d2df6e0e3ed9eb2488b7d55d7ad..816abec2a73a1e01c1f40dca21341d03811395ab 100644 (file)
@@ -1,7 +1,6 @@
 --- DevIL/DevIL/src-IL/CMakeLists.txt.orig     2017-01-02 01:03:56.000000000 +0100
-+++ DevIL/DevIL/src-IL/CMakeLists.txt  2017-05-13 07:17:07.992571414 +0200
-@@ -57,7 +57,8 @@
- source_group("Text Files" FILES ${DevIL_TXT} )
++++ DevIL/DevIL/src-IL/CMakeLists.txt  2023-03-25 10:36:16.647374199 +0100
+@@ -58,6 +58,7 @@ source_group("Text Files" FILES ${DevIL_
  
  if(BUILD_SHARED_LIBS)
      add_library(IL SHARED ${DevIL_SRCS} ${DevIL_INC} ${DevIL_RSRC} ${DevIL_TXT})
@@ -9,7 +8,7 @@
  else(BUILD_SHARED_LIBS)
      add_library(IL ${DevIL_SRCS} ${DevIL_INC} ${DevIL_RSRC} ${DevIL_TXT})
  endif(BUILD_SHARED_LIBS)
-@@ -248,14 +248,14 @@
+@@ -248,14 +249,14 @@ configure_file( pkgconfig/IL.pc.cmake.in
  
  # Installation
  install (TARGETS IL
@@ -28,9 +27,8 @@
  )
  
 --- DevIL/DevIL/src-ILU/CMakeLists.txt.orig    2017-01-02 01:03:56.000000000 +0100
-+++ DevIL/DevIL/src-ILU/CMakeLists.txt 2017-05-13 07:17:53.745904312 +0200
-@@ -43,7 +43,8 @@
- source_group("Resource Files" FILES ${ILU_RSRC} )
++++ DevIL/DevIL/src-ILU/CMakeLists.txt 2023-03-25 10:36:31.683959406 +0100
+@@ -44,6 +44,7 @@ source_group("Resource Files" FILES ${IL
  
  # Remove SHARED to create a static library
  add_library(ILU SHARED ${ILU_SRCS} ${ILU_INC} ${ILU_RSRC})
@@ -38,7 +36,7 @@
  
  
  ## ILU requires IL
-@@ -74,14 +74,17 @@
+@@ -74,14 +75,17 @@ endif(UNICODE)
  
  # Installation
  install (TARGETS ILU
@@ -61,9 +59,8 @@
 +target_link_libraries(ilur ILU IL)
 +install (TARGETS ilur DESTINATION bin)
 --- DevIL/DevIL/src-ILUT/CMakeLists.txt.orig   2017-01-02 01:03:56.000000000 +0100
-+++ DevIL/DevIL/src-ILUT/CMakeLists.txt        2017-05-13 07:18:31.642570459 +0200
-@@ -43,7 +43,8 @@
- source_group("Resource Files" FILES ${ILUT_RSRC} )
++++ DevIL/DevIL/src-ILUT/CMakeLists.txt        2023-03-25 10:36:46.680544829 +0100
+@@ -44,6 +44,7 @@ source_group("Resource Files" FILES ${IL
  
  # Remove SHARED to create a static library
  add_library(ILUT SHARED ${ILUT_SRCS} ${ILUT_INC} ${ILUT_RSRC})
@@ -71,7 +68,7 @@
  
  ## add link sub library info
  target_link_libraries(ILUT
-@@ -72,14 +72,14 @@
+@@ -72,14 +73,14 @@ endif(UNICODE)
  
  # Installation
  install (TARGETS ILUT
diff --git a/DevIL-jasper3.patch b/DevIL-jasper3.patch
new file mode 100644 (file)
index 0000000..96d846c
--- /dev/null
@@ -0,0 +1,18 @@
+--- DevIL/DevIL/src-IL/src/il_jp2.cpp.orig     2017-01-02 01:03:56.000000000 +0100
++++ DevIL/DevIL/src-IL/src/il_jp2.cpp  2023-03-25 10:49:09.046523087 +0100
+@@ -314,13 +314,13 @@ ILboolean iLoadJp2Internal(jas_stream_t
+-static int iJp2_file_read(jas_stream_obj_t *obj, char *buf, int cnt)
++static ssize_t iJp2_file_read(jas_stream_obj_t *obj, char *buf, size_t cnt)
+ {
+       obj;
+       return iread(buf, 1, cnt);
+ }
+-static int iJp2_file_write(jas_stream_obj_t *obj, char *buf, int cnt)
++static ssize_t iJp2_file_write(jas_stream_obj_t *obj, const char *buf, size_t cnt)
+ {
+       obj;
+       return iwrite(buf, 1, cnt);
index 9f90340d2b9c98708059c25c89da274e269509c3..bc88369e5a757f7a12910637340174eb41f06d48 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Full featured image library
 Summary(pl.UTF-8):     Biblioteka obsługi obrazów z mnóstwem funkcji
 Name:          DevIL
 Version:       1.8.0
-Release:       1
+Release:       2
 License:       LGPL v2.1
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/openil/%{name}-%{version}.tar.gz
@@ -10,19 +10,21 @@ Source0:    http://downloads.sourceforge.net/openil/%{name}-%{version}.tar.gz
 Patch0:                %{name}-cmake.patch
 Patch1:                %{name}-info.patch
 Patch2:                %{name}-ILUT.patch
+Patch3:                %{name}-jasper3.patch
 URL:           http://openil.sourceforge.net/
 BuildRequires: OpenEXR-devel
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: SDL-devel >= 1.2.5
 BuildRequires: allegro-devel >= 4.1.16
 BuildRequires: cmake >= 2.6
-BuildRequires: jasper-devel
+BuildRequires: jasper-devel >= 3
 BuildRequires: lcms2-devel >= 2
 BuildRequires: libjpeg-devel
 BuildRequires: libmng-devel
 BuildRequires: libpng-devel
 BuildRequires: libtiff-devel
 BuildRequires: pkgconfig
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.605
 BuildRequires: squish-devel
 BuildRequires: sed >= 4.0
@@ -69,14 +71,14 @@ Summary(pl.UTF-8):  Pliki nagłówkowe bibliotek DevIL
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      OpenEXR-devel
-Requires:      jasper-devel
+Requires:      jasper-devel >= 3
 Requires:      lcms-devel
 Requires:      libjpeg-devel
 Requires:      libmng-devel
 Requires:      libpng-devel
 Requires:      libtiff-devel
 Requires:      squish-devel
-Obsoletes:     DevIL-static
+Obsoletes:     DevIL-static < 1.8
 
 %description devel
 DevIL development files (for IL and ILU libraries).
@@ -108,7 +110,7 @@ Requires:   OpenGL-GLU-devel
 Requires:      SDL-devel >= 1.2.5
 Requires:      allegro-devel >= 4.1.16
 Requires:      xorg-lib-libXext-devel
-Obsoletes:     DevIL-ILUT-static
+Obsoletes:     DevIL-ILUT-static < 1.8
 
 %description ILUT-devel
 Development files for DevIL ILUT library.
@@ -120,6 +122,7 @@ Pliki programistyczne biblioteki DevIL ILUT.
 Summary:       DevIL documentation
 Summary(pl.UTF-8):     Dokumentacja DevIL
 Group:         Documentation
+BuildArch:     noarch
 
 %description doc
 DevIL documentation.
@@ -132,6 +135,7 @@ Dokumentacja DevIL.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 # although there is configure.ac, but it misses some auxiliary files (m4/*)
This page took 0.130856 seconds and 4 git commands to generate.