]> git.pld-linux.org Git - packages/DevIL.git/commitdiff
- added libpng14.patch (and undos related sources) auto/ti/DevIL-1_7_2-4
authorSzymon Siwek <sls@pld-linux.org>
Tue, 9 Feb 2010 23:27:57 +0000 (23:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- rel. 4

Changed files:
    DevIL.spec -> 1.25
    libpng14.patch -> 1.1

DevIL.spec
libpng14.patch [new file with mode: 0644]

index 9d7f22bbb523319a5c067194a8382ef72ce8ded4..c43146910c0d4bcec69cfc21fb07fa618b740679 100644 (file)
@@ -4,7 +4,7 @@ Name:           DevIL
 Version:       1.7.2
 %define                manual_version  1.5.5
 %define                docs_version    1.6.5
-Release:       3
+Release:       4
 License:       LGPL v2.1
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/openil/%{name}-%{version}.tar.gz
@@ -16,6 +16,7 @@ Source2:      http://dl.sourceforge.net/openil/%{name}-docs.tar.gz
 Patch0:                %{name}-c++.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-gnu-inline.patch
+Patch3:                libpng14.patch
 URL:           http://openil.sourceforge.net/
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: SDL-devel >= 1.2.5
@@ -29,6 +30,8 @@ BuildRequires:        libmng-devel
 BuildRequires: libpng-devel
 BuildRequires: libtiff-devel
 BuildRequires: libtool >= 2:1.5
+BuildRequires: rpmbuild(macros) >= 1.533
+BuildRequires: sed >= 4.0
 BuildRequires: unzip
 BuildRequires: which
 Requires:      allegro >= 4.1.16
@@ -104,6 +107,9 @@ Dokumentacja DevIL.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%undos src-IL/src/il_png.c
+%undos src-IL/src/il_icon.c
+%patch3 -p1
 
 # just SDL and messing libtool macros
 rm -f acinclude.m4
diff --git a/libpng14.patch b/libpng14.patch
new file mode 100644 (file)
index 0000000..df5684d
--- /dev/null
@@ -0,0 +1,40 @@
+--- DevIL-1.7.2/src-IL/src/il_png.c.orig       2010-02-07 16:59:29.208824733 +0100
++++ DevIL-1.7.2/src-IL/src/il_png.c    2010-02-07 17:04:17.675411333 +0100
+@@ -103,7 +103,11 @@ ILboolean iIsValidPng()
+       Read = iread(Signature, 1, 8);
+       iseek(-Read, IL_SEEK_CUR);
++#if PNG_LIBPNG_VER < 10400
+       return png_check_sig(Signature, 8);
++#else
++      return png_sig_cmp(Signature, 0, 8) == 0;
++#endif
+ }
+@@ -278,7 +282,11 @@ ILboolean readpng_get_image(ILdouble dis
+       // Expand low-bit-depth grayscale images to 8 bits
+       if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
++#if PNG_LIBPNG_VER < 10400
+               png_set_gray_1_2_4_to_8(png_ptr);
++#else
++              png_set_expand_gray_1_2_4_to_8(png_ptr);
++#endif
+       }
+       // Expand RGB images with transparency to full alpha channels
+--- DevIL-1.7.2/src-IL/src/il_icon.c.orig      2010-02-07 17:15:17.456176881 +0100
++++ DevIL-1.7.2/src-IL/src/il_icon.c   2010-02-07 17:15:59.942840566 +0100
+@@ -530,7 +530,11 @@
+       // Expand low-bit-depth grayscale images to 8 bits
+       if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
++#if PNG_LIBPNG_VER < 10400
+               png_set_gray_1_2_4_to_8(ico_png_ptr);
++#else
++              png_set_expand_gray_1_2_4_to_8(ico_png_ptr);
++#endif
+       }
+       // Expand RGB images with transparency to full alpha channels
This page took 0.081628 seconds and 4 git commands to generate.