]> git.pld-linux.org Git - packages/DevIL.git/blame_incremental - DevIL.spec
- rel 2
[packages/DevIL.git] / DevIL.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with sse # use SSE extension
4%bcond_with sse2 # use SSE2 extension
5%bcond_with sse3 # use SSE3 extension
6#
7%ifarch pentium3 pentium4 %{x8664}
8%define with_sse 1
9%endif
10%ifarch pentium4 %{x8664}
11%define with_sse2 1
12%endif
13%define manual_version 1.5.5
14Summary: Full featured image library
15Summary(pl.UTF-8): Biblioteka obsługi obrazów z mnóstwem funkcji
16Name: DevIL
17Version: 1.7.8
18Release: 2
19License: LGPL v2.1
20Group: Libraries
21Source0: http://downloads.sourceforge.net/openil/%{name}-%{version}.tar.gz
22# Source0-md5: 7918f215524589435e5ec2e8736d5e1d
23Source1: http://downloads.sourceforge.net/openil/%{name}-Manual-%{manual_version}.zip
24# Source1-md5: 6bb2ddfcbe09930c48ef84b8f99479fe
25Source2: http://downloads.sourceforge.net/openil/%{name}-docs.tar.gz
26# Source2-md5: eec6ae7a028a3f058bab1a6918428ed5
27Patch0: libpng14.patch
28Patch1: %{name}-squish.patch
29Patch2: %{name}-as-needed.patch
30URL: http://openil.sourceforge.net/
31BuildRequires: OpenEXR-devel
32BuildRequires: OpenGL-GLU-devel
33BuildRequires: SDL-devel >= 1.2.5
34BuildRequires: allegro-devel >= 4.1.16
35BuildRequires: autoconf >= 2.52
36BuildRequires: automake
37BuildRequires: jasper-devel
38BuildRequires: lcms-devel
39BuildRequires: libjpeg-devel
40BuildRequires: libmng-devel
41BuildRequires: libpng-devel
42BuildRequires: libtiff-devel
43BuildRequires: libtool >= 2:1.5
44BuildRequires: pkgconfig
45BuildRequires: rpmbuild(macros) >= 1.533
46BuildRequires: squish-devel
47BuildRequires: sed >= 4.0
48BuildRequires: unzip
49BuildRequires: xorg-lib-libXext-devel
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%define _noautoreqdep libGL.so.1 libGLU.so.1
53
54%description
55Developer's Image Library (DevIL) is a programmer's library to develop
56applications with very powerful image loading capabilities, yet is
57easy for a developer to learn and use. Ultimate control of images is
58left to the developer, so unnecessary conversions, etc. are not
59performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can
60load, save, convert, manipulate, filter and display a wide variety of
61image formats.
62
63Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .icns,
64.jp2, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic,
65.png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif files.
66
67Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm,
68.pcx, .pgm, .png, .ppm, .raw, .sgi, .tga and .tif.
69
70%description -l pl.UTF-8
71Developer's Image Library (DevIL) jest biblioteką programisty
72pozwalającą tworzyć aplikacje z potężnymi możliwościami ładowania
73obrazów. Pozostaje przy tym łatwa w użyciu i prosta do nauczenia się.
74Ostateczna kontrola nad obrazami jest zostawiona programiście, nie
75wprowadza się niepotrzebnych konwersji, itp. DevIL używa prostej, lecz
76potężnej składni poleceń, wzorowanej na OpenGL-u. DevIL potrafi
77ładować, zapisywać, konwertować, manipulować, filtrować szeroki
78wachlarz formatów plików graficznych.
79
80W chwili obecnej DevIL odczytuje pliki z rozszerzeniami bmp, cut, dds,
81doom, gif, icns, ico, jp2, jpg, lbm, mdl, mng, pal, pbm, pcd, pcx,
82pgm, pic, png, ppm, psd, psp, raw, sgi, tga i tif.
83
84Obsługiwane jest zapisywanie do plików bmp, dds, h, jpg, pal, pbm,
85pcx, pgm, png, ppm, raw, sgi, tga i tif.
86
87%package devel
88Summary: DevIL development files
89Summary(pl.UTF-8): Pliki nagłówkowe bibliotek DevIL
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Requires: OpenEXR-devel
93Requires: jasper-devel
94Requires: lcms-devel
95Requires: libjpeg-devel
96Requires: libmng-devel
97Requires: libpng-devel
98Requires: libtiff-devel
99Requires: squish-devel
100
101%description devel
102DevIL development files (for IL and ILU libraries).
103
104%description devel -l pl.UTF-8
105Pliki nagłówkowe bibliotek DevIL (IL i ILU).
106
107%package static
108Summary: Static DevIL libraries
109Summary(pl.UTF-8): Statyczne biblioteki DevIL
110Group: Development/Libraries
111Requires: %{name}-devel = %{version}-%{release}
112
113%description static
114Static DevIL libraries (IL and ILU).
115
116%description static -l pl.UTF-8
117Statyczne biblioteki DevIL (IL i ILU).
118
119%package ILUT
120Summary: DevIL ILUT library
121Summary(pl.UTF-8): Biblioteka DevIL ILUT
122Group: Libraries
123Requires: %{name} = %{version}-%{release}
124Requires: SDL >= 1.2.5
125Requires: allegro >= 4.1.16
126
127%description ILUT
128DevIL ILUT library - connection to higher level libraries.
129
130%description ILUT
131Biblioteka DevIL ILUT - łącznik z bibliotekami wyższego poziomu.
132
133%package ILUT-devel
134Summary: Development files for DevIL ILUT library
135Summary(pl.UTF-8): Pliki programistyczne biblioteki DevIL ILUT
136Group: Development/Libraries
137Requires: %{name}-ILUT = %{version}-%{release}
138Requires: %{name}-devel = %{version}-%{release}
139Requires: OpenGL-GLU-devel
140Requires: SDL-devel >= 1.2.5
141Requires: allegro-devel >= 4.1.16
142Requires: xorg-lib-libXext-devel
143
144%description ILUT-devel
145Development files for DevIL ILUT library.
146
147%description ILUT-devel -l pl.UTF-8
148Pliki programistyczne biblioteki DevIL ILUT.
149
150%package ILUT-static
151Summary: Static DevIL ILUT library
152Summary(pl.UTF-8): Statyczna biblioteka DevIL ILUT
153Group: Development/Libraries
154Requires: %{name}-ILUT-devel = %{version}-%{release}
155
156%description ILUT-static
157Static DevIL ILUT library.
158
159%description ILUT-static -l pl.UTF-8
160Statyczna biblioteka DevIL ILUT.
161
162%package doc
163Summary: DevIL documentation
164Summary(pl.UTF-8): Dokumentacja DevIL
165Group: Documentation
166
167%description doc
168DevIL documentation.
169
170%description doc -l pl.UTF-8
171Dokumentacja DevIL.
172
173%prep
174%setup -q -c -a1 -a2
175%patch0 -p1
176%patch1 -p1
177%patch2 -p1
178
179%build
180cd devil-%{version}
181%{__libtoolize}
182%{__aclocal} -I m4
183%{__autoconf}
184%{__autoheader}
185%{__automake}
186%configure \
187 --enable-ILU \
188 --enable-ILUT \
189 %{?debug:--disable-release} \
190 %{!?with_sse:--disable-sse} \
191 %{!?with_sse2:--disable-sse2} \
192 %{!?with_sse3:--disable-sse3}
193%{__make}
194
195%install
196rm -rf $RPM_BUILD_ROOT
197
198%{__make} -C devil-%{version} install \
199 DESTDIR=$RPM_BUILD_ROOT
200
201%clean
202rm -rf $RPM_BUILD_ROOT
203
204%post -p /sbin/ldconfig
205%postun -p /sbin/ldconfig
206
207%post devel -p /sbin/postshell
208-/usr/sbin/fix-info-dir -c %{_infodir}
209
210%postun devel -p /sbin/postshell
211-/usr/sbin/fix-info-dir -c %{_infodir}
212
213%files
214%defattr(644,root,root,755)
215%doc devil-%{version}/{AUTHORS,CREDITS,ChangeLog,README.unix}
216%attr(755,root,root) %{_bindir}/ilur
217%attr(755,root,root) %{_libdir}/libIL.so.*.*.*
218%attr(755,root,root) %ghost %{_libdir}/libIL.so.1
219%attr(755,root,root) %{_libdir}/libILU.so.*.*.*
220%attr(755,root,root) %ghost %{_libdir}/libILU.so.1
221
222%files devel
223%defattr(644,root,root,755)
224%attr(755,root,root) %{_libdir}/libIL.so
225%attr(755,root,root) %{_libdir}/libILU.so
226%{_libdir}/libIL.la
227%{_libdir}/libILU.la
228%dir %{_includedir}/IL
229%{_includedir}/IL/il.h
230%{_includedir}/IL/ilu.h
231%{_includedir}/IL/ilu_region.h
232%{_pkgconfigdir}/IL.pc
233%{_pkgconfigdir}/ILU.pc
234%{_infodir}/DevIL_manual.info*
235
236%files static
237%defattr(644,root,root,755)
238%{_libdir}/libIL.a
239%{_libdir}/libILU.a
240
241%files ILUT
242%defattr(644,root,root,755)
243%attr(755,root,root) %{_libdir}/libILUT.so.*.*.*
244%attr(755,root,root) %ghost %{_libdir}/libILUT.so.1
245
246%files ILUT-devel
247%defattr(644,root,root,755)
248%attr(755,root,root) %{_libdir}/libILUT.so
249%{_includedir}/IL/devil_cpp_wrapper.hpp
250%{_includedir}/IL/ilut.h
251%{_libdir}/libILUT.la
252%{_pkgconfigdir}/ILUT.pc
253
254%files ILUT-static
255%defattr(644,root,root,755)
256%{_libdir}/libILUT.a
257
258%files doc
259%defattr(644,root,root,755)
260%doc DevIL*.pdf
This page took 0.058351 seconds and 4 git commands to generate.