]> git.pld-linux.org Git - packages/DevIL.git/blame - DevIL.spec
- fix building with jasper 2
[packages/DevIL.git] / DevIL.spec
CommitLineData
e74167f1
JB
1#
2# Conditional build:
3%bcond_with sse # use SSE extension
4%bcond_with sse2 # use SSE2 extension
5%bcond_with sse3 # use SSE3 extension
6#
7%ifarch pentium3 pentium4 %{x8664}
8%define with_sse 1
9%endif
10%ifarch pentium4 %{x8664}
11%define with_sse2 1
12%endif
549f5ea9 13%define manual_version 1.5.5
b26e6e51 14Summary: Full featured image library
9d1f46ef 15Summary(pl.UTF-8): Biblioteka obsługi obrazów z mnóstwem funkcji
b26e6e51 16Name: DevIL
549f5ea9 17Version: 1.7.8
8c0a98df 18Release: 17
16a5e177 19License: LGPL v2.1
b26e6e51 20Group: Libraries
549f5ea9 21Source0: http://downloads.sourceforge.net/openil/%{name}-%{version}.tar.gz
22# Source0-md5: 7918f215524589435e5ec2e8736d5e1d
23Source1: http://downloads.sourceforge.net/openil/%{name}-Manual-%{manual_version}.zip
f28788f8 24# Source1-md5: 6bb2ddfcbe09930c48ef84b8f99479fe
549f5ea9 25Source2: http://downloads.sourceforge.net/openil/%{name}-docs.tar.gz
b9b4afaf 26# Source2-md5: eec6ae7a028a3f058bab1a6918428ed5
6a2717dc 27Patch0: libpng14.patch
e74167f1
JB
28Patch1: %{name}-squish.patch
29Patch2: %{name}-as-needed.patch
6de980dc 30Patch3: gcc5.patch
8c0a98df 31Patch4: jasper2.patch
b26e6e51 32URL: http://openil.sourceforge.net/
6a2717dc 33BuildRequires: OpenEXR-devel
663a085f
JB
34BuildRequires: OpenGL-GLU-devel
35BuildRequires: SDL-devel >= 1.2.5
36BuildRequires: allegro-devel >= 4.1.16
37BuildRequires: autoconf >= 2.52
b26e6e51 38BuildRequires: automake
16a5e177 39BuildRequires: jasper-devel
b26e6e51 40BuildRequires: lcms-devel
41BuildRequires: libjpeg-devel
42BuildRequires: libmng-devel
43BuildRequires: libpng-devel
44BuildRequires: libtiff-devel
663a085f 45BuildRequires: libtool >= 2:1.5
9731601b 46BuildRequires: pkgconfig
5921fce3 47BuildRequires: rpmbuild(macros) >= 1.533
e74167f1 48BuildRequires: squish-devel
5921fce3 49BuildRequires: sed >= 4.0
5a07b428 50BuildRequires: unzip
6a2717dc 51BuildRequires: xorg-lib-libXext-devel
b26e6e51 52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54%define _noautoreqdep libGL.so.1 libGLU.so.1
55
56%description
57Developer's Image Library (DevIL) is a programmer's library to develop
58applications with very powerful image loading capabilities, yet is
59easy for a developer to learn and use. Ultimate control of images is
60left to the developer, so unnecessary conversions, etc. are not
61performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can
62load, save, convert, manipulate, filter and display a wide variety of
63image formats.
64
16a5e177
JB
65Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .icns,
66.jp2, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic,
67.png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif files.
b26e6e51 68
69Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm,
70.pcx, .pgm, .png, .ppm, .raw, .sgi, .tga and .tif.
71
e247203e
JR
72%description -l pl.UTF-8
73Developer's Image Library (DevIL) jest biblioteką programisty
74pozwalającą tworzyć aplikacje z potężnymi możliwościami ładowania
75obrazów. Pozostaje przy tym łatwa w użyciu i prosta do nauczenia się.
76Ostateczna kontrola nad obrazami jest zostawiona programiście, nie
77wprowadza się niepotrzebnych konwersji, itp. DevIL używa prostej, lecz
78potężnej składni poleceń, wzorowanej na OpenGL-u. DevIL potrafi
79ładować, zapisywać, konwertować, manipulować, filtrować szeroki
80wachlarz formatów plików graficznych.
b26e6e51 81
82W chwili obecnej DevIL odczytuje pliki z rozszerzeniami bmp, cut, dds,
16a5e177
JB
83doom, gif, icns, ico, jp2, jpg, lbm, mdl, mng, pal, pbm, pcd, pcx,
84pgm, pic, png, ppm, psd, psp, raw, sgi, tga i tif.
b26e6e51 85
6a2717dc
JB
86Obsługiwane jest zapisywanie do plików bmp, dds, h, jpg, pal, pbm,
87pcx, pgm, png, ppm, raw, sgi, tga i tif.
b26e6e51 88
89%package devel
6a2717dc
JB
90Summary: DevIL development files
91Summary(pl.UTF-8): Pliki nagłówkowe bibliotek DevIL
b26e6e51 92Group: Development/Libraries
51c3e4ff 93Requires: %{name} = %{version}-%{release}
6a2717dc 94Requires: OpenEXR-devel
16a5e177 95Requires: jasper-devel
663a085f
JB
96Requires: lcms-devel
97Requires: libjpeg-devel
98Requires: libmng-devel
99Requires: libpng-devel
100Requires: libtiff-devel
e74167f1 101Requires: squish-devel
b26e6e51 102
103%description devel
6a2717dc 104DevIL development files (for IL and ILU libraries).
b26e6e51 105
e247203e 106%description devel -l pl.UTF-8
6a2717dc
JB
107Pliki nagłówkowe bibliotek DevIL (IL i ILU).
108
109%package static
110Summary: Static DevIL libraries
111Summary(pl.UTF-8): Statyczne biblioteki DevIL
112Group: Development/Libraries
113Requires: %{name}-devel = %{version}-%{release}
114
115%description static
116Static DevIL libraries (IL and ILU).
117
118%description static -l pl.UTF-8
119Statyczne biblioteki DevIL (IL i ILU).
120
121%package ILUT
122Summary: DevIL ILUT library
123Summary(pl.UTF-8): Biblioteka DevIL ILUT
124Group: Libraries
125Requires: %{name} = %{version}-%{release}
126Requires: SDL >= 1.2.5
127Requires: allegro >= 4.1.16
128
129%description ILUT
130DevIL ILUT library - connection to higher level libraries.
131
739f9dbd 132%description ILUT -l pl.UTF-8
6a2717dc
JB
133Biblioteka DevIL ILUT - łącznik z bibliotekami wyższego poziomu.
134
135%package ILUT-devel
136Summary: Development files for DevIL ILUT library
137Summary(pl.UTF-8): Pliki programistyczne biblioteki DevIL ILUT
138Group: Development/Libraries
139Requires: %{name}-ILUT = %{version}-%{release}
140Requires: %{name}-devel = %{version}-%{release}
141Requires: OpenGL-GLU-devel
142Requires: SDL-devel >= 1.2.5
143Requires: allegro-devel >= 4.1.16
144Requires: xorg-lib-libXext-devel
145
146%description ILUT-devel
147Development files for DevIL ILUT library.
148
149%description ILUT-devel -l pl.UTF-8
150Pliki programistyczne biblioteki DevIL ILUT.
151
152%package ILUT-static
153Summary: Static DevIL ILUT library
154Summary(pl.UTF-8): Statyczna biblioteka DevIL ILUT
155Group: Development/Libraries
156Requires: %{name}-ILUT-devel = %{version}-%{release}
157
158%description ILUT-static
159Static DevIL ILUT library.
160
161%description ILUT-static -l pl.UTF-8
162Statyczna biblioteka DevIL ILUT.
b26e6e51 163
164%package doc
165Summary: DevIL documentation
9d1f46ef 166Summary(pl.UTF-8): Dokumentacja DevIL
462875c5 167Group: Documentation
b26e6e51 168
169%description doc
170DevIL documentation.
171
e247203e 172%description doc -l pl.UTF-8
b26e6e51 173Dokumentacja DevIL.
174
175%prep
16a5e177 176%setup -q -c -a1 -a2
c7956080 177%patch0 -p1
e74167f1
JB
178%patch1 -p1
179%patch2 -p1
6de980dc 180%patch3 -p1
8c0a98df 181%patch4 -p1
b26e6e51 182
b26e6e51 183%build
549f5ea9 184cd devil-%{version}
663a085f 185%{__libtoolize}
549f5ea9 186%{__aclocal} -I m4
663a085f 187%{__autoconf}
16a5e177 188%{__autoheader}
663a085f 189%{__automake}
b26e6e51 190%configure \
6a2717dc
JB
191 --enable-ILU \
192 --enable-ILUT \
e74167f1
JB
193 %{?debug:--disable-release} \
194 %{!?with_sse:--disable-sse} \
195 %{!?with_sse2:--disable-sse2} \
196 %{!?with_sse3:--disable-sse3}
b26e6e51 197%{__make}
198
199%install
200rm -rf $RPM_BUILD_ROOT
201
549f5ea9 202%{__make} -C devil-%{version} install \
19d04b2f 203 DESTDIR=$RPM_BUILD_ROOT
b26e6e51 204
205%clean
206rm -rf $RPM_BUILD_ROOT
207
b388cc31
AG
208%post -p /sbin/ldconfig
209%postun -p /sbin/ldconfig
210
6a2717dc
JB
211%post devel -p /sbin/postshell
212-/usr/sbin/fix-info-dir -c %{_infodir}
213
214%postun devel -p /sbin/postshell
215-/usr/sbin/fix-info-dir -c %{_infodir}
216
b26e6e51 217%files
218%defattr(644,root,root,755)
549f5ea9 219%doc devil-%{version}/{AUTHORS,CREDITS,ChangeLog,README.unix}
6a2717dc 220%attr(755,root,root) %{_bindir}/ilur
663a085f 221%attr(755,root,root) %{_libdir}/libIL.so.*.*.*
16a5e177 222%attr(755,root,root) %ghost %{_libdir}/libIL.so.1
663a085f 223%attr(755,root,root) %{_libdir}/libILU.so.*.*.*
16a5e177 224%attr(755,root,root) %ghost %{_libdir}/libILU.so.1
b26e6e51 225
226%files devel
227%defattr(644,root,root,755)
663a085f
JB
228%attr(755,root,root) %{_libdir}/libIL.so
229%attr(755,root,root) %{_libdir}/libILU.so
663a085f
JB
230%{_libdir}/libIL.la
231%{_libdir}/libILU.la
6a2717dc
JB
232%dir %{_includedir}/IL
233%{_includedir}/IL/il.h
234%{_includedir}/IL/ilu.h
235%{_includedir}/IL/ilu_region.h
236%{_pkgconfigdir}/IL.pc
237%{_pkgconfigdir}/ILU.pc
238%{_infodir}/DevIL_manual.info*
239
240%files static
241%defattr(644,root,root,755)
242%{_libdir}/libIL.a
243%{_libdir}/libILU.a
244
245%files ILUT
246%defattr(644,root,root,755)
247%attr(755,root,root) %{_libdir}/libILUT.so.*.*.*
248%attr(755,root,root) %ghost %{_libdir}/libILUT.so.1
249
250%files ILUT-devel
251%defattr(644,root,root,755)
252%attr(755,root,root) %{_libdir}/libILUT.so
253%{_includedir}/IL/devil_cpp_wrapper.hpp
254%{_includedir}/IL/ilut.h
663a085f 255%{_libdir}/libILUT.la
6a2717dc
JB
256%{_pkgconfigdir}/ILUT.pc
257
258%files ILUT-static
259%defattr(644,root,root,755)
260%{_libdir}/libILUT.a
b26e6e51 261
262%files doc
263%defattr(644,root,root,755)
f28788f8 264%doc DevIL*.pdf
This page took 0.13651 seconds and 4 git commands to generate.