]> git.pld-linux.org Git - packages/DenyHosts.git/commitdiff
- import
authorleafnode <leafnode@pld-linux.org>
Tue, 22 Feb 2005 12:01:28 +0000 (12:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    DenyHosts-kodos.patch -> 1.1
    DenyHosts.cfg -> 1.1
    DenyHosts.cron -> 1.1
    DenyHosts.spec -> 1.1

DenyHosts-kodos.patch [new file with mode: 0644]
DenyHosts.cfg [new file with mode: 0644]
DenyHosts.cron [new file with mode: 0644]
DenyHosts.spec [new file with mode: 0644]

diff --git a/DenyHosts-kodos.patch b/DenyHosts-kodos.patch
new file mode 100644 (file)
index 0000000..823f64f
--- /dev/null
@@ -0,0 +1,23 @@
+diff -uNr DenyHosts-0.5.5-org/setup.py DenyHosts-0.5.5/setup.py
+--- DenyHosts-0.5.5-org/setup.py       2005-02-13 04:26:49.000000000 +0100
++++ DenyHosts-0.5.5/setup.py   2005-02-22 12:44:10.155446912 +0100
+@@ -6,11 +6,6 @@
+ import sys
+ from glob import glob
+-
+-libpath = "/usr/share/kodos"
+-
+-
+-
+ #########################################################################
+ setup(name="DenyHosts",
+@@ -23,7 +18,6 @@
+       ##package_dir={'': 'modules'},
+       ##packages=['modules', "."],
+       license="GPL",
+-      extra_path='kodos',
+       long_description="""
+ DenyHosts is a python program that automatically blocks ssh attacks by adding entries to 
+ /etc/hosts.deny. DenyHosts will also inform Linux administrators about offending hosts, attacked 
diff --git a/DenyHosts.cfg b/DenyHosts.cfg
new file mode 100644 (file)
index 0000000..0695761
--- /dev/null
@@ -0,0 +1,84 @@
+
+########################################################################
+#
+# SECURE_LOG: the log file that contains sshd logging info
+# if you are not sure, grep "sshd:" /var/log/*
+#
+# The file to process can be overridden with the --file command line
+# argument
+#
+# Redhat:
+SECURE_LOG = /var/log/secure
+#
+# Mandrake: 
+#SECURE_LOG = /var/log/auth.log
+#
+# SuSE:
+#SECURE_LOG = /var/log/messages
+#
+########################################################################
+
+########################################################################
+# HOSTS_DENY: the file which contains restricted host access information
+#
+HOSTS_DENY = /etc/tcpd/hosts.deny
+#
+#######################################################################
+
+
+#######################################################################
+# BLOCK_SERVICE: the service name that should be blocked in HOSTS_DENY
+# 
+# man 5 host_access for details
+#
+#
+# To block all services for the offending host:
+#BLOCK_SERVICE = ALL
+# To block only sshd:
+BLOCK_SERVICE  = sshd   
+#
+#######################################################################
+
+#######################################################################
+#
+# DENY_THRESHOLD: block each host after the number of failed login 
+# attempts has exceeded this value.
+#
+DENY_THRESHOLD = 3
+#
+#######################################################################
+
+#######################################################################
+#
+# WORK_DIR: the path that DenyHosts will use for writing data to
+# (it will be created if it does not already exist).       
+WORK_DIR = denyhosts
+#
+#######################################################################
+
+
+
+       ############ THESE SETTINGS ARE OPTIONAL ############
+
+
+
+#######################################################################
+#
+# ADMIN_EMAIL: if you would like to receive emails regarding newly
+# restricted hosts and suspicious logins, set this address to 
+# match your email address.  If you do not want to receive these reports
+# leave this field blank (or run with the --noemail option)
+#
+ADMIN_EMAIL = root@localhost
+#
+#######################################################################
+
+#######################################################################
+#
+SMTP_HOST = localhost
+SMTP_PORT = 25
+SMTP_FROM = DenyHosts
+SMTP_SUBJECT = DenyHosts Report
+#
+#######################################################################
+
diff --git a/DenyHosts.cron b/DenyHosts.cron
new file mode 100644 (file)
index 0000000..9515151
--- /dev/null
@@ -0,0 +1 @@
+*/10 * * * * root python /usr/bin/denyhosts.py -c /etc/DenyHosts.cfg
diff --git a/DenyHosts.spec b/DenyHosts.spec
new file mode 100644 (file)
index 0000000..5d9ec6a
--- /dev/null
@@ -0,0 +1,67 @@
+#
+Summary:       Script to help thwart ssh server attacks.
+Summary(pl):   Skrypt do blokowania ataków na serwery SSH.
+Name:          DenyHosts
+Version:       0.5.5
+Release:       1
+License:       GPL
+Group:         Applications/System
+Source0:       http://dl.sourceforge.net/DenyHosts/%{name}-%{version}.tar.gz
+# Source0-md5: e5b49f8e949d3afd3bbd9d4611267dae
+Source1:       %{name}.cron
+Source2:       %{name}.cfg
+Patch0:                %{name}-kodos.patch
+URL:           http://denyhosts.sourceforge.net/
+BuildRequires: python
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+DenyHosts is a script intended to be run by Linux system
+administrators to help thwart ssh server attacks.
+
+If you've ever looked at your ssh log (/var/log/secure on Redhat,
+/var/log/auth.log on Mandrake, etc...) you may be alarmed to see how
+many hackers attempted to gain access to your server. Hopefully, none
+of them were successful (but then again, how would you know?).
+Wouldn't it be better to automatically prevent that attacker from
+continuing to gain entry into your system?
+
+%description -l pl
+DenyHosts jest skryptem dla administratorów systemów Linux, którego
+zadaniem jest odparcie ataków na serwery ssh.
+
+W logach ssh mo¿na znale¼æ wiele informacji o próbach uzyskania
+dostêpu do serwera poprzez us³ugê ssh. Dobrze jest zapobiec kolejnym
+próbom w³amiania przez odciêcie w³amywaczom dostêpu do serwera.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+
+echo 'VERSION="%{version}"' > version.py
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.d
+
+python setup.py install \
+       --root=$RPM_BUILD_ROOT \
+       --optimize=2
+
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/%{name}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README.txt
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.cfg
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cron.d/%{name}
+%attr(755,root,root) %{_bindir}/*
This page took 0.194276 seconds and 4 git commands to generate.