]> git.pld-linux.org Git - packages/DFB++.git/blobdiff - DFB++.spec
- updated to 1.0.0
[packages/DFB++.git] / DFB++.spec
index c07532e6e6010215b014b01cd4ba0eda0537ed38..ac795c4d743745ad27b630374f301d0d2097b497 100644 (file)
@@ -1,15 +1,19 @@
 Summary:       C++ binding for DirectFB
-Summary(pl):   Interfejs C++ do DirectFB
+Summary(pl.UTF-8):     Interfejs C++ do DirectFB
 Name:          DFB++
-Version:       0.9.12
+Version:       1.0.0
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://www.directfb.org/download/%{name}-%{version}.tar.gz
-URL:           http://www.directfb.org/
-BuildRequires: DirectFB-devel
-BuildRequires: autoconf
+Source0:       http://www.directfb.org/downloads/Extras/%{name}-%{version}.tar.gz
+# Source0-md5: c7d0b98bcc648a25ff11bfc74635f4ca
+URL:           http://www.directfb.org/index.php?path=Development/Projects/DFB++
+BuildRequires: DirectFB-devel >= 1:%{version}
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake
 BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 2:1.5
+BuildRequires: pkgconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -19,54 +23,61 @@ argument of every interface function. Another feature is the usage of
 exceptions. It's annoying having these error checking stuff with
 growing deinitialization stacks. Most functions are 'void'. As soon as
 a DirectFB function returns an error a DFBException is thrown.
-               
-%description -l pl
-DFB++ jest interfejsem C++ do biblioteki DirectFB, u³atwiaj±cym jej
-u¿ywanie. Jedn± z zalet jest brak konieczno¶ci przekazywania 'thiz'
-jako pierwszego parametru ka¿dej funkcji. Kolejn± jest korzystanie z
-wyj±tków. Ci±g³e sprawdzanie b³êdów z powiêkszaj±cym stosem
-deinicjalizacji mo¿e byæ dokuczliwe. W DFB++, kiedy funkcja DirectFB
-zwraca b³±d, rzucany jest wyj±tek DFBException.
+
+%description -l pl.UTF-8
+DFB++ jest interfejsem C++ do biblioteki DirectFB, ułatwiającym jej
+używanie. Jedną z zalet jest brak konieczności przekazywania 'thiz'
+jako pierwszego parametru każdej funkcji. Kolejną jest korzystanie z
+wyjątków. Ciągłe sprawdzanie błędów z powiększającym się stosem
+deinicjalizacji może być dokuczliwe. W DFB++, kiedy funkcja DirectFB
+zwraca błąd, rzucany jest wyjątek DFBException.
 
 %package devel
 Summary:       DFB++ header files
-Summary(pl):   Pliki nag³ówkowe DFB++
+Summary(pl.UTF-8):     Pliki nagłówkowe DFB++
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      DirectFB-devel >= 1:%{version}
+Requires:      libstdc++-devel
 
 %description devel
 Header files for DFB++ library.
 
-%description devel -l pl
-Pliki nag³ówkowe biblioteki DFB++.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki DFB++.
 
 %package static
 Summary:       DFB++ static library
-Summary(pl):   Statyczna biblioteka DFB++
+Summary(pl.UTF-8):     Statyczna biblioteka DFB++
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 DFB++ static library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna biblioteka DFB++.
 
 %prep
 %setup -q
 
 %build
+%{__libtoolize}
+%{__aclocal}
 %{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
        --enable-static
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 install examples/simple.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %clean
@@ -78,17 +89,19 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_bindir}/dfbshow
+%attr(755,root,root) %{_bindir}/dfbswitch
+%attr(755,root,root) %{_libdir}/libdfb++-*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%attr(755,root,root) %{_libdir}/lib*.la
 %attr(755,root,root) %{_bindir}/dfb++-config
+%attr(755,root,root) %{_libdir}/libdfb++.so
+%{_libdir}/libdfb++.la
 %{_includedir}/dfb++
 %{_pkgconfigdir}/*.pc
 %{_examplesdir}/%{name}-%{version}
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libdfb++.a
This page took 0.033991 seconds and 4 git commands to generate.