]> git.pld-linux.org Git - packages/DFB++.git/blob - DFB++.spec
- updated URL
[packages/DFB++.git] / DFB++.spec
1 Summary:        C++ binding for DirectFB
2 Summary(pl.UTF-8):      Interfejs C++ do DirectFB
3 Name:           DFB++
4 Version:        1.2.0
5 Release:        1
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://www.directfb.org/downloads/Extras/%{name}-%{version}.tar.gz
9 # Source0-md5:  80b94caff14e2e59be762cad8018e655
10 Patch0:         %{name}-types.patch
11 URL:            http://www.directfb.org/index.php?path=Projects/DFB%2B%2B
12 BuildRequires:  DirectFB-devel >= 1:%{version}
13 BuildRequires:  autoconf >= 2.52
14 BuildRequires:  automake
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRequires:  pkgconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 DFB++ is a C++ binding for DirectFB providing a much easier usage. One
22 advantage is that the 'thiz' doesn't need to be passed as the first
23 argument of every interface function. Another feature is the usage of
24 exceptions. It's annoying having these error checking stuff with
25 growing deinitialization stacks. Most functions are 'void'. As soon as
26 a DirectFB function returns an error a DFBException is thrown.
27
28 %description -l pl.UTF-8
29 DFB++ jest interfejsem C++ do biblioteki DirectFB, ułatwiającym jej
30 używanie. Jedną z zalet jest brak konieczności przekazywania 'thiz'
31 jako pierwszego parametru każdej funkcji. Kolejną jest korzystanie z
32 wyjątków. Ciągłe sprawdzanie błędów z powiększającym się stosem
33 deinicjalizacji może być dokuczliwe. W DFB++, kiedy funkcja DirectFB
34 zwraca błąd, rzucany jest wyjątek DFBException.
35
36 %package devel
37 Summary:        DFB++ header files
38 Summary(pl.UTF-8):      Pliki nagłówkowe DFB++
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       DirectFB-devel >= 1:%{version}
42 Requires:       libstdc++-devel
43
44 %description devel
45 Header files for DFB++ library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki DFB++.
49
50 %package static
51 Summary:        DFB++ static library
52 Summary(pl.UTF-8):      Statyczna biblioteka DFB++
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 DFB++ static library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka DFB++.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65
66 %build
67 %{__libtoolize}
68 %{__aclocal}
69 %{__autoconf}
70 %{__autoheader}
71 %{__automake}
72 %configure \
73         --enable-static
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 install examples/*.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS ChangeLog README
94 %attr(755,root,root) %{_bindir}/dfbshow
95 %attr(755,root,root) %{_bindir}/dfbswitch
96 %attr(755,root,root) %{_libdir}/libdfb++-1.2.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libdfb++-1.2.so.0
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_bindir}/dfb++-config
102 %attr(755,root,root) %{_libdir}/libdfb++.so
103 %{_libdir}/libdfb++.la
104 %{_includedir}/dfb++
105 %{_pkgconfigdir}/dfb++.pc
106 %{_examplesdir}/%{name}-%{version}
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libdfb++.a
This page took 0.054038 seconds and 3 git commands to generate.