]> git.pld-linux.org Git - packages/CuraEngine.git/blob - CuraEngine.spec
- pl, release 3 (rebuild with protobuf 3.6)
[packages/CuraEngine.git] / CuraEngine.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 Summary:        Engine for processing 3D models into G-code instructions for 3D printers
6 Summary(pl.UTF-8):      Silnik do przetwarzania modeli 3D na instrukcje G-code dla drukarek 3D
7 Name:           CuraEngine
8 Version:        2.5.0
9 Release:        3
10 Epoch:          1
11 License:        AGPL v3
12 Group:          Applications/Engineering
13 Source0:        https://github.com/Ultimaker/CuraEngine/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  8d8de8f56fd5831b3b74e8946a26681e
15 Patch0:         %{name}-rpath.patch
16 Patch1:         %{name}-static-libstdcpp.patch
17 Patch2:         %{name}-system-libs.patch
18 URL:            https://github.com/Ultimaker/CuraEngine
19 BuildRequires:  cmake
20 BuildRequires:  libArcus-devel = %{version}
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  polyclipping-devel >= 6.1.2
23 BuildRequires:  protobuf-devel
24 %{?with_tests:BuildRequires:  python}
25 BuildRequires:  rapidjson-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 CuraEngine is a C++ console application for 3D printing G-code
30 generation. It has been made as a better and faster alternative to the
31 old Skeinforge engine.
32
33 This is just a console application for G-code generation. For a full
34 graphical application look at cura with is the graphical frontend for
35 CuraEngine.
36
37 %description -l pl.UTF-8
38 CuraEngine to aplikacja konsolowa C++ do generowania intrukcji G-code
39 dla drukarek 3D. Powstała jako lepsza i szybsza alternatywa dla
40 starego silnika Skeinforge.
41
42 To jest tylko aplikacja konsolowa do generowania kodu. Pełna graficzna
43 aplikacja, będąca graficznym interfejsem do CuraEngine, znajduje się w
44 pakiecie cura.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49 %patch1 -p1
50 %patch2 -p1
51
52 # bundled libraries
53 rm -rf libs
54 %{__sed} -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h src/*.cpp
55
56 # The -DCURA_ENGINE_VERSION does not work, so we sed-change the default value
57 %{__sed} -i 's/"DEV"/"%{version}"/' src/settings/settings.h
58
59 %build
60 mkdir build
61 cd build
62 %cmake .. \
63         -DBUILD_SHARED_LIBS:BOOL=OFF \
64         -DCURA_ENGINE_VERSION:STRING=%{version}
65
66 %{__make}
67
68 %{?with_tests:%{__make} test}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} -C build install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc LICENSE README.md
82 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.093368 seconds and 3 git commands to generate.