]> git.pld-linux.org Git - packages/CuraEngine.git/blame - CuraEngine.spec
- pl, release 3 (rebuild with protobuf 3.6)
[packages/CuraEngine.git] / CuraEngine.spec
CommitLineData
880c7dcc
ER
1#
2# Conditional build:
3%bcond_with tests # build with tests
4
fd41772a 5Summary: Engine for processing 3D models into G-code instructions for 3D printers
4b3b0a44 6Summary(pl.UTF-8): Silnik do przetwarzania modeli 3D na instrukcje G-code dla drukarek 3D
fd41772a 7Name: CuraEngine
913bfb50 8Version: 2.5.0
4b3b0a44 9Release: 3
913bfb50 10Epoch: 1
4b3b0a44 11License: AGPL v3
fd41772a 12Group: Applications/Engineering
913bfb50
JR
13Source0: https://github.com/Ultimaker/CuraEngine/archive/%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: 8d8de8f56fd5831b3b74e8946a26681e
15Patch0: %{name}-rpath.patch
16Patch1: %{name}-static-libstdcpp.patch
17Patch2: %{name}-system-libs.patch
880c7dcc 18URL: https://github.com/Ultimaker/CuraEngine
913bfb50
JR
19BuildRequires: cmake
20BuildRequires: libArcus-devel = %{version}
880c7dcc 21BuildRequires: libstdc++-devel
fd41772a 22BuildRequires: polyclipping-devel >= 6.1.2
913bfb50 23BuildRequires: protobuf-devel
fd41772a 24%{?with_tests:BuildRequires: python}
913bfb50 25BuildRequires: rapidjson-devel
880c7dcc 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
fd41772a
AM
27
28%description
4b3b0a44 29CuraEngine is a C++ console application for 3D printing G-code
fd41772a
AM
30generation. It has been made as a better and faster alternative to the
31old Skeinforge engine.
32
33This is just a console application for G-code generation. For a full
34graphical application look at cura with is the graphical frontend for
4b3b0a44
JB
35CuraEngine.
36
37%description -l pl.UTF-8
38CuraEngine to aplikacja konsolowa C++ do generowania intrukcji G-code
39dla drukarek 3D. Powstała jako lepsza i szybsza alternatywa dla
40starego silnika Skeinforge.
41
42To jest tylko aplikacja konsolowa do generowania kodu. Pełna graficzna
43aplikacja, będąca graficznym interfejsem do CuraEngine, znajduje się w
44pakiecie cura.
fd41772a
AM
45
46%prep
47%setup -q
913bfb50
JR
48%patch0 -p1
49%patch1 -p1
50%patch2 -p1
fd41772a 51
913bfb50
JR
52# bundled libraries
53rm -rf libs
4b3b0a44 54%{__sed} -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h src/*.cpp
fd41772a 55
913bfb50 56# The -DCURA_ENGINE_VERSION does not work, so we sed-change the default value
4b3b0a44 57%{__sed} -i 's/"DEV"/"%{version}"/' src/settings/settings.h
fd41772a
AM
58
59%build
913bfb50
JR
60mkdir build
61cd build
4b3b0a44 62%cmake .. \
913bfb50
JR
63 -DBUILD_SHARED_LIBS:BOOL=OFF \
64 -DCURA_ENGINE_VERSION:STRING=%{version}
65
66%{__make}
fd41772a
AM
67
68%{?with_tests:%{__make} test}
69
70%install
71rm -rf $RPM_BUILD_ROOT
913bfb50
JR
72
73%{__make} -C build install \
74 DESTDIR=$RPM_BUILD_ROOT
fd41772a
AM
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
81%doc LICENSE README.md
82%attr(755,root,root) %{_bindir}/%{name}
This page took 0.122279 seconds and 4 git commands to generate.