]> git.pld-linux.org Git - packages/CuraEngine.git/blame - CuraEngine.spec
cleanups
[packages/CuraEngine.git] / CuraEngine.spec
CommitLineData
880c7dcc
ER
1#
2# Conditional build:
3%bcond_with tests # build with tests
4
fd41772a
AM
5Summary: Engine for processing 3D models into G-code instructions for 3D printers
6Name: CuraEngine
7Version: 15.04
8Release: 1
9License: AGPLv3
10Group: Applications/Engineering
fd41772a
AM
11Source0: https://github.com/Ultimaker/CuraEngine/archive/%{version}.tar.gz
12# Source0-md5: 75d34492ca18358aa554a56afb2de440
880c7dcc
ER
13URL: https://github.com/Ultimaker/CuraEngine
14BuildRequires: libstdc++-devel
fd41772a
AM
15BuildRequires: polyclipping-devel >= 6.1.2
16%{?with_tests:BuildRequires: python}
880c7dcc 17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
fd41772a
AM
18
19%description
20%{name} is a C++ console application for 3D printing G-code
21generation. It has been made as a better and faster alternative to the
22old Skeinforge engine.
23
24This is just a console application for G-code generation. For a full
25graphical application look at cura with is the graphical frontend for
26%{name}.
27
28%prep
29%setup -q
30
31# bundled clipper
880c7dcc 32rm -r clipper
fd41772a
AM
33sed -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h
34sed -i 's|-lclipper|-lpolyclipping|g' Makefile
35sed -i 's| $(BUILD_DIR)/libclipper.a||g' Makefile
36
37# allow redefinition of CFLAGS and do not build it static
38sed -i 's|CFLAGS +=|CFLAGS?=|' Makefile
39sed -i 's|--static||g' Makefile
40
41%build
42CXX="%{__cxx}" \
43CFLAGS="-I. -Ilibs -c %{rpmcflags} %{rpmcppflags} -std=c++11 -fomit-frame-pointer" \
44 %{__make}
45
46%{?with_tests:%{__make} test}
47
48%install
49rm -rf $RPM_BUILD_ROOT
880c7dcc
ER
50install -d $RPM_BUILD_ROOT%{_bindir}/%{name}
51install -p build/%{name} $RPM_BUILD_ROOT%{_bindir}
fd41772a
AM
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%doc LICENSE README.md
59%attr(755,root,root) %{_bindir}/%{name}
This page took 0.091087 seconds and 4 git commands to generate.