]> git.pld-linux.org Git - packages/Collage.git/blame - Collage.spec
boost rebuild
[packages/Collage.git] / Collage.spec
CommitLineData
262ad267
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
59a55be8 4
262ad267
JB
5Summary: Cross-platform C++ network library
6Summary(pl.UTF-8): Wieloplatformowa biblioteka sieciowa dla C++
7Name: Collage
44e57821 8Version: 1.7.0
367897a8 9Release: 8
262ad267
JB
10License: LGPL v2.1
11Group: Libraries
44e57821 12#Source0Download: https://github.com/Eyescale/Collage/releases
262ad267 13Source0: https://github.com/Eyescale/Collage/archive/%{version}/%{name}-%{version}.tar.gz
44e57821 14# Source0-md5: f0e57c1a2f6196c11ad8ac6029483e56
ced5b5c1 15Patch0: boost-1.61.patch
61f14322 16Patch1: %{name}-boost.patch
6d279807 17Patch2: includes.patch
262ad267 18URL: http://libcollage.net/
44e57821
JB
19BuildRequires: Lunchbox-devel >= 1.16.0
20BuildRequires: Eyescale-CMake >= 2017.05
21BuildRequires: Pression-devel >= 2.0.0
22BuildRequires: Servus-devel >= 1.5.1
262ad267 23BuildRequires: boost-devel >= 1.41.0
44e57821 24BuildRequires: cmake >= 3.1
262ad267
JB
25%{?with_apidocs:BuildRequires: doxygen}
26BuildRequires: libibverbs-devel
27BuildRequires: librdmacm-devel
28BuildRequires: libstdc++-devel
29BuildRequires: pkgconfig
54e13fd9 30BuildRequires: rpm-build >= 4.6
93cca369 31BuildRequires: rpmbuild(macros) >= 1.605
262ad267 32BuildRequires: udt-devel
44e57821
JB
33Requires: Lunchbox >= 1.16.0
34Requires: Pression >= 2.0.0
35Requires: Servus >= 1.5.1
262ad267
JB
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Collage is a cross-platform C++ library for building heterogenous,
40distributed applications. Among other things, it is the cluster
41backend for the Equalizer parallel rendering framework. Collage
42provides an abstraction of different network connections, peer-to-peer
43messaging, node discovery, synchronization and high-performance,
44object-oriented, versioned data distribution. Collage is designed for
45low-overhead multi-threaded execution which allows applications to
46easily exploit multi-core architectures.
47
48%description -l pl.UTF-8
49Collage to wieloplatformowa biblioteka C++ do tworzenia
50heterogenicznych, rozproszonych aplikacji. Jest to między innymi
51backend klastrowy dla szkieletu równoległego renderowania Equalizer.
52Zapewnia abstrakcję różnych połączeń sieciowych, przesyłania
53komunikatów między węzłami, wykrywanie węzłów, synchronizację oraz
54wydajne, zorientowane obiektowo i wersjonowane rozproszenie danych.
55Collage został zaprojektowany pod kątem lekkiej wielowątkowości, co
56pozwala aplikacjom łatwo wykorzystywać architektury wielordzeniowe.
57
58%package devel
59Summary: Header files for Collage library
60Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Collage
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
44e57821
JB
63Requires: Lunchbox-devel >= 1.16.0
64Requires: Pression-devel >= 2.0.0
65Requires: Servus-devel >= 1.5.1
66Requires: boost-devel >= 1.41.0
262ad267
JB
67
68%description devel
69Header files for Collage library.
70
71%description devel -l pl.UTF-8
72Pliki nagłówkowe biblioteki Collage.
73
74%package apidocs
75Summary: Collage API documentation
76Summary(pl.UTF-8): Dokumentacja API biblioteki Collage
77Group: Documentation
59a55be8 78BuildArch: noarch
262ad267
JB
79
80%description apidocs
81API documentation for Collage library.
82
83%description apidocs -l pl.UTF-8
84Dokumentacja API biblioteki Collage.
85
86%prep
ced5b5c1
JR
87%setup -q
88%patch0 -p1
61f14322 89%patch1 -p1
6d279807 90%patch2 -p1
262ad267 91
44e57821 92rmdir CMake/common
ced5b5c1 93ln -s %{_datadir}/Eyescale-CMake CMake/common
262ad267
JB
94
95%build
96install -d build
97cd build
98%cmake .. \
0f6053fd
JP
99 -DBUILDYARD_DISABLED=ON \
100 -DCOMMON_DISABLE_WERROR=ON
262ad267
JB
101%{__make}
102
103%if %{with apidocs}
104doxygen doc/Doxyfile
105%endif
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} -C build install \
111 DESTDIR=$RPM_BUILD_ROOT
112
113%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Collage/{doc,tests}
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120
121%files
122%defattr(644,root,root,755)
ced5b5c1 123%doc LICENSE.txt README.md doc/{README.IB,README.udt} doc/Changelog.md
262ad267
JB
124%attr(755,root,root) %{_bindir}/coNetperf
125%attr(755,root,root) %{_bindir}/coNodeperf
126%attr(755,root,root) %{_bindir}/coObjectperf
127%attr(755,root,root) %{_libdir}/libCollage.so.*.*.*
44e57821 128%attr(755,root,root) %ghost %{_libdir}/libCollage.so.7
262ad267
JB
129
130%files devel
131%defattr(644,root,root,755)
132%attr(755,root,root) %{_libdir}/libCollage.so
133%{_includedir}/co
262ad267
JB
134%dir %{_datadir}/Collage
135%{_datadir}/Collage/CMake
136
137%if %{with apidocs}
138%files apidocs
139%defattr(644,root,root,755)
140%doc build/doc/html/*
141%endif
This page took 0.241134 seconds and 4 git commands to generate.