]> git.pld-linux.org Git - packages/CoinUtils.git/blob - CoinUtils.spec
- unconditional noarch subpackages
[packages/CoinUtils.git] / CoinUtils.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        COIN-OR Utilities library
7 Summary(pl.UTF-8):      Biblioteka narzędziowa COIN-OR Utilities
8 Name:           CoinUtils
9 Version:        2.9.17
10 Release:        4
11 License:        Eclipse Public License v1.0
12 Group:          Libraries
13 Source0:        http://www.coin-or.org/download/source/CoinUtils/%{name}-%{version}.tgz
14 # Source0-md5:  e91ff822dc535055968094d88bcaabce
15 Patch0:         %{name}-format.patch
16 Patch1:         %{name}-destdir.patch
17 URL:            https://projects.coin-or.org/CoinUtils
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  blas-devel
21 BuildRequires:  bzip2-devel
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  lapack-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:1.5
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 CoinUtils (Coin-or Utilities) is an open-source collection of classes
31 and functions that are generally useful to more than one COIN-OR
32 project. These utilities include:
33  - Vector classes
34  - Matrix classes
35  - MPS file reading
36  - Comparing floating point numbers with a tolerance
37
38 %description -l pl.UTF-8
39 CoinUtils (Coin-or Utilities) to mający otwarte źródła zbiór klas i
40 funkcji ogólnie przydatnych dla więcej niż jednego projektu COIN-OR.
41 Narzędzia Coin-or zawirają:
42  - klasy wektorów
43  - klasy macierzy
44  - odczyt plików MPS
45  - porównywanie liczb zmiennoprzecinkowych z określoną dokładnością
46
47 %package devel
48 Summary:        Header files for CoinUtils library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CoinUtils
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       blas-devel
53 Requires:       bzip2-devel
54 Requires:       lapack-devel
55 Requires:       libstdc++-devel
56 Requires:       zlib-devel
57
58 %description devel
59 Header files for CoinUtils library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki CoinUtils.
63
64 %package static
65 Summary:        Static CoinUtils library
66 Summary(pl.UTF-8):      Statyczna biblioteka CoinUtils
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static CoinUtils library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka CoinUtils.
75
76 %package apidocs
77 Summary:        CoinUtils API documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki CoinUtils
79 Group:          Documentation
80 %if "%{_rpmversion}" >= "5"
81 BuildArch:      noarch
82 %endif
83
84 %description apidocs
85 API documentation for CoinUtils library.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki CoinUtils.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94
95 ln -s ../BuildTools CoinUtils/BuildTools
96
97 %build
98 cd CoinUtils
99 %{__libtoolize}
100 %{__aclocal} -I BuildTools
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 cd ..
105 %configure \
106         PKG_CONFIG_PATH="%{_pkgconfigdir}" \
107         --enable-dependency-linking \
108         %{?with_static_libs:--enable-static}
109 %{__make}
110
111 %if %{with apidocs}
112 %{__make} doxydoc
113 %endif
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 # obsoleted by pkg-config
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libCoinUtils.la
123 # packages as %doc
124 %{__rm} $RPM_BUILD_ROOT%{_datadir}/coin/doc/CoinUtils/{AUTHORS,LICENSE,README}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc CoinUtils/{AUTHORS,LICENSE,README}
135 %attr(755,root,root) %{_libdir}/libCoinUtils.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libCoinUtils.so.3
137 %dir %{_datadir}/coin
138 %{_datadir}/coin/Data
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libCoinUtils.so
143 %dir %{_includedir}/coin
144 %{_includedir}/coin/CoinUtilsConfig.h
145 %{_includedir}/coin/Coin_C_defines.h
146 %{_includedir}/coin/Coin*.hpp
147 %{_pkgconfigdir}/coindatasample.pc
148 %{_pkgconfigdir}/coinutils.pc
149 %dir %{_datadir}/coin/doc
150 %dir %{_datadir}/coin/doc/CoinUtils
151 %{_datadir}/coin/doc/CoinUtils/coinutils_addlibs.txt
152
153 %if %{with static_libs}
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libCoinUtils.a
157 %endif
158
159 %if %{with apidocs}
160 %files apidocs
161 %defattr(644,root,root,755)
162 %doc doxydoc/html/*
163 %endif
This page took 0.098571 seconds and 3 git commands to generate.