]> git.pld-linux.org Git - packages/Coin.git/blob - Coin.spec
BR automake for _aclocaldir macro
[packages/Coin.git] / Coin.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        High-level, retained-mode toolkit for effective 3D graphics development
6 Summary(pl.UTF-8):      Wysokopoziomowy toolkit do efektywnego rozwijania grafiki 3D
7 Name:           Coin
8 Version:        3.1.3
9 Release:        2
10 License:        GPL or Coin PEL or Coin EL
11 Group:          X11/Libraries
12 Source0:        https://bitbucket.org/Coin3D/coin/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  1538682f8d92cdf03e845c786879fbea
14 Patch0:         %{name}-build.patch
15 Patch1:         %{name}-pc.patch
16 Patch2:         %{name}-format.patch
17 URL:            http://www.coin3d.org/
18 BuildRequires:  OpenAL-devel
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  automake
22 BuildRequires:  bzip2-devel
23 BuildRequires:  fontconfig-devel
24 BuildRequires:  freetype-devel >= 2
25 #BuildRequires: js-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  xorg-lib-libX11-devel
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 High-level, retained-mode toolkit for effective 3D graphics
33 development. It's fully compatible with SGI Open Inventor 2.1.
34
35 %description -l pl.UTF-8
36 Wysokopoziomowy toolkit trybu przechowującego do efektywnego
37 rozwijania grafiki 3D. Jest w pełni kompatybilny z pakietem SGI Open
38 Inventor 2.1.
39
40 %package devel
41 Summary:        Header files for Coin3D library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Coin3D
43 Group:          X11/Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Obsoletes:      openinventor-devel
46 Obsoletes:      sgi-OpenInventor-devel
47
48 %description devel
49 Header files for Coin3D library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki Coin3D.
53
54 %package static
55 Summary:        Static Coin3D library
56 Summary(pl.UTF-8):      Statyczna biblioteka Coin3D
57 Group:          X11/Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static Coin3D library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka Coin3D.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71
72 %build
73 # must include COIN_INTERNAL and COIN_DEBUG in CFLAGS/CXXFLAGS, because
74 # internal CPPFLAGS are not propagated everywhere
75 CFLAGS="%{rpmcflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
76 CXXFLAGS="%{rpmcxxflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
77 %configure \
78         --enable-3ds-import \
79         --disable-debug \
80         --enable-java-wrapper \
81         --enable-man \
82         %{?with_static_libs:--enable-static} \
83         --enable-system-expat \
84         --enable-threadsafe
85
86 # FIXME: don't use global LIBS to fix libCoin.la linking
87 # (but cannot regenerate ac/am because of missing m4 files)
88 %{__make} \
89         LIBS="-ldl -lGL -lX11 -lpthread"
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 # sanitize file list
95 %{__sed} -i -ne '/^S/p' man/man3/filelist.txt
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 # obsoleted by pkg-config
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libCoin.la
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS COPYING ChangeLog FAQ FAQ.legal NEWS README README.UNIX RELNOTES THANKS
112 %attr(755,root,root) %{_libdir}/libCoin.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libCoin.so.60
114 %{_datadir}/%{name}
115 %exclude %{_datadir}/%{name}/conf/coin-default.cfg
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libCoin.so
120 %attr(755,root,root) %{_bindir}/coin-config
121 %{_datadir}/%{name}/conf/coin-default.cfg
122 %dir %{_includedir}/Inventor
123 %{_includedir}/Inventor/C
124 %{_includedir}/Inventor/VRMLnodes
125 %{_includedir}/Inventor/actions
126 %{_includedir}/Inventor/annex
127 %{_includedir}/Inventor/bundles
128 %{_includedir}/Inventor/caches
129 %{_includedir}/Inventor/collision
130 %{_includedir}/Inventor/details
131 %{_includedir}/Inventor/draggers
132 %{_includedir}/Inventor/elements
133 %{_includedir}/Inventor/engines
134 %{_includedir}/Inventor/errors
135 %{_includedir}/Inventor/events
136 %{_includedir}/Inventor/fields
137 %{_includedir}/Inventor/lists
138 %{_includedir}/Inventor/lock
139 %{_includedir}/Inventor/manips
140 %{_includedir}/Inventor/misc
141 %{_includedir}/Inventor/nodekits
142 %{_includedir}/Inventor/nodes
143 %{_includedir}/Inventor/projectors
144 %{_includedir}/Inventor/scxml
145 %{_includedir}/Inventor/sensors
146 %{_includedir}/Inventor/system
147 %{_includedir}/Inventor/threads
148 %{_includedir}/Inventor/tools
149 %{_includedir}/Inventor/Sb*.h
150 %{_includedir}/Inventor/So*.h
151 %{_includedir}/Inventor/non_winsys.h
152 %{_includedir}/Inventor/oivwin32.h
153 %{_includedir}/SoDebug.h
154 %{_includedir}/SoWinEnterScope.h
155 %{_includedir}/SoWinLeaveScope.h
156 %{_pkgconfigdir}/Coin.pc
157 %{_aclocaldir}/coin.m4
158 %{_mandir}/man1/coin-config.1*
159 %{_mandir}/man3/Sb*.3*
160 %{_mandir}/man3/Sc*.3*
161 %{_mandir}/man3/So*.3*
162
163 %if %{with static_libs}
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libCoin.a
167 %endif
This page took 0.096064 seconds and 3 git commands to generate.