]> git.pld-linux.org Git - packages/Coin.git/blob - Coin.spec
ad4328a73d5e3bc1733f3db3236e3e814b65bcd3
[packages/Coin.git] / Coin.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        High-level, retained-mode toolkit for effective 3D graphics development
6 Summary(pl.UTF-8):      Wysokopoziomowy toolkit do efektywnego rozwijania grafiki 3D
7 Name:           Coin
8 Version:        3.1.3
9 Release:        2
10 License:        GPL or Coin PEL or Coin EL
11 Group:          X11/Libraries
12 Source0:        https://bitbucket.org/Coin3D/coin/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  1538682f8d92cdf03e845c786879fbea
14 Patch0:         %{name}-build.patch
15 Patch1:         %{name}-pc.patch
16 Patch2:         %{name}-format.patch
17 URL:            http://www.coin3d.org/
18 BuildRequires:  OpenAL-devel
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  bzip2-devel
22 BuildRequires:  fontconfig-devel
23 BuildRequires:  freetype-devel >= 2
24 #BuildRequires: js-devel
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  xorg-lib-libX11-devel
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 High-level, retained-mode toolkit for effective 3D graphics
32 development. It's fully compatible with SGI Open Inventor 2.1.
33
34 %description -l pl.UTF-8
35 Wysokopoziomowy toolkit trybu przechowującego do efektywnego
36 rozwijania grafiki 3D. Jest w pełni kompatybilny z pakietem SGI Open
37 Inventor 2.1.
38
39 %package devel
40 Summary:        Header files for Coin3D library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Coin3D
42 Group:          X11/Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Obsoletes:      openinventor-devel
45 Obsoletes:      sgi-OpenInventor-devel
46
47 %description devel
48 Header files for Coin3D library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki Coin3D.
52
53 %package static
54 Summary:        Static Coin3D library
55 Summary(pl.UTF-8):      Statyczna biblioteka Coin3D
56 Group:          X11/Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static Coin3D library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka Coin3D.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70
71 %build
72 # must include COIN_INTERNAL and COIN_DEBUG in CFLAGS/CXXFLAGS, because
73 # internal CPPFLAGS are not propagated everywhere
74 CFLAGS="%{rpmcflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
75 CXXFLAGS="%{rpmcxxflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
76 %configure \
77         --enable-3ds-import \
78         --disable-debug \
79         --enable-java-wrapper \
80         --enable-man \
81         %{?with_static_libs:--enable-static} \
82         --enable-system-expat \
83         --enable-threadsafe
84
85 # FIXME: don't use global LIBS to fix libCoin.la linking
86 # (but cannot regenerate ac/am because of missing m4 files)
87 %{__make} \
88         LIBS="-ldl -lGL -lX11 -lpthread"
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 # sanitize file list
94 %{__sed} -i -ne '/^S/p' man/man3/filelist.txt
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libCoin.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS COPYING ChangeLog FAQ FAQ.legal NEWS README README.UNIX RELNOTES THANKS
111 %attr(755,root,root) %{_libdir}/libCoin.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libCoin.so.60
113 %{_datadir}/%{name}
114 %exclude %{_datadir}/%{name}/conf/coin-default.cfg
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libCoin.so
119 %attr(755,root,root) %{_bindir}/coin-config
120 %{_datadir}/%{name}/conf/coin-default.cfg
121 %dir %{_includedir}/Inventor
122 %{_includedir}/Inventor/C
123 %{_includedir}/Inventor/VRMLnodes
124 %{_includedir}/Inventor/actions
125 %{_includedir}/Inventor/annex
126 %{_includedir}/Inventor/bundles
127 %{_includedir}/Inventor/caches
128 %{_includedir}/Inventor/collision
129 %{_includedir}/Inventor/details
130 %{_includedir}/Inventor/draggers
131 %{_includedir}/Inventor/elements
132 %{_includedir}/Inventor/engines
133 %{_includedir}/Inventor/errors
134 %{_includedir}/Inventor/events
135 %{_includedir}/Inventor/fields
136 %{_includedir}/Inventor/lists
137 %{_includedir}/Inventor/lock
138 %{_includedir}/Inventor/manips
139 %{_includedir}/Inventor/misc
140 %{_includedir}/Inventor/nodekits
141 %{_includedir}/Inventor/nodes
142 %{_includedir}/Inventor/projectors
143 %{_includedir}/Inventor/scxml
144 %{_includedir}/Inventor/sensors
145 %{_includedir}/Inventor/system
146 %{_includedir}/Inventor/threads
147 %{_includedir}/Inventor/tools
148 %{_includedir}/Inventor/Sb*.h
149 %{_includedir}/Inventor/So*.h
150 %{_includedir}/Inventor/non_winsys.h
151 %{_includedir}/Inventor/oivwin32.h
152 %{_includedir}/SoDebug.h
153 %{_includedir}/SoWinEnterScope.h
154 %{_includedir}/SoWinLeaveScope.h
155 %{_pkgconfigdir}/Coin.pc
156 %{_aclocaldir}/coin.m4
157 %{_mandir}/man1/coin-config.1*
158 %{_mandir}/man3/Sb*.3*
159 %{_mandir}/man3/Sc*.3*
160 %{_mandir}/man3/So*.3*
161
162 %if %{with static_libs}
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/libCoin.a
166 %endif
This page took 0.096429 seconds and 2 git commands to generate.