]> git.pld-linux.org Git - packages/Coin.git/blob - Coin.spec
795a790e637b38f21fc03353552dc67fb491a9d7
[packages/Coin.git] / Coin.spec
1 # TODO: 
2 #       Make it build :( 
3
4 # Conditional build:
5 %bcond_with     tests           # build with tests
6 %bcond_without  tests           # build without tests
7 #
8 ######          Unknown group!
9 Summary:        High-level, retained-mode toolkit for effective 3D graphics development
10 Summary(pl.UTF-8):      Zbiór narzędzi wysokiego poziomu do efektywnego rozwijania grafiki 3D.
11 Name:           Coin
12 Version:        3.1.3
13 Release:        0.1
14 License:        GPL
15 Group:          Productivity/Other
16 # http://ftp.coin3d.org/coin/src/all/Coin-3.1.3.tar.gz
17 Source0:        http://ftp.coin3d.org/coin/src/all/%{name}-%{version}.tar.gz
18 # Source0-md5:  1538682f8d92cdf03e845c786879fbea
19 #Source1:       -
20 # Source1-md5:  -
21 URL:            http://www.coin3d.org/
22 #Patch0: %{name}-DESTDIR.patch
23 %if %{with initscript}
24 BuildRequires:  rpmbuild(macros) >= 1.228
25 Requires(post,preun):   /sbin/chkconfig
26 Requires:       rc-scripts
27 %endif
28 #BuildRequires: -
29 #BuildRequires: autoconf
30 #BuildRequires: automake
31 #BuildRequires: intltool
32 #BuildRequires: libtool
33 #Requires(postun):      -
34 #Requires(pre,post):    -
35 #Requires(preun):       -
36 #Requires:      -
37 #Provides:      -
38 #Provides:      group(foo)
39 #Provides:      user(foo)
40 #Obsoletes:     -
41 #Conflicts:     -
42 #BuildArch:     noarch
43 #ExclusiveArch: %{ix86}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47
48 %description -l pl.UTF-8
49
50 %package subpackage
51 ######          Unknown group!
52 Summary:        -
53 Summary(pl.UTF-8):      -
54 Group:          -
55
56 %description subpackage
57
58 %description subpackage -l pl.UTF-8
59
60 %package libs
61 Summary:        -
62 Summary(pl.UTF-8):      -
63 Group:          Libraries
64
65 %description libs
66
67 %description libs -l pl.UTF-8
68
69 %package devel
70 Summary:        Header files for ... library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ...
72 Group:          Development/Libraries
73 # if base package contains shared library for which these headers are
74 #Requires:      %{name} = %{version}-%{release}
75 # if -libs package contains shared library for which these headers are
76 #Requires:      %{name}-libs = %{version}-%{release}
77
78 %description devel
79 Header files for ... library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki ....
83
84 %package static
85 Summary:        Static ... library
86 Summary(pl.UTF-8):      Statyczna biblioteka ...
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static ... library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka ....
95
96 %prep
97 %setup -q
98 #%setup -q -c -T
99 #%setup -q -n %{name}
100 #%setup -q -n %{name}-%{version}.orig -a 1
101 #%patch0 -p1
102
103 # undos the source
104 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
105
106 # remove CVS control files
107 #find -name CVS -print0 | xargs -0 rm -rf
108
109 # you'll need this if you cp -a complete dir in source
110 # cleanup backups after patching
111 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
112
113 %build
114 # if ac/am/* rebuilding is necessary, do it in this order and add
115 # appropriate BuildRequires
116 #%%{__intltoolize}
117 #%%{__gettextize}
118 #%%{__libtoolize}
119 #%%{__aclocal}
120 #%%{__autoconf}
121 #%%{__autoheader}
122 #%%{__automake}
123 # if not running libtool or automake, but config.sub is too old:
124 # cp -f /usr/share/automake/config.sub .
125 %configure \
126           --enable-system-expat
127
128 %{__make}
129
130 #%{__make} \
131 #       CFLAGS="%{rpmcflags}" \
132 #       LDFLAGS="%{rpmldflags}"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 # create directories if necessary
137 #install -d $RPM_BUILD_ROOT
138 %if %{with initscript}
139 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
140 %endif
141 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %pre
150 %groupadd -g xxx %{name}
151 %useradd -u xxx -d /var/lib/%{name} -g %{name} -c "XXX User" %{name}
152
153 %post
154
155 %preun
156
157 %postun
158 if [ "$1" = "0" ]; then
159         %userremove %{name}
160         %groupremove %{name}
161 fi
162
163 %if %{with ldconfig}
164 %post   -p /sbin/ldconfig
165 %postun -p /sbin/ldconfig
166 %endif
167
168 %if %{with initscript}
169 %post init
170 /sbin/chkconfig --add %{name}
171 %service %{name} restart
172
173 %preun init
174 if [ "$1" = "0" ]; then
175         %service -q %{name} stop
176         /sbin/chkconfig --del %{name}
177 fi
178 %endif
179
180 %files
181 %defattr(644,root,root,755)
182 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
183
184 %if 0
185 # if _sysconfdir != %{_sysconfdir}:
186 #%%dir %{_sysconfdir}
187 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
188 %attr(755,root,root) %{_bindir}/*
189 %{_datadir}/%{name}
190 %endif
191
192 # initscript and its config
193 %if %{with initscript}
194 %attr(754,root,root) /etc/rc.d/init.d/%{name}
195 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
196 %endif
197
198 #%{_examplesdir}/%{name}-%{version}
199
200 %if %{with subpackage}
201 %files subpackage
202 %defattr(644,root,root,755)
203 #%doc extras/*.gz
204 #%{_datadir}/%{name}-ext
205 %endif
This page took 0.056554 seconds and 2 git commands to generate.