]> git.pld-linux.org Git - packages/Coin.git/blob - Coin.spec
- added build patch (misc compile fixes)
[packages/Coin.git] / Coin.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        High-level, retained-mode toolkit for effective 3D graphics development
6 Summary(pl.UTF-8):      Wysokopoziomowy toolkit do efektywnego rozwijania grafiki 3D
7 Name:           Coin
8 Version:        3.1.3
9 Release:        1
10 License:        GPL or Coin PEL or Coin EL
11 Group:          X11/Libraries
12 Source0:        https://bitbucket.org/Coin3D/coin/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  1538682f8d92cdf03e845c786879fbea
14 Patch0:         %{name}-build.patch
15 Patch1:         %{name}-pc.patch
16 Patch2:         %{name}-format.patch
17 URL:            http://www.coin3d.org/
18 BuildRequires:  OpenAL-devel
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  bzip2-devel
22 BuildRequires:  fontconfig-devel
23 BuildRequires:  freetype-devel >= 2
24 #BuildRequires: js-devel
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  xorg-lib-libX11-devel
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 #define specflags -DCOIN_INTERNAL -DCOIN_DEBUG=0
31
32 %description
33 High-level, retained-mode toolkit for effective 3D graphics
34 development. It's fully compatible with SGI Open Inventor 2.1.
35
36 %description -l pl.UTF-8
37 Wysokopoziomowy toolkit trybu przechowującego do efektywnego
38 rozwijania grafiki 3D. Jest w pełni kompatybilny z pakietem SGI Open
39 Inventor 2.1.
40
41 %package devel
42 Summary:        Header files for Coin3D library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Coin3D
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for Coin3D library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki Coin3D.
52
53 %package static
54 Summary:        Static Coin3D library
55 Summary(pl.UTF-8):      Statyczna biblioteka Coin3D
56 Group:          X11/Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static Coin3D library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka Coin3D.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70
71 %build
72 # must include COIN_INTERNAL and COIN_DEBUG in CFLAGS/CXXFLAGS, because
73 # internal CPPFLAGS are not propagated everywhere
74 CFLAGS="%{rpmcflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
75 CXXFLAGS="%{rpmcxxflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
76 %configure \
77         --enable-3ds-import \
78         --disable-debug \
79         --enable-java-wrapper \
80         --enable-man \
81         %{?with_static_libs:--enable-static} \
82         --enable-system-expat \
83         --enable-threadsafe
84
85 # FIXME: don't use global LIBS to fix libCoin.la linking
86 # (but cannot regenerate ac/am because of missing m4 files)
87 %{__make} \
88         LIBS="-ldl -lGL -lX11 -lpthread"
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 # sanitize file list
94 %{__sed} -i -ne '/^S/p' man/man3/filelist.txt
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libCoin.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS COPYING ChangeLog FAQ FAQ.legal NEWS README README.UNIX RELNOTES THANKS
111 %attr(755,root,root) %{_bindir}/coin-config
112 %attr(755,root,root) %{_libdir}/libCoin.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libCoin.so.60
114 %{_datadir}/%{name}
115 %{_mandir}/man1/coin-config.1*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libCoin.so
120 %dir %{_includedir}/Inventor
121 %{_includedir}/Inventor/C
122 %{_includedir}/Inventor/VRMLnodes
123 %{_includedir}/Inventor/actions
124 %{_includedir}/Inventor/annex
125 %{_includedir}/Inventor/bundles
126 %{_includedir}/Inventor/caches
127 %{_includedir}/Inventor/collision
128 %{_includedir}/Inventor/details
129 %{_includedir}/Inventor/draggers
130 %{_includedir}/Inventor/elements
131 %{_includedir}/Inventor/engines
132 %{_includedir}/Inventor/errors
133 %{_includedir}/Inventor/events
134 %{_includedir}/Inventor/fields
135 %{_includedir}/Inventor/lists
136 %{_includedir}/Inventor/lock
137 %{_includedir}/Inventor/manips
138 %{_includedir}/Inventor/misc
139 %{_includedir}/Inventor/nodekits
140 %{_includedir}/Inventor/nodes
141 %{_includedir}/Inventor/projectors
142 %{_includedir}/Inventor/scxml
143 %{_includedir}/Inventor/sensors
144 %{_includedir}/Inventor/system
145 %{_includedir}/Inventor/threads
146 %{_includedir}/Inventor/tools
147 %{_includedir}/Inventor/Sb*.h
148 %{_includedir}/Inventor/So*.h
149 %{_includedir}/Inventor/non_winsys.h
150 %{_includedir}/Inventor/oivwin32.h
151 %{_includedir}/SoDebug.h
152 %{_includedir}/SoWinEnterScope.h
153 %{_includedir}/SoWinLeaveScope.h
154 %{_pkgconfigdir}/Coin.pc
155 %{_aclocaldir}/coin.m4
156 %{_mandir}/man3/Sb*.3*
157 %{_mandir}/man3/Sc*.3*
158 %{_mandir}/man3/So*.3*
159
160 %if %{with static_libs}
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/libCoin.a
164 %endif
This page took 0.06137 seconds and 3 git commands to generate.